]> git.pld-linux.org Git - packages/apache-mod_python.git/blobdiff - apache-mod_python.spec
- release 14 (by relup.sh)
[packages/apache-mod_python.git] / apache-mod_python.spec
index 10b537421d51f64063b68c5b2ada448b1e35017e..1599a789622e2dd4ab7d9c4e980e085dd3e3dc64 100644 (file)
@@ -20,7 +20,7 @@ Summary(pl.UTF-8):    Wbudowany interpreter języka Python dla serwera WWW Apache
 Summary(sv.UTF-8):     En inbyggd Python-interpretator för webbservern Apache
 Name:          apache-mod_%{mod_name}
 Version:       3.5.0
-Release:       2
+Release:       14
 License:       Apache
 Group:         Networking/Daemons/HTTP
 Source0:       http://dist.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
@@ -29,6 +29,7 @@ Source1:      %{name}.conf
 Source2:       %{name}3.conf
 Patch0:                %{name}-httpd-not-needed.patch
 Patch1:                no-git.patch
+Patch2:                set-request-response-status.patch
 URL:           http://www.modpython.org/
 BuildRequires: apache-devel >= 2.0.52-7
 BuildRequires: apr-devel >= 1:1.0.0
@@ -36,7 +37,7 @@ BuildRequires:        autoconf
 BuildRequires: automake
 BuildRequires: flex >= 2.5.31
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: rpmbuild(macros) >= 1.671
 %if %{with python2}
 BuildRequires: python
 BuildRequires: python-devel >= 2.6
@@ -45,11 +46,14 @@ BuildRequires:      python-devel >= 2.6
 BuildRequires: python3
 BuildRequires: python3-devel >= 3.3
 %endif
+Requires(post,preun,postun):   systemd-units >= 38
+Requires:      rc-scripts
 Requires:      apache(modules-api) = %apache_modules_api
 Requires:      apr >= 1:1.0.0
 # apache.py uses pdb module
 Requires:      python-devel-tools
 %requires_eq   python-libs
+Requires:      systemd-units >= 38
 Conflicts:     apache-mod_python3
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -142,11 +146,14 @@ Summary(ja.UTF-8):        Apache Web サーバー用の組込み Python 3 インター
 Summary(pl.UTF-8):     Wbudowany interpreter języka Python 3 dla serwera WWW Apache
 Summary(sv.UTF-8):     En inbyggd Python3-interpretator för webbservern Apache
 Group:         Networking/Daemons/HTTP
+Requires(post,preun,postun):   systemd-units >= 38
+Requires:      rc-scripts
 Requires:      apache(modules-api) = %apache_modules_api
 Requires:      apr >= 1:1.0.0
 # apache.py uses pdb module
 Requires:      python3-devel-tools
 %requires_eq   python3-libs
+Requires:      systemd-units >= 38
 Conflicts:     apache-mod_python
 
 %description -n apache-mod_python3
@@ -229,25 +236,30 @@ prestandan jämfört med den traditionella CGI-metoden.
 %setup -q -n mod_%{mod_name}-%{version}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 %{__aclocal}
 %{__autoconf}
+
 %if %{with python2}
 %configure \
        --with-apxs=%{apxs} \
        --with-python=%{__python}
+
+%{__make} clean
 %{__make} dso
 install -d apache-mod_python{%{apachelibdir},%{apacheconfdir},%{_bindir}}
 %{__make} install \
        DESTDIR=`pwd`/apache-mod_python
-%{__make} clean
 %endif
 
 %if %{with python3}
 %configure \
        --with-apxs=%{apxs} \
        --with-python=%{__python3}
+
+%{__make} clean
 %{__make} dso
 install -d apache-mod_python3{%{apachelibdir},%{apacheconfdir},%{_bindir}}
 %{__make} install \
@@ -260,9 +272,6 @@ install -d apache-mod_python3{%{apachelibdir},%{apacheconfdir},%{_bindir}}
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir},%{_bindir}}
 
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
-
 %if %{with python2}
 cp -a apache-mod_python/* $RPM_BUILD_ROOT
 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/60_mod_python.conf
@@ -280,18 +289,22 @@ rm -rf $RPM_BUILD_ROOT
 
 %post
 %service -q httpd restart
+%systemd_service_restart httpd.service
 
 %postun
 if [ "$1" = "0" ]; then
        %service -q httpd restart
+       %systemd_service_restart httpd.service
 fi
 
 %post -n apache-mod_python3
 %service -q httpd restart
+%systemd_service_restart httpd.service
 
 %postun -n apache-mod_python3
 if [ "$1" = "0" ]; then
        %service -q httpd restart
+       %systemd_service_restart httpd.service
 fi
 
 %if %{with python2}
This page took 0.035119 seconds and 4 git commands to generate.