]> git.pld-linux.org Git - packages/apache-mod_python.git/blobdiff - apache-mod_python-no-compile.patch
- use DESTDIR when installing python modules
[packages/apache-mod_python.git] / apache-mod_python-no-compile.patch
index 46d3fdefe4a6bbdc6b821c26710ce27cb75e6939..25860fcf7f13c9b79b306448aefceb367c62346d 100644 (file)
@@ -1,12 +1,21 @@
-diff -Nur mod_python-3.0.1.orig/Makefile.in mod_python-3.0.1/Makefile.in
---- mod_python-3.0.1.orig/Makefile.in  Thu Feb 27 09:55:00 2003
-+++ mod_python-3.0.1/Makefile.in       Thu Feb 27 09:59:39 2003
-@@ -108,8 +108,6 @@
-       do \
-               $(INSTALL) $$f $(DESTDIR)$(PY_STD_LIB)/site-packages/mod_python; \
-       done
--      ${PYTHON_BIN} $(PY_STD_LIB)/compileall.py $(PY_STD_LIB)/site-packages/mod_python
--      ${PYTHON_BIN} -O $(PY_STD_LIB)/compileall.py $(DESTDIR)$(PY_STD_LIB)/site-packages/mod_python
+--- mod_python-3.0.3/Makefile.in.orig  2003-06-11 22:36:03.877686520 +0000
++++ mod_python-3.0.3/Makefile.in       2003-06-11 22:36:41.091029232 +0000
+@@ -104,13 +104,11 @@
+ install_py_lib:
+       cd dist && $(MAKE) install_py_lib
+-#     $(INSTALL) -d $(PY_STD_LIB)/site-packages/mod_python
+-#     @for f in `ls lib/python/mod_python/*.py`; \
+-#     do \
+-#             $(INSTALL) $$f $(PY_STD_LIB)/site-packages/mod_python; \
+-#     done
+-#     ${PYTHON_BIN} $(PY_STD_LIB)/compileall.py $(PY_STD_LIB)/site-packages/mod_python
+-#     ${PYTHON_BIN} -O $(PY_STD_LIB)/compileall.py $(PY_STD_LIB)/site-packages/mod_python
++      $(INSTALL) -d $(DESTDIR)$(PY_STD_LIB)/site-packages/mod_python
++      @for f in `ls lib/python/mod_python/*.py`; \
++      do \
++              $(INSTALL) $$f $(DESTDIR)$(PY_STD_LIB)/site-packages/mod_python; \
++      done
  
  clean:
        cd src && $(MAKE) clean
  
  clean:
        cd src && $(MAKE) clean
This page took 0.061435 seconds and 4 git commands to generate.