]> git.pld-linux.org Git - packages/apache-mod_python.git/blob - apache-mod_python.spec
- corrected %doc - adds html documetation
[packages/apache-mod_python.git] / apache-mod_python.spec
1 %define         mod_name        python
2 Summary:        A Python for the Apache Web server
3 Summary(pl):    Python dla serwera WWW Apache
4 Name:           apache-mod_%{mod_name}
5 Version:        2.7.6
6 Release:        3
7 License:        distributable
8 Group:          Networking/Daemons
9 Group(de):      Netzwerkwesen/Server
10 Group(pl):      Sieciowe/Serwery
11 Source0:        http://www.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
12 Patch0:         apache-mod_python-shared.patch
13 Patch1:         apache-mod_python-DESTDIR.patch
14 URL:            http://www.modpython.org/
15 Requires:       apache
16 %requires_eq    python
17 BuildRequires:  autoconf
18 BuildRequires:  apache
19 BuildRequires:  apache-devel
20 BuildRequires:  python-devel
21 BuildRequires:  rpm-pythonprov
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define apache_moddir  %(/usr/sbin/apxs -q LIBEXECDIR)
25
26 %include /usr/lib/rpm/macros.python
27
28 %description
29 mod_python allows embedding Python within the Apache Web server for a
30 considerable boost in performance and added flexibility in designing
31 web based applications.
32
33 NOTE: This versions should still be considered Beta.
34
35 %description -l pl
36 mod_python pozwala na zagnie¿d¿enie pythona w serwerze WWW Apache w
37 celu zauwa¿alnej poprawy wydajno¶ci i zwiêkszonej elastyczno¶ci przy
38 tworzeniu aplikacji opartych na WWW.
39
40 Uwaga: ta wersja nadal powinna byæ uwa¿ana za Beta.
41
42 %prep 
43 %setup -q -n mod_%{mod_name}-%{version}
44 %patch0 -p1
45 %patch1 -p1
46
47 %build
48 autoconf
49
50 # new apache needs it
51 CFLAGS=-DEAPI
52 %configure \
53   --with-apxs=/usr/sbin/apxs
54  
55 %{__make} dso
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT{%{apache_moddir},%{py_sitedir}/mod_%{mod_name}}
60
61 %{__make} install DESTDIR=$RPM_BUILD_ROOT
62
63 gzip -9nf README COPYRIGHT NEWS CREDITS
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %post
69 /usr/sbin/apxs -e -a -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
70 if [ -f /var/lock/subsys/httpd ]; then
71         /etc/rc.d/init.d/httpd restart 1>&2
72 fi
73
74 %preun
75 if [ "$1" = "0" ]; then
76         /usr/sbin/apxs -e -A -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
77         if [ -f /var/lock/subsys/httpd ]; then
78                 /etc/rc.d/init.d/httpd restart 1>&2
79         fi
80 fi
81
82 %files
83 %defattr(644,root,root,755)
84 %doc doc-html/*
85 %doc {README,COPYRIGHT,NEWS,CREDITS}.gz
86 %attr(755,root,root) %{apache_moddir}/*
87 %{py_sitedir}/mod_%{mod_name}
This page took 0.042583 seconds and 4 git commands to generate.