]> git.pld-linux.org Git - packages/apache-mod_python.git/blob - apache-mod_python.spec
- one more git call removed
[packages/apache-mod_python.git] / apache-mod_python.spec
1 %define         mod_name        python
2 %define         apxs            /usr/sbin/apxs
3 Summary:        An embedded Python interpreter for the Apache Web server
4 Summary(cs.UTF-8):      Vestavěný interpret Pythonu pro WWW server Apache
5 Summary(da.UTF-8):      En indbygget Python-fortolker for webtjeneren Apache
6 Summary(de.UTF-8):      Ein eingebetteter Python-Interpreter für den Apache Web-Server
7 Summary(es.UTF-8):      Intérprete Perl para el servidor Web Apache
8 Summary(fr.UTF-8):      Interpréteur Python intégré pour le serveur Web Apache
9 Summary(id.UTF-8):      Interpreter Perl untuk web server Apache
10 Summary(is.UTF-8):      Perl túlkur fyrir Apache vefþjóninn
11 Summary(it.UTF-8):      Interprete Python integrato per il server Web Apache
12 Summary(ja.UTF-8):      Apache Web サーバー用の組込み Perl インタープリタ
13 Summary(nb.UTF-8):      En Python-fortolker for webtjeneren Apache
14 Summary(pl.UTF-8):      Wbudowany interpreter języka Python dla serwera WWW Apache
15 Summary(pt.UTF-8):      Um interpretador de Perl embebido para o servidor Web Apache
16 Summary(ru.UTF-8):      Встроенный интерпретатор Perl для WWW-сервера Apache
17 Summary(sk.UTF-8):      Interpreter jazyka Perl pre webový server Apache
18 Summary(sl.UTF-8):      Vključeni pythonski tolmač za spletni strežnik Apache
19 Summary(sv.UTF-8):      En inbyggd Python-interpretator för webbservern Apache
20 Name:           apache-mod_%{mod_name}
21 Version:        3.4.1
22 Release:        4
23 License:        Apache
24 Group:          Networking/Daemons/HTTP
25 Source0:        http://dist.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
26 # Source0-md5:  d27804354f1808ad55d432fd76ed9d05
27 Source1:        %{name}.conf
28 Patch0:         %{name}-httpd-not-needed.patch
29 Patch1:         no-git.patch
30 URL:            http://www.modpython.org/
31 BuildRequires:  apache-devel >= 2.0.52-7
32 BuildRequires:  apr-devel >= 1:1.0.0
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 BuildRequires:  flex >= 2.5.31
36 BuildRequires:  python
37 BuildRequires:  python-devel >= 2.2
38 BuildRequires:  rpm-pythonprov
39 BuildRequires:  rpmbuild(macros) >= 1.268
40 Requires:       apache(modules-api) = %apache_modules_api
41 Requires:       apr >= 1:1.0.0
42 # apache.py uses pdb module
43 Requires:       python-devel-tools
44 %requires_eq    python-libs
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
48 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
49
50 %description
51 Mod_python is a module that embeds the Python language interpreter
52 within the server, allowing Apache handlers to be written in Python.
53
54 Mod_python brings together the versatility of Python and the power of
55 the Apache Web server for a considerable boost in flexibility and
56 performance over the traditional CGI approach.
57
58 %description -l cs.UTF-8
59 Balíček mod_python obsahuje modul, který umožní serveru Apache přímo
60 interpretovat CGI skripty napsané v jazyce Python. To vede k výraznému
61 zvýšení rychlosti jejich provedení.
62
63 %description -l de.UTF-8
64 Mod_python ist ein Modul, das den Python-Sprachinterpreter innerhalb
65 des Servers einbettet und es den Apache-Handlern ermöglicht, in Python
66 geschrieben zu werden.
67
68 Mod_python verbindet die Vielseitigkeit von Python und die
69 Leistungsstärke des Apache Web-Servers, was eine enorme Steigerung der
70 Flexibilität und Leistung gegenüber dem traditionellen CGI-Ansatz
71 bedeutet.
72
73 %description -l es.UTF-8
74 Mod_python es un módulo que activa el intérprete de Python en el
75 servidor, permitiendo que se escriban gestores para Apache en Python.
76
77 Mod_python proporciona la versatilidad y el poder del servidor web
78 Apache para acelerar considerablemente la flexibilidad y prestaciones
79 en comparación a una aproximación tradicional con CGI.
80
81 %description -l fr.UTF-8
82 Mod_python est un module qui intègre l'interpréteur de langage Python
83 dans le serveur, permettant aux gestionnaires Apache d'être écrits en
84 Python.
85
86 Mod_python conjugue la versatilité de Python et la puissance du
87 serveur Web Apache de façon à augmenter considérablement la
88 flexibilité et la performance par rapport à une approche CGI
89 traditionnelle.
90
91 %description -l it.UTF-8
92 Mod_python è un modulo che integra nel server l'interprete del
93 linguaggio Python, in modo che i programmi di gestione possano essere
94 scritti in Python.
95
96 Mod_python unisce in sé la versatilità di Python e la potenza del
97 server Web Apache, con un conseguente accrescimento di flessibilità e
98 un miglioramento notevole nelle prestazioni rispetto all'approccio
99 tradizionale CGI.
100
101 %description -l ja.UTF-8
102 Mod_python はサーバー内に Python
103 言語インタープリタを組み込んだモジュール です。これにより、Apache
104 ハンドラを Python で記述できます。 Mod_python は、Python の汎用性と
105 Apache Web サーバーのパワーを組み合わせる ことにより、従来の CGI
106 アプローチから柔軟性とパフォーマンスを大幅に向上させます。
107
108 %description -l pl.UTF-8
109 mod_python jest modułem osadzającym interpreter języka Python w
110 serwerze WWW Apache, umożliwiając mu obsługę kodu napisanego w
111 Pythonie.
112
113 mod_python łączy wszechstronność Pythona i moc Apache'a jako serwera
114 WWW, co daje zwiększoną elastyczność i zauważalną poprawę wydajności w
115 stosunku do tradycyjnego rozwiązania opartego na CGI.
116
117 %description -l sv.UTF-8
118 Mod_python är en modul som bygger in en interpretator för språket
119 Python i servern, och låter Apach-hanterare skrivas i Python.
120
121 Mod_python sammanför mångsidigheten hos Python och kraften hos
122 webbservern Apache till en avsevärd ökning av flexibiliteten och
123 prestandan jämfört med den traditionella CGI-metoden.
124
125 %prep
126 %setup -q -n mod_%{mod_name}-%{version}
127 %patch0 -p1
128 %patch1 -p1
129
130 %build
131 %{__aclocal}
132 %{__autoconf}
133 %configure \
134         --with-apxs=%{apxs}
135 %{__make} dso
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir},%{_bindir}}
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/60_mod_python.conf
145 %py_postclean
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post
151 %service -q httpd restart
152
153 %postun
154 if [ "$1" = "0" ]; then
155         %service -q httpd restart
156 fi
157
158 %files
159 %defattr(644,root,root,755)
160 %doc doc-html/* README.md COPYRIGHT NEWS CREDITS
161 %doc examples
162 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
163 %attr(755,root,root) %{_bindir}/mod_python
164 %attr(755,root,root) %{apachelibdir}/*.so
165 %dir %{py_sitedir}/mod_%{mod_name}
166 %if "%{py_ver}" > "2.4"
167 %{py_sitedir}/mod_%{mod_name}-*.egg-info
168 %endif
169 %attr(755,root,root) %{py_sitedir}/mod_%{mod_name}/*.so
170 %{py_sitedir}/mod_%{mod_name}/*.py[co]
This page took 0.077356 seconds and 3 git commands to generate.