]> git.pld-linux.org Git - packages/apache-mod_python.git/blob - apache-mod_python.spec
bf6533aa062cbb1689b9988f2c1dd6817d8f4826
[packages/apache-mod_python.git] / apache-mod_python.spec
1 %define         mod_name        python
2 %define         apxs            /usr/sbin/apxs
3 Summary:        An embedded Python interpreter for the Apache Web server
4 Summary(cs.UTF-8):      Vestavěný interpret Pythonu pro WWW server Apache
5 Summary(da.UTF-8):      En indbygget Python-fortolker for webtjeneren Apache
6 Summary(de.UTF-8):      Ein eingebetteter Python-Interpreter für den Apache Web-Server
7 Summary(es.UTF-8):      Intérprete Perl para el servidor Web Apache
8 Summary(fr.UTF-8):      Interpréteur Python intégré pour le serveur Web Apache
9 Summary(id.UTF-8):      Interpreter Perl untuk web server Apache
10 Summary(is.UTF-8):      Perl túlkur fyrir Apache vefþjóninn
11 Summary(it.UTF-8):      Interprete Python integrato per il server Web Apache
12 Summary(ja.UTF-8):      Apache Web サーバー用の組込み Perl インタープリタ
13 Summary(nb.UTF-8):      En Python-fortolker for webtjeneren Apache
14 Summary(pl.UTF-8):      Wbudowany interpreter języka Python dla serwera WWW Apache
15 Summary(pt.UTF-8):      Um interpretador de Perl embebido para o servidor Web Apache
16 Summary(ru.UTF-8):      Встроенный интерпретатор Perl для WWW-сервера Apache
17 Summary(sk.UTF-8):      Interpreter jazyka Perl pre webový server Apache
18 Summary(sl.UTF-8):      Vključeni pythonski tolmač za spletni strežnik Apache
19 Summary(sv.UTF-8):      En inbyggd Python-interpretator för webbservern Apache
20 Name:           apache-mod_%{mod_name}
21 Version:        3.3.1
22 Release:        13
23 License:        Apache
24 Group:          Networking/Daemons/HTTP
25 Source0:        http://www.apache.org/dist/httpd/modpython/mod_%{mod_name}-%{version}.tgz
26 # Source0-md5:  a3b0150176b726bd2833dac3a7837dc5
27 Source1:        %{name}.conf
28 Patch0:         %{name}-httpd-not-needed.patch
29 Patch1:         %{name}-ldflags.patch
30 Patch2:         %{name}-apr_brigade_sentinel.patch
31 URL:            http://www.modpython.org/
32 BuildRequires:  apache-devel >= 2.0.52-7
33 BuildRequires:  apr-devel >= 1:1.0.0
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 BuildRequires:  flex >= 2.5.31
37 BuildRequires:  python
38 BuildRequires:  python-devel >= 2.2
39 BuildRequires:  rpm-pythonprov
40 BuildRequires:  rpmbuild(macros) >= 1.268
41 Requires:       apache(modules-api) = %apache_modules_api
42 Requires:       apr >= 1:1.0.0
43 # apache.py uses pdb module
44 Requires:       python-devel-tools
45 %requires_eq    python-libs
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
49 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
50
51 %description
52 Mod_python is a module that embeds the Python language interpreter
53 within the server, allowing Apache handlers to be written in Python.
54
55 Mod_python brings together the versatility of Python and the power of
56 the Apache Web server for a considerable boost in flexibility and
57 performance over the traditional CGI approach.
58
59 %description -l cs.UTF-8
60 Balíček mod_python obsahuje modul, který umožní serveru Apache přímo
61 interpretovat CGI skripty napsané v jazyce Python. To vede k výraznému
62 zvýšení rychlosti jejich provedení.
63
64 %description -l de.UTF-8
65 Mod_python ist ein Modul, das den Python-Sprachinterpreter innerhalb
66 des Servers einbettet und es den Apache-Handlern ermöglicht, in Python
67 geschrieben zu werden.
68
69 Mod_python verbindet die Vielseitigkeit von Python und die
70 Leistungsstärke des Apache Web-Servers, was eine enorme Steigerung der
71 Flexibilität und Leistung gegenüber dem traditionellen CGI-Ansatz
72 bedeutet.
73
74 %description -l es.UTF-8
75 Mod_python es un módulo que activa el intérprete de Python en el
76 servidor, permitiendo que se escriban gestores para Apache en Python.
77
78 Mod_python proporciona la versatilidad y el poder del servidor web
79 Apache para acelerar considerablemente la flexibilidad y prestaciones
80 en comparación a una aproximación tradicional con CGI.
81
82 %description -l fr.UTF-8
83 Mod_python est un module qui intègre l'interpréteur de langage Python
84 dans le serveur, permettant aux gestionnaires Apache d'être écrits en
85 Python.
86
87 Mod_python conjugue la versatilité de Python et la puissance du
88 serveur Web Apache de façon à augmenter considérablement la
89 flexibilité et la performance par rapport à une approche CGI
90 traditionnelle.
91
92 %description -l it.UTF-8
93 Mod_python è un modulo che integra nel server l'interprete del
94 linguaggio Python, in modo che i programmi di gestione possano essere
95 scritti in Python.
96
97 Mod_python unisce in sé la versatilità di Python e la potenza del
98 server Web Apache, con un conseguente accrescimento di flessibilità e
99 un miglioramento notevole nelle prestazioni rispetto all'approccio
100 tradizionale CGI.
101
102 %description -l ja.UTF-8
103 Mod_python はサーバー内に Python
104 言語インタープリタを組み込んだモジュール です。これにより、Apache
105 ハンドラを Python で記述できます。 Mod_python は、Python の汎用性と
106 Apache Web サーバーのパワーを組み合わせる ことにより、従来の CGI
107 アプローチから柔軟性とパフォーマンスを大幅に向上させます。
108
109 %description -l pl.UTF-8
110 mod_python jest modułem osadzającym interpreter języka Python w
111 serwerze WWW Apache, umożliwiając mu obsługę kodu napisanego w
112 Pythonie.
113
114 mod_python łączy wszechstronność Pythona i moc Apache'a jako serwera
115 WWW, co daje zwiększoną elastyczność i zauważalną poprawę wydajności w
116 stosunku do tradycyjnego rozwiązania opartego na CGI.
117
118 %description -l sv.UTF-8
119 Mod_python är en modul som bygger in en interpretator för språket
120 Python i servern, och låter Apach-hanterare skrivas i Python.
121
122 Mod_python sammanför mångsidigheten hos Python och kraften hos
123 webbservern Apache till en avsevärd ökning av flexibiliteten och
124 prestandan jämfört med den traditionella CGI-metoden.
125
126 %prep
127 %setup -q -n mod_%{mod_name}-%{version}
128 %patch0 -p1
129 %patch1 -p1
130 %patch2 -p1
131
132 %build
133 %{__aclocal}
134 %{__autoconf}
135 %configure \
136         --with-apxs=%{apxs}
137 %{__make} dso
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir}}
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/60_mod_python.conf
147 %py_postclean
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post
153 %service -q httpd restart
154
155 %postun
156 if [ "$1" = "0" ]; then
157         %service -q httpd restart
158 fi
159
160 %files
161 %defattr(644,root,root,755)
162 %doc doc-html/* README COPYRIGHT NEWS CREDITS
163 %doc examples
164 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
165 %attr(755,root,root) %{apachelibdir}/*.so
166 %dir %{py_sitedir}/mod_%{mod_name}
167 %if "%{py_ver}" > "2.4"
168 %{py_sitedir}/mod_%{mod_name}-*.egg-info
169 %endif
170 %attr(755,root,root) %{py_sitedir}/mod_%{mod_name}/*.so
171 %{py_sitedir}/mod_%{mod_name}/*.py[co]
This page took 0.043116 seconds and 2 git commands to generate.