]> git.pld-linux.org Git - packages/apache-mod_python.git/blob - apache-mod_python.spec
- release 5
[packages/apache-mod_python.git] / apache-mod_python.spec
1 %define         mod_name        python
2 %define         apxs            /usr/sbin/apxs
3 Summary:        An embedded Python interpreter for the Apache Web server
4 Summary(cs.UTF-8):      Vestavěný interpret Pythonu pro WWW server Apache
5 Summary(da.UTF-8):      En indbygget Python-fortolker for webtjeneren Apache
6 Summary(de.UTF-8):      Ein eingebetteter Python-Interpreter für den Apache Web-Server
7 Summary(es.UTF-8):      Intérprete Perl para el servidor Web Apache
8 Summary(fr.UTF-8):      Interpréteur Python intégré pour le serveur Web Apache
9 Summary(id.UTF-8):      Interpreter Perl untuk web server Apache
10 Summary(is.UTF-8):      Perl túlkur fyrir Apache vefþjóninn
11 Summary(it.UTF-8):      Interprete Python integrato per il server Web Apache
12 Summary(ja.UTF-8):      Apache Web サーバー用の組込み Perl インタープリタ
13 Summary(nb.UTF-8):      En Python-fortolker for webtjeneren Apache
14 Summary(pl.UTF-8):      Wbudowany interpreter języka Python dla serwera WWW Apache
15 Summary(pt.UTF-8):      Um interpretador de Perl embebido para o servidor Web Apache
16 Summary(ru.UTF-8):      Встроенный интерпретатор Perl для WWW-сервера Apache
17 Summary(sk.UTF-8):      Interpreter jazyka Perl pre webový server Apache
18 Summary(sl.UTF-8):      Vključeni pythonski tolmač za spletni strežnik Apache
19 Summary(sv.UTF-8):      En inbyggd Python-interpretator för webbservern Apache
20 Name:           apache-mod_%{mod_name}
21 Version:        3.3.1
22 Release:        5
23 License:        Apache Group License
24 Group:          Networking/Daemons
25 Source0:        http://www.apache.org/dist/httpd/modpython/mod_%{mod_name}-%{version}.tgz
26 # Source0-md5:  a3b0150176b726bd2833dac3a7837dc5
27 Source1:        %{name}.conf
28 Patch0:         %{name}-httpd-not-needed.patch
29 Patch1:         %{name}-ldflags.patch
30 Patch2:         %{name}-apr_brigade_sentinel.patch
31 URL:            http://www.modpython.org/
32 BuildRequires:  %{apxs}
33 BuildRequires:  apache-devel >= 2.0.52-7
34 BuildRequires:  apr-devel >= 1:1.0.0
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 BuildRequires:  flex >= 2.5.31
38 BuildRequires:  python
39 BuildRequires:  python-devel >= 2.2
40 BuildRequires:  rpm-pythonprov
41 BuildRequires:  rpmbuild(macros) >= 1.268
42 Requires:       apache(modules-api) = %apache_modules_api
43 Requires:       apr >= 1:1.0.0
44 # apache.py uses pdb module
45 Requires:       python-devel-tools
46 %requires_eq    python-libs
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
50 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
51
52 %description
53 Mod_python is a module that embeds the Python language interpreter
54 within the server, allowing Apache handlers to be written in Python.
55
56 Mod_python brings together the versatility of Python and the power of
57 the Apache Web server for a considerable boost in flexibility and
58 performance over the traditional CGI approach.
59
60 %description -l cs.UTF-8
61 Balíček mod_python obsahuje modul, který umožní serveru Apache přímo
62 interpretovat CGI skripty napsané v jazyce Python. To vede k výraznému
63 zvýšení rychlosti jejich provedení.
64
65 %description -l de.UTF-8
66 Mod_python ist ein Modul, das den Python-Sprachinterpreter innerhalb
67 des Servers einbettet und es den Apache-Handlern ermöglicht, in Python
68 geschrieben zu werden.
69
70 Mod_python verbindet die Vielseitigkeit von Python und die
71 Leistungsstärke des Apache Web-Servers, was eine enorme Steigerung der
72 Flexibilität und Leistung gegenüber dem traditionellen CGI-Ansatz
73 bedeutet.
74
75 %description -l es.UTF-8
76 Mod_python es un módulo que activa el intérprete de Python en el
77 servidor, permitiendo que se escriban gestores para Apache en Python.
78
79 Mod_python proporciona la versatilidad y el poder del servidor web
80 Apache para acelerar considerablemente la flexibilidad y prestaciones
81 en comparación a una aproximación tradicional con CGI.
82
83 %description -l fr.UTF-8
84 Mod_python est un module qui intègre l'interpréteur de langage Python
85 dans le serveur, permettant aux gestionnaires Apache d'être écrits en
86 Python.
87
88 Mod_python conjugue la versatilité de Python et la puissance du
89 serveur Web Apache de façon à augmenter considérablement la
90 flexibilité et la performance par rapport à une approche CGI
91 traditionnelle.
92
93 %description -l it.UTF-8
94 Mod_python è un modulo che integra nel server l'interprete del
95 linguaggio Python, in modo che i programmi di gestione possano essere
96 scritti in Python.
97
98 Mod_python unisce in sé la versatilità di Python e la potenza del
99 server Web Apache, con un conseguente accrescimento di flessibilità e
100 un miglioramento notevole nelle prestazioni rispetto all'approccio
101 tradizionale CGI.
102
103 %description -l ja.UTF-8
104 Mod_python はサーバー内に Python
105 言語インタープリタを組み込んだモジュール です。これにより、Apache
106 ハンドラを Python で記述できます。 Mod_python は、Python の汎用性と
107 Apache Web サーバーのパワーを組み合わせる ことにより、従来の CGI
108 アプローチから柔軟性とパフォーマンスを大幅に向上させます。
109
110 %description -l pl.UTF-8
111 mod_python jest modułem osadzającym interpreter języka Python w
112 serwerze WWW Apache, umożliwiając mu obsługę kodu napisanego w
113 Pythonie.
114
115 mod_python łączy wszechstronność Pythona i moc Apache'a jako serwera
116 WWW, co daje zwiększoną elastyczność i zauważalną poprawę wydajności w
117 stosunku do tradycyjnego rozwiązania opartego na CGI.
118
119 %description -l sv.UTF-8
120 Mod_python är en modul som bygger in en interpretator för språket
121 Python i servern, och låter Apach-hanterare skrivas i Python.
122
123 Mod_python sammanför mångsidigheten hos Python och kraften hos
124 webbservern Apache till en avsevärd ökning av flexibiliteten och
125 prestandan jämfört med den traditionella CGI-metoden.
126
127 %prep
128 %setup -q -n mod_%{mod_name}-%{version}
129 %patch0 -p1
130 %patch1 -p1
131 %patch2 -p1
132
133 %build
134 %{__aclocal}
135 %{__autoconf}
136 %configure \
137         --with-apxs=%{apxs}
138 %{__make} dso
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142 install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir}}
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/60_mod_python.conf
148 %py_postclean
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post
154 %service -q httpd restart
155
156 %postun
157 if [ "$1" = "0" ]; then
158         %service -q httpd restart
159 fi
160
161 %files
162 %defattr(644,root,root,755)
163 %doc doc-html/* README COPYRIGHT NEWS CREDITS
164 %doc examples
165 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
166 %attr(755,root,root) %{apachelibdir}/*.so
167 %dir %{py_sitedir}/mod_%{mod_name}
168 %attr(755,root,root) %{py_sitedir}/mod_%{mod_name}/*.so
169 %{py_sitedir}/mod_%{mod_name}/*.py[co]
This page took 0.045707 seconds and 3 git commands to generate.