]> git.pld-linux.org Git - packages/apache-mod_python.git/blob - apache-mod_python.spec
- removed out of date patches
[packages/apache-mod_python.git] / apache-mod_python.spec
1
2 #
3 # todo:
4 # - configuration file in /etc/httpd/httpd.conf/ _directory_
5 #
6
7 %include        /usr/lib/rpm/macros.python
8 %define         mod_name        python
9 %define         apxs            /usr/sbin/apxs
10 Summary:        An embedded Python interpreter for the Apache Web server
11 Summary(cs):    Vestavìný interpret Pythonu pro WWW server Apache
12 Summary(da):    En indbygget Python-fortolker for webtjeneren Apache
13 Summary(de):    Ein eingebetteter Python-Interpreter für den Apache Web-Server
14 Summary(es):    Intérprete Perl para el servidor Web Apache
15 Summary(fr):    Interpréteur Python intégré pour le serveur Web Apache
16 Summary(id):    Interpreter Perl untuk web server Apache
17 Summary(is):    Perl túlkur fyrir Apache vefþjóninn
18 Summary(it):    Interprete Python integrato per il server Web Apache
19 Summary(ja):    Apache Web ¥µ¡¼¥Ð¡¼ÍѤÎÁȹþ¤ß Perl ¥¤¥ó¥¿¡¼¥×¥ê¥¿
20 Summary(no):    En Python-fortolker for webtjeneren Apache
21 Summary(pl):    Wbudowany interpreter Pythona dla serwera WWW Apache
22 Summary(pt):    Um interpretador de Perl embebido para o servidor Web Apache
23 Summary(ru):    ÷ÓÔÒÏÅÎÎÙÊ ÉÎÔÅÒÐÒÅÔÁÔÏÒ Perl ÄÌÑ WWW-ÓÅÒ×ÅÒÁ Apache
24 Summary(sk):    Interpreter jazyka Perl pre webový server Apache
25 Summary(sl):    Vkljuèeni pythonski tolmaè za spletni stre¾nik Apache
26 Summary(sv):    En inbyggd Python-interpretator för webbservern Apache
27 Name:           apache-mod_%{mod_name}
28 Version:        3.0.1
29 Release:        0.2
30 License:        Apache Group License
31 Group:          Networking/Daemons
32 Source0:        http://www.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
33 Patch0:         %{name}-DESTDIR.patch
34 Patch1:         %{name}-no-compile.patch
35 URL:            http://www.modpython.org/
36 BuildRequires:  autoconf
37 BuildRequires:  automake
38 BuildRequires:  apache-devel >= 2.0.44
39 BuildRequires:  python-devel >= 2.2
40 BuildRequires:  rpm-pythonprov
41 BuildRequires:  %{apxs}
42 Prereq:         %{_sbindir}/apxs
43 Requires:       apache
44 %pyrequires_eq  python
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         apache_moddir   %(%{apxs} -q LIBEXECDIR)
48
49 %description
50 Mod_python is a module that embeds the Python language interpreter
51 within the server, allowing Apache handlers to be written in Python.
52
53 Mod_python brings together the versatility of Python and the power of
54 the Apache Web server for a considerable boost in flexibility and
55 performance over the traditional CGI approach.
56
57 %description -l cs
58 Balíèek mod_python obsahuje modul, který umo¾ní serveru Apache pøímo
59 interpretovat CGI skripty napsané v jazyce Python. To vede k výraznému
60 zvý¹ení rychlosti jejich provedení.
61
62 %description -l de
63 Mod_python ist ein Modul, das den Python-Sprachinterpreter innerhalb
64 des Servers einbettet und es den Apache-Handlern ermöglicht, in Python
65 geschrieben zu werden.
66
67 Mod_python verbindet die Vielseitigkeit von Python und die
68 Leistungsstärke des Apache Web-Servers, was eine enorme Steigerung der
69 Flexibilität und Leistung gegenüber dem traditionellen CGI-Ansatz
70 bedeutet.
71
72 %description -l es
73 Mod_python es un módulo que activa el intérprete de Python en el
74 servidor, permitiendo que se escriban gestores para Apache en Python.
75
76 Mod_python proporciona la versatilidad y el poder del servidor web
77 Apache para acelerar considerablemente la flexibilidad y prestaciones
78 en comparación a una aproximación tradicional con CGI.
79
80 %description -l fr
81 Mod_python est un module qui intègre l'interpréteur de langage Python
82 dans le serveur, permettant aux gestionnaires Apache d'être écrits en
83 Python.
84
85 Mod_python conjugue la versatilité de Python et la puissance du
86 serveur Web Apache de façon à augmenter considérablement la
87 flexibilité et la performance par rapport à une approche CGI
88 traditionnelle.
89
90 %description -l it
91 Mod_python è un modulo che integra nel server l'interprete del
92 linguaggio Python, in modo che i programmi di gestione possano essere
93 scritti in Python.
94
95 Mod_python unisce in sé la versatilità di Python e la potenza del
96 server Web Apache, con un conseguente accrescimento di flessibilità e
97 un miglioramento notevole nelle prestazioni rispetto all'approccio
98 tradizionale CGI.
99
100 %description -l ja
101 Mod_python ¤Ï¥µ¡¼¥Ð¡¼Æâ¤Ë Python
102 ¸À¸ì¥¤¥ó¥¿¡¼¥×¥ê¥¿¤òÁȤ߹þ¤ó¤À¥â¥¸¥å¡¼¥ë ¤Ç¤¹¡£¤³¤ì¤Ë¤è¤ê¡¢Apache
103 ¥Ï¥ó¥É¥é¤ò Python ¤Çµ­½Ò¤Ç¤­¤Þ¤¹¡£ Mod_python ¤Ï¡¢Python ¤ÎÈÆÍÑÀ­¤È
104 Apache Web ¥µ¡¼¥Ð¡¼¤Î¥Ñ¥ï¡¼¤òÁȤ߹ç¤ï¤»¤ë ¤³¤È¤Ë¤è¤ê¡¢½¾Íè¤Î CGI
105 ¥¢¥×¥í¡¼¥Á¤«¤é½ÀÆðÀ­¤È¥Ñ¥Õ¥©¡¼¥Þ¥ó¥¹¤òÂçÉý¤Ë¸þ¾å¤µ¤»¤Þ¤¹¡£
106
107 %description -l pl
108 mod_python jest modu³em osadzaj±cym interpreter jêzyka Python w
109 serwerze WWW Apache, umo¿liwiaj±c mu obs³ugê kodu napisanego w
110 Pythonie.
111
112 mod_python ³±czy wszechstronno¶æ Pythona i moc Apache'a jako serwera
113 WWW, co daje zwiêkszon± elastyczno¶æ i zauwa¿aln± poprawê wydajno¶ci w
114 stosunku do tradycyjnego rozwi±zania opartego na CGI.
115
116 %description -l sv
117 Mod_python är en modul som bygger in en interpretator för språket
118 Python i servern, och låter Apach-hanterare skrivas i Python.
119
120 Mod_python sammanför mångsidigheten hos Python och kraften hos
121 webbservern Apache till en avsevärd ökning av flexibiliteten och
122 prestandan jämfört med den traditionella CGI-metoden.
123
124 %prep
125 %setup -q -n mod_%{mod_name}-%{version}
126 %patch0 -p1
127 %patch1 -p1
128
129 %build
130 %{__aclocal}
131 %{__autoconf}
132
133 # new apache needs it
134 CFLAGS="-DEAPI %{rpmcflags}"
135 %configure \
136         --with-apxs=%{apxs}
137
138 %{__make} dso
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142 install -d $RPM_BUILD_ROOT{%{apache_moddir},%{py_sitedir}/mod_%{mod_name}}
143
144 %{__make} install DESTDIR=$RPM_BUILD_ROOT
145
146 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
147 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post
153 if [ -f /var/lock/subsys/httpd ]; then
154         /etc/rc.d/init.d/httpd restart 1>&2
155 fi
156
157 %preun
158 if [ "$1" = "0" ]; then
159         if [ -f /var/lock/subsys/httpd ]; then
160                 /etc/rc.d/init.d/httpd restart 1>&2
161         fi
162 fi
163
164 %files
165 %defattr(644,root,root,755)
166 %doc doc-html/*
167 %doc README COPYRIGHT NEWS CREDITS
168 %attr(755,root,root) %{apache_moddir}/*
169 %dir %{py_sitedir}/mod_%{mod_name}
170 %{py_sitedir}/mod_%{mod_name}/*.py[co]
This page took 0.042953 seconds and 3 git commands to generate.