]> git.pld-linux.org Git - packages/apache-mod_python.git/blob - apache-mod_python.spec
a3f324c4537436d8638d1ea61f3c4ed73ef67253
[packages/apache-mod_python.git] / apache-mod_python.spec
1 %define         mod_name        python
2 Summary:        A Python for the Apache Web server
3 Name:           apache-mod_%{mod_name}
4 Version:        2.2
5 Release:        1
6 License:        distributable
7 Group:          Networking/Daemons
8 Group(pl):      Sieciowe/Serwery
9 Source:         http://www.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
10 URL:            http://www.modpython.org/
11 Requires:       apache
12 Requires:       python 
13 BuildRequires:  apache
14 BuildRequires:  apache-devel
15 BuildRequires:  python-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define apache_moddir  %(/usr/sbin/apxs -q LIBEXECDIR)
19 %define python_prefix  %(echo `python -c "import sys; print sys.prefix"`)
20 %define python_version %(echo `python -c "import sys; print sys.version[:3]"`)
21 %define python_libdir      %{python_prefix}/lib/python%{python_version}
22 %define python_includedir  %{python_prefix}/include/python%{python_version}
23 %define python_sitedir     %{python_libdir}/site-packages
24
25
26 %description
27 mod_python allows embedding Python within the Apache Web server 
28 for a considerable boost in performance and added flexibility 
29 in designing web based applications. 
30
31 NOTE: This versions should still be considered Beta
32
33 %prep 
34 %setup -q -n mod_%{mod_name}-%{version}
35
36 %build
37 python %{python_libdir}/compileall.py lib/python/mod_python/
38
39 PTHREADS=
40 if ldd %{python_prefix}/bin/python | grep libpthread >/dev/null; then 
41         PTHREADS=-lpthread
42 fi   
43 cd src
44 /usr/sbin/apxs -I%{python_includedir} -lpython $PTHREADS -o mod_%{mod_name}.so -c mod_%{mod_name}.c
45 cd ..
46 gzip -9nf README COPYRIGHT
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 install -d $RPM_BUILD_ROOT%{apache_moddir}
52 install src/mod_%{mod_name}.so $RPM_BUILD_ROOT%{apache_moddir}
53 strip --strip-unneeded $RPM_BUILD_ROOT%{apache_moddir}/* 
54
55 install -d $RPM_BUILD_ROOT%{python_sitedir}/mod_%{mod_name}
56 install lib/python/mod_python/* $RPM_BUILD_ROOT%{python_sitedir}/mod_%{mod_name}
57
58 %post
59 /usr/sbin/apxs -e -a -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
60 if [ -f /var/lock/subsys/httpd ]; then
61         /etc/rc.d/init.d/httpd restart 1>&2
62 fi
63
64 %preun
65 if [ "$1" = "0" ]; then
66         /usr/sbin/apxs -e -A -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
67         if [ -f /var/lock/subsys/httpd ]; then
68                 /etc/rc.d/init.d/httpd restart 1>&2
69         fi
70 fi
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %attr(755,root,root) %{apache_moddir}/*
78 %{python_sitedir}/mod_%{mod_name}
79 %doc doc/*
80 %doc {README,COPYRIGHT}.gz
This page took 0.030167 seconds and 2 git commands to generate.