]> git.pld-linux.org Git - packages/apache-mod_python.git/blob - apache-mod_python.spec
8f576ffe4ebb71a9dca7cce30a31bf0a97ffb3f8
[packages/apache-mod_python.git] / apache-mod_python.spec
1
2 %include        /usr/lib/rpm/macros.python
3 %define         mod_name        python
4 %define         apxs            /usr/sbin/apxs
5
6 Summary:        An embedded Python interpreter for the Apache Web server
7 Summary(cs):    Vestavìný interpret Pythonu pro WWW server Apache
8 Summary(da):    En indbygget Python-fortolker for webtjeneren Apache
9 Summary(de):    Ein eingebetteter Python-Interpreter für den Apache Web-Server
10 Summary(es):    Intérprete Perl para el servidor Web Apache
11 Summary(fr):    Interpréteur Python intégré pour le serveur Web Apache
12 Summary(id):    Interpreter Perl untuk web server Apache
13 Summary(is):    Perl túlkur fyrir Apache vefþjóninn
14 Summary(it):    Interprete Python integrato per il server Web Apache
15 Summary(ja):    Apache Web ¥µ¡¼¥Ð¡¼ÍѤÎÁȹþ¤ß Perl ¥¤¥ó¥¿¡¼¥×¥ê¥¿
16 Summary(nb):    En Python-fortolker for webtjeneren Apache
17 Summary(pl):    Wbudowany interpreter jêzyka Python dla serwera WWW Apache
18 Summary(pt):    Um interpretador de Perl embebido para o servidor Web Apache
19 Summary(ru):    ÷ÓÔÒÏÅÎÎÙÊ ÉÎÔÅÒÐÒÅÔÁÔÏÒ Perl ÄÌÑ WWW-ÓÅÒ×ÅÒÁ Apache
20 Summary(sk):    Interpreter jazyka Perl pre webový server Apache
21 Summary(sl):    Vkljuèeni pythonski tolmaè za spletni stre¾nik Apache
22 Summary(sv):    En inbyggd Python-interpretator för webbservern Apache
23 Name:           apache-mod_%{mod_name}
24 Version:        3.1.3
25 Release:        2
26 License:        Apache Group License
27 Group:          Networking/Daemons
28 Source0:        http://www.apache.org/dist/httpd/modpython/mod_%{mod_name}-%{version}.tgz
29 # Source0-md5:  2e1983e35edd428f308b0dfeb1c23bfe
30 Source1:        %{name}.conf
31 Patch0:         %{name}-lib64.patch
32 URL:            http://www.modpython.org/
33 BuildRequires:  %{apxs}
34 BuildRequires:  apache-devel >= 2.0.44
35 BuildRequires:  apr-devel >= 1:0.9.4-1
36 BuildRequires:  autoconf
37 BuildRequires:  automake
38 BuildRequires:  flex >= 2.5.31
39 BuildRequires:  python-devel >= 2.2
40 BuildRequires:  rpm-pythonprov
41 Requires(post,preun):   %{apxs}
42 Requires:       apache >= 2.0.44
43 Requires:       python-devel-tools
44 %pyrequires_eq  python
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         apache_moddir   %(%{apxs} -q LIBEXECDIR)
48
49 %description
50 Mod_python is a module that embeds the Python language interpreter
51 within the server, allowing Apache handlers to be written in Python.
52
53 Mod_python brings together the versatility of Python and the power of
54 the Apache Web server for a considerable boost in flexibility and
55 performance over the traditional CGI approach.
56
57 %description -l cs
58 Balíèek mod_python obsahuje modul, který umo¾ní serveru Apache pøímo
59 interpretovat CGI skripty napsané v jazyce Python. To vede k výraznému
60 zvý¹ení rychlosti jejich provedení.
61
62 %description -l de
63 Mod_python ist ein Modul, das den Python-Sprachinterpreter innerhalb
64 des Servers einbettet und es den Apache-Handlern ermöglicht, in Python
65 geschrieben zu werden.
66
67 Mod_python verbindet die Vielseitigkeit von Python und die
68 Leistungsstärke des Apache Web-Servers, was eine enorme Steigerung der
69 Flexibilität und Leistung gegenüber dem traditionellen CGI-Ansatz
70 bedeutet.
71
72 %description -l es
73 Mod_python es un módulo que activa el intérprete de Python en el
74 servidor, permitiendo que se escriban gestores para Apache en Python.
75
76 Mod_python proporciona la versatilidad y el poder del servidor web
77 Apache para acelerar considerablemente la flexibilidad y prestaciones
78 en comparación a una aproximación tradicional con CGI.
79
80 %description -l fr
81 Mod_python est un module qui intègre l'interpréteur de langage Python
82 dans le serveur, permettant aux gestionnaires Apache d'être écrits en
83 Python.
84
85 Mod_python conjugue la versatilité de Python et la puissance du
86 serveur Web Apache de façon à augmenter considérablement la
87 flexibilité et la performance par rapport à une approche CGI
88 traditionnelle.
89
90 %description -l it
91 Mod_python è un modulo che integra nel server l'interprete del
92 linguaggio Python, in modo che i programmi di gestione possano essere
93 scritti in Python.
94
95 Mod_python unisce in sé la versatilità di Python e la potenza del
96 server Web Apache, con un conseguente accrescimento di flessibilità e
97 un miglioramento notevole nelle prestazioni rispetto all'approccio
98 tradizionale CGI.
99
100 %description -l ja
101 Mod_python ¤Ï¥µ¡¼¥Ð¡¼Æâ¤Ë Python
102 ¸À¸ì¥¤¥ó¥¿¡¼¥×¥ê¥¿¤òÁȤ߹þ¤ó¤À¥â¥¸¥å¡¼¥ë ¤Ç¤¹¡£¤³¤ì¤Ë¤è¤ê¡¢Apache
103 ¥Ï¥ó¥É¥é¤ò Python ¤Çµ­½Ò¤Ç¤­¤Þ¤¹¡£ Mod_python ¤Ï¡¢Python ¤ÎÈÆÍÑÀ­¤È
104 Apache Web ¥µ¡¼¥Ð¡¼¤Î¥Ñ¥ï¡¼¤òÁȤ߹ç¤ï¤»¤ë ¤³¤È¤Ë¤è¤ê¡¢½¾Íè¤Î CGI
105 ¥¢¥×¥í¡¼¥Á¤«¤é½ÀÆðÀ­¤È¥Ñ¥Õ¥©¡¼¥Þ¥ó¥¹¤òÂçÉý¤Ë¸þ¾å¤µ¤»¤Þ¤¹¡£
106
107 %description -l pl
108 mod_python jest modu³em osadzaj±cym interpreter jêzyka Python w
109 serwerze WWW Apache, umo¿liwiaj±c mu obs³ugê kodu napisanego w
110 Pythonie.
111
112 mod_python ³±czy wszechstronno¶æ Pythona i moc Apache'a jako serwera
113 WWW, co daje zwiêkszon± elastyczno¶æ i zauwa¿aln± poprawê wydajno¶ci w
114 stosunku do tradycyjnego rozwi±zania opartego na CGI.
115
116 %description -l sv
117 Mod_python är en modul som bygger in en interpretator för språket
118 Python i servern, och låter Apach-hanterare skrivas i Python.
119
120 Mod_python sammanför mångsidigheten hos Python och kraften hos
121 webbservern Apache till en avsevärd ökning av flexibiliteten och
122 prestandan jämfört med den traditionella CGI-metoden.
123
124 %prep
125 %setup -q -n mod_%{mod_name}-%{version}
126 %if "%{_libdir}" == "%{_prefix}/lib64"
127 %patch0
128 %endif
129
130 %build
131 %{__aclocal}
132 %{__autoconf}
133
134 # new apache needs it
135 CFLAGS="-DEAPI %{rpmcflags}"
136 %configure \
137         --with-apxs=%{apxs}
138
139 %{__make} dso
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143 install -d $RPM_BUILD_ROOT%{apache_moddir} \
144         $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf
145
146 %{__make} install \
147         DESTDIR=$RPM_BUILD_ROOT
148
149 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/60_mod_python.conf
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post
155 if [ -f /var/lock/subsys/httpd ]; then
156         /etc/rc.d/init.d/httpd restart 1>&2
157 fi
158
159 %preun
160 if [ "$1" = "0" ]; then
161         if [ -f /var/lock/subsys/httpd ]; then
162                 /etc/rc.d/init.d/httpd restart 1>&2
163         fi
164 fi
165
166 %files
167 %defattr(644,root,root,755)
168 %doc doc-html/* README COPYRIGHT NEWS CREDITS
169 %{_sysconfdir}/httpd/httpd.conf/60_mod_python.conf
170 %attr(755,root,root) %{apache_moddir}/*
171 %dir %{py_sitedir}/mod_%{mod_name}
172 %attr(755,root,root) %{py_sitedir}/mod_%{mod_name}/*.so
173 %{py_sitedir}/mod_%{mod_name}/*.py[co]
This page took 0.053918 seconds and 3 git commands to generate.