]> git.pld-linux.org Git - packages/apache-mod_python.git/blob - apache-mod_python.spec
- updated to 3.4.1
[packages/apache-mod_python.git] / apache-mod_python.spec
1 %define         mod_name        python
2 %define         apxs            /usr/sbin/apxs
3 Summary:        An embedded Python interpreter for the Apache Web server
4 Summary(cs.UTF-8):      Vestavěný interpret Pythonu pro WWW server Apache
5 Summary(da.UTF-8):      En indbygget Python-fortolker for webtjeneren Apache
6 Summary(de.UTF-8):      Ein eingebetteter Python-Interpreter für den Apache Web-Server
7 Summary(es.UTF-8):      Intérprete Perl para el servidor Web Apache
8 Summary(fr.UTF-8):      Interpréteur Python intégré pour le serveur Web Apache
9 Summary(id.UTF-8):      Interpreter Perl untuk web server Apache
10 Summary(is.UTF-8):      Perl túlkur fyrir Apache vefþjóninn
11 Summary(it.UTF-8):      Interprete Python integrato per il server Web Apache
12 Summary(ja.UTF-8):      Apache Web サーバー用の組込み Perl インタープリタ
13 Summary(nb.UTF-8):      En Python-fortolker for webtjeneren Apache
14 Summary(pl.UTF-8):      Wbudowany interpreter języka Python dla serwera WWW Apache
15 Summary(pt.UTF-8):      Um interpretador de Perl embebido para o servidor Web Apache
16 Summary(ru.UTF-8):      Встроенный интерпретатор Perl для WWW-сервера Apache
17 Summary(sk.UTF-8):      Interpreter jazyka Perl pre webový server Apache
18 Summary(sl.UTF-8):      Vključeni pythonski tolmač za spletni strežnik Apache
19 Summary(sv.UTF-8):      En inbyggd Python-interpretator för webbservern Apache
20 Name:           apache-mod_%{mod_name}
21 Version:        3.4.1
22 Release:        1
23 License:        Apache
24 Group:          Networking/Daemons/HTTP
25 Source0:        http://dist.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
26 # Source0-md5:  d27804354f1808ad55d432fd76ed9d05
27 Source1:        %{name}.conf
28 Patch0:         %{name}-httpd-not-needed.patch
29 URL:            http://www.modpython.org/
30 BuildRequires:  apache-devel >= 2.0.52-7
31 BuildRequires:  apr-devel >= 1:1.0.0
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 BuildRequires:  flex >= 2.5.31
35 BuildRequires:  python
36 BuildRequires:  python-devel >= 2.2
37 BuildRequires:  rpm-pythonprov
38 BuildRequires:  rpmbuild(macros) >= 1.268
39 Requires:       apache(modules-api) = %apache_modules_api
40 Requires:       apr >= 1:1.0.0
41 # apache.py uses pdb module
42 Requires:       python-devel-tools
43 %requires_eq    python-libs
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
47 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
48
49 %description
50 Mod_python is a module that embeds the Python language interpreter
51 within the server, allowing Apache handlers to be written in Python.
52
53 Mod_python brings together the versatility of Python and the power of
54 the Apache Web server for a considerable boost in flexibility and
55 performance over the traditional CGI approach.
56
57 %description -l cs.UTF-8
58 Balíček mod_python obsahuje modul, který umožní serveru Apache přímo
59 interpretovat CGI skripty napsané v jazyce Python. To vede k výraznému
60 zvýšení rychlosti jejich provedení.
61
62 %description -l de.UTF-8
63 Mod_python ist ein Modul, das den Python-Sprachinterpreter innerhalb
64 des Servers einbettet und es den Apache-Handlern ermöglicht, in Python
65 geschrieben zu werden.
66
67 Mod_python verbindet die Vielseitigkeit von Python und die
68 Leistungsstärke des Apache Web-Servers, was eine enorme Steigerung der
69 Flexibilität und Leistung gegenüber dem traditionellen CGI-Ansatz
70 bedeutet.
71
72 %description -l es.UTF-8
73 Mod_python es un módulo que activa el intérprete de Python en el
74 servidor, permitiendo que se escriban gestores para Apache en Python.
75
76 Mod_python proporciona la versatilidad y el poder del servidor web
77 Apache para acelerar considerablemente la flexibilidad y prestaciones
78 en comparación a una aproximación tradicional con CGI.
79
80 %description -l fr.UTF-8
81 Mod_python est un module qui intègre l'interpréteur de langage Python
82 dans le serveur, permettant aux gestionnaires Apache d'être écrits en
83 Python.
84
85 Mod_python conjugue la versatilité de Python et la puissance du
86 serveur Web Apache de façon à augmenter considérablement la
87 flexibilité et la performance par rapport à une approche CGI
88 traditionnelle.
89
90 %description -l it.UTF-8
91 Mod_python è un modulo che integra nel server l'interprete del
92 linguaggio Python, in modo che i programmi di gestione possano essere
93 scritti in Python.
94
95 Mod_python unisce in sé la versatilità di Python e la potenza del
96 server Web Apache, con un conseguente accrescimento di flessibilità e
97 un miglioramento notevole nelle prestazioni rispetto all'approccio
98 tradizionale CGI.
99
100 %description -l ja.UTF-8
101 Mod_python はサーバー内に Python
102 言語インタープリタを組み込んだモジュール です。これにより、Apache
103 ハンドラを Python で記述できます。 Mod_python は、Python の汎用性と
104 Apache Web サーバーのパワーを組み合わせる ことにより、従来の CGI
105 アプローチから柔軟性とパフォーマンスを大幅に向上させます。
106
107 %description -l pl.UTF-8
108 mod_python jest modułem osadzającym interpreter języka Python w
109 serwerze WWW Apache, umożliwiając mu obsługę kodu napisanego w
110 Pythonie.
111
112 mod_python łączy wszechstronność Pythona i moc Apache'a jako serwera
113 WWW, co daje zwiększoną elastyczność i zauważalną poprawę wydajności w
114 stosunku do tradycyjnego rozwiązania opartego na CGI.
115
116 %description -l sv.UTF-8
117 Mod_python är en modul som bygger in en interpretator för språket
118 Python i servern, och låter Apach-hanterare skrivas i Python.
119
120 Mod_python sammanför mångsidigheten hos Python och kraften hos
121 webbservern Apache till en avsevärd ökning av flexibiliteten och
122 prestandan jämfört med den traditionella CGI-metoden.
123
124 %prep
125 %setup -q -n mod_%{mod_name}-%{version}
126 %patch0 -p1
127
128 %build
129 %{__aclocal}
130 %{__autoconf}
131 %configure \
132         --with-apxs=%{apxs}
133 %{__make} dso
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir},%{_bindir}}
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/60_mod_python.conf
143 %py_postclean
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post
149 %service -q httpd restart
150
151 %postun
152 if [ "$1" = "0" ]; then
153         %service -q httpd restart
154 fi
155
156 %files
157 %defattr(644,root,root,755)
158 %doc doc-html/* README.md COPYRIGHT NEWS CREDITS
159 %doc examples
160 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
161 %attr(755,root,root) %{_bindir}/mod_python
162 %attr(755,root,root) %{apachelibdir}/*.so
163 %dir %{py_sitedir}/mod_%{mod_name}
164 %if "%{py_ver}" > "2.4"
165 %{py_sitedir}/mod_%{mod_name}-*.egg-info
166 %endif
167 %attr(755,root,root) %{py_sitedir}/mod_%{mod_name}/*.so
168 %{py_sitedir}/mod_%{mod_name}/*.py[co]
This page took 0.053167 seconds and 3 git commands to generate.