]> git.pld-linux.org Git - packages/apache-mod_python.git/blob - apache-mod_python.spec
- properly set request response status for wsgi handler (status_line must match status)
[packages/apache-mod_python.git] / apache-mod_python.spec
1 # TODO:
2 #       1) make mod_python3 use it's own set of config directives
3 #       2) test if both flavors can be loaded at the same time
4 #       3) after 1 and 2 are done, drop conflicts
5 #
6 # Conditional build:
7 %bcond_without  python2         # CPython 2.x module
8 %bcond_without  python3         # CPython 3.x module
9
10 %define         mod_name        python
11 %define         apxs            /usr/sbin/apxs
12 Summary:        An embedded Python interpreter for the Apache Web server
13 Summary(cs.UTF-8):      Vestavěný interpret Pythonu pro WWW server Apache
14 Summary(de.UTF-8):      Ein eingebetteter Python-Interpreter für den Apache Web-Server
15 Summary(es.UTF-8):      Intérprete Python para el servidor Web Apache
16 Summary(fr.UTF-8):      Interpréteur Python intégré pour le serveur Web Apache
17 Summary(it.UTF-8):      Interprete Python integrato per il server Web Apache
18 Summary(ja.UTF-8):      Apache Web サーバー用の組込み Python インタープリタ
19 Summary(pl.UTF-8):      Wbudowany interpreter języka Python dla serwera WWW Apache
20 Summary(sv.UTF-8):      En inbyggd Python-interpretator för webbservern Apache
21 Name:           apache-mod_%{mod_name}
22 Version:        3.5.0
23 Release:        2
24 License:        Apache
25 Group:          Networking/Daemons/HTTP
26 Source0:        http://dist.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
27 # Source0-md5:  2e61621e8d030f535f112d8e739161e2
28 Source1:        %{name}.conf
29 Source2:        %{name}3.conf
30 Patch0:         %{name}-httpd-not-needed.patch
31 Patch1:         no-git.patch
32 Patch2:         set-request-response-status.patch
33 URL:            http://www.modpython.org/
34 BuildRequires:  apache-devel >= 2.0.52-7
35 BuildRequires:  apr-devel >= 1:1.0.0
36 BuildRequires:  autoconf
37 BuildRequires:  automake
38 BuildRequires:  flex >= 2.5.31
39 BuildRequires:  rpm-pythonprov
40 BuildRequires:  rpmbuild(macros) >= 1.268
41 %if %{with python2}
42 BuildRequires:  python
43 BuildRequires:  python-devel >= 2.6
44 %endif
45 %if %{with python3}
46 BuildRequires:  python3
47 BuildRequires:  python3-devel >= 3.3
48 %endif
49 Requires:       apache(modules-api) = %apache_modules_api
50 Requires:       apr >= 1:1.0.0
51 # apache.py uses pdb module
52 Requires:       python-devel-tools
53 %requires_eq    python-libs
54 Conflicts:      apache-mod_python3
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
58 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
59
60 %description
61 Mod_python is a module that embeds the Python language interpreter
62 within the server, allowing Apache handlers to be written in Python.
63
64 Mod_python brings together the versatility of Python and the power of
65 the Apache Web server for a considerable boost in flexibility and
66 performance over the traditional CGI approach.
67
68 %description -l cs.UTF-8
69 Balíček mod_python obsahuje modul, který umožní serveru Apache přímo
70 interpretovat CGI skripty napsané v jazyce Python. To vede k výraznému
71 zvýšení rychlosti jejich provedení.
72
73 %description -l de.UTF-8
74 Mod_python ist ein Modul, das den Python-Sprachinterpreter innerhalb
75 des Servers einbettet und es den Apache-Handlern ermöglicht, in Python
76 geschrieben zu werden.
77
78 Mod_python verbindet die Vielseitigkeit von Python und die
79 Leistungsstärke des Apache Web-Servers, was eine enorme Steigerung der
80 Flexibilität und Leistung gegenüber dem traditionellen CGI-Ansatz
81 bedeutet.
82
83 %description -l es.UTF-8
84 Mod_python es un módulo que activa el intérprete de Python en el
85 servidor, permitiendo que se escriban gestores para Apache en Python.
86
87 Mod_python proporciona la versatilidad y el poder del servidor web
88 Apache para acelerar considerablemente la flexibilidad y prestaciones
89 en comparación a una aproximación tradicional con CGI.
90
91 %description -l fr.UTF-8
92 Mod_python est un module qui intègre l'interpréteur de langage Python
93 dans le serveur, permettant aux gestionnaires Apache d'être écrits en
94 Python.
95
96 Mod_python conjugue la versatilité de Python et la puissance du
97 serveur Web Apache de façon à augmenter considérablement la
98 flexibilité et la performance par rapport à une approche CGI
99 traditionnelle.
100
101 %description -l it.UTF-8
102 Mod_python è un modulo che integra nel server l'interprete del
103 linguaggio Python, in modo che i programmi di gestione possano essere
104 scritti in Python.
105
106 Mod_python unisce in sé la versatilità di Python e la potenza del
107 server Web Apache, con un conseguente accrescimento di flessibilità e
108 un miglioramento notevole nelle prestazioni rispetto all'approccio
109 tradizionale CGI.
110
111 %description -l ja.UTF-8
112 Mod_python はサーバー内に Python
113 言語インタープリタを組み込んだモジュール です。これにより、Apache
114 ハンドラを Python で記述できます。 Mod_python は、Python の汎用性と
115 Apache Web サーバーのパワーを組み合わせる ことにより、従来の CGI
116 アプローチから柔軟性とパフォーマンスを大幅に向上させます。
117
118 %description -l pl.UTF-8
119 mod_python jest modułem osadzającym interpreter języka Python w
120 serwerze WWW Apache, umożliwiając mu obsługę kodu napisanego w
121 Pythonie.
122
123 mod_python łączy wszechstronność Pythona i moc Apache'a jako serwera
124 WWW, co daje zwiększoną elastyczność i zauważalną poprawę wydajności w
125 stosunku do tradycyjnego rozwiązania opartego na CGI.
126
127 %description -l sv.UTF-8
128 Mod_python är en modul som bygger in en interpretator för språket
129 Python i servern, och låter Apach-hanterare skrivas i Python.
130
131 Mod_python sammanför mångsidigheten hos Python och kraften hos
132 webbservern Apache till en avsevärd ökning av flexibiliteten och
133 prestandan jämfört med den traditionella CGI-metoden.
134
135 %package -n apache-mod_python3
136 Summary:        An embedded Python 3 interpreter for the Apache Web server
137 Summary(cs.UTF-8):      Vestavěný interpret Pythonu 3 pro WWW server Apache
138 Summary(de.UTF-8):      Ein eingebetteter Python3-Interpreter für den Apache Web-Server
139 Summary(es.UTF-8):      Intérprete Python 3 para el servidor Web Apache
140 Summary(fr.UTF-8):      Interpréteur Python 3 intégré pour le serveur Web Apache
141 Summary(it.UTF-8):      Interprete Python 3 integrato per il server Web Apache
142 Summary(ja.UTF-8):      Apache Web サーバー用の組込み Python 3 インタープリタ
143 Summary(pl.UTF-8):      Wbudowany interpreter języka Python 3 dla serwera WWW Apache
144 Summary(sv.UTF-8):      En inbyggd Python3-interpretator för webbservern Apache
145 Group:          Networking/Daemons/HTTP
146 Requires:       apache(modules-api) = %apache_modules_api
147 Requires:       apr >= 1:1.0.0
148 # apache.py uses pdb module
149 Requires:       python3-devel-tools
150 %requires_eq    python3-libs
151 Conflicts:      apache-mod_python
152
153 %description -n apache-mod_python3
154 mod_python3 is a module that embeds the Python 3 language interpreter
155 within the server, allowing Apache handlers to be written in Python 3.
156
157 mod_python3 brings together the versatility of Python 3 and the power
158 of the Apache Web server for a considerable boost in flexibility and
159 performance over the traditional CGI approach.
160
161 %description -n apache-mod_python3 -l cs.UTF-8
162 Balíček mod_python3 obsahuje modul, který umožní serveru Apache přímo
163 interpretovat CGI skripty napsané v jazyce Python 3. To vede k
164 výraznému zvýšení rychlosti jejich provedení.
165
166 %description -n apache-mod_python3 -l de.UTF-8
167 mod_python3 ist ein Modul, das den Python3-Sprachinterpreter innerhalb
168 des Servers einbettet und es den Apache-Handlern ermöglicht,
169 in Python 3 geschrieben zu werden.
170
171 mod_python3 verbindet die Vielseitigkeit von Python 3 und die
172 Leistungsstärke des Apache Web-Servers, was eine enorme Steigerung der
173 Flexibilität und Leistung gegenüber dem traditionellen CGI-Ansatz
174 bedeutet.
175
176 %description -n apache-mod_python3 -l es.UTF-8
177 mod_python3 es un módulo que activa el intérprete de Python 3 en el
178 servidor, permitiendo que se escriban gestores para Apache en
179 Python 3.
180
181 mod_python3 proporciona la versatilidad y el poder del servidor web
182 Apache para acelerar considerablemente la flexibilidad y prestaciones
183 en comparación a una aproximación tradicional con CGI.
184
185 %description -n apache-mod_python3 -l fr.UTF-8
186 mod_python3 est un module qui intègre l'interpréteur de langage
187 Python 3 dans le serveur, permettant aux gestionnaires Apache d'être
188 écrits en Python 3.
189
190 mod_python3 conjugue la versatilité de Python 3 et la puissance du
191 serveur Web Apache de façon à augmenter considérablement la
192 flexibilité et la performance par rapport à une approche CGI
193 traditionnelle.
194
195 %description -n apache-mod_python3 -l it.UTF-8
196 mod_python3 è un modulo che integra nel server l'interprete del
197 linguaggio Python 3, in modo che i programmi di gestione possano
198 essere scritti in Python 3.
199
200 mod_python3 unisce in sé la versatilità di Python 3 e la potenza del
201 server Web Apache, con un conseguente accrescimento di flessibilità e
202 un miglioramento notevole nelle prestazioni rispetto all'approccio
203 tradizionale CGI.
204
205 %description -n apache-mod_python3 -l ja.UTF-8
206 mod_python3 はサーバー内に Python 3
207 言語インタープリタを組み込んだモジュール です。これにより、Apache
208 ハンドラを Python 3 で記述できます。 mod_python3 は、Python 3 
209 の汎用性と Apache Web サーバーのパワーを組み合わせる ことにより、
210 従来の CGI アプローチから柔軟性とパフォーマンスを大幅に向上させます。
211
212 %description -n apache-mod_python3 -l pl.UTF-8
213 mod_python3 jest modułem osadzającym interpreter języka Python 3 w
214 serwerze WWW Apache, umożliwiając mu obsługę kodu napisanego w
215 Pythonie 3.
216
217 mod_python3 łączy wszechstronność Pythona 3 i moc Apache'a jako
218 serwera WWW, co daje zwiększoną elastyczność i zauważalną poprawę
219 wydajności w stosunku do tradycyjnego rozwiązania opartego na CGI.
220
221 %description -n apache-mod_python3 -l sv.UTF-8
222 mod_python3 är en modul som bygger in en interpretator för språket
223 Python 3 i servern, och låter Apach-hanterare skrivas i Python 3.
224
225 mod_python3 sammanför mångsidigheten hos Python 3 och kraften hos
226 webbservern Apache till en avsevärd ökning av flexibiliteten och
227 prestandan jämfört med den traditionella CGI-metoden.
228
229 %prep
230 %setup -q -n mod_%{mod_name}-%{version}
231 %patch0 -p1
232 %patch1 -p1
233 %patch2 -p1
234
235 %build
236 %{__aclocal}
237 %{__autoconf}
238
239 %if %{with python2}
240 %configure \
241         --with-apxs=%{apxs} \
242         --with-python=%{__python}
243
244 %{__make} clean
245 %{__make} dso
246 install -d apache-mod_python{%{apachelibdir},%{apacheconfdir},%{_bindir}}
247 %{__make} install \
248         DESTDIR=`pwd`/apache-mod_python
249 %endif
250
251 %if %{with python3}
252 %configure \
253         --with-apxs=%{apxs} \
254         --with-python=%{__python3}
255
256 %{__make} clean
257 %{__make} dso
258 install -d apache-mod_python3{%{apachelibdir},%{apacheconfdir},%{_bindir}}
259 %{__make} install \
260         DESTDIR=`pwd`/apache-mod_python3
261 %{__mv} apache-mod_python3%{_bindir}/mod_python{,3}
262 %{__mv} apache-mod_python3%{apachelibdir}/mod_python{,3}.so
263 %endif
264
265 %install
266 rm -rf $RPM_BUILD_ROOT
267 install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir},%{_bindir}}
268
269 %if %{with python2}
270 cp -a apache-mod_python/* $RPM_BUILD_ROOT
271 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/60_mod_python.conf
272 %endif
273
274 %if %{with python3}
275 cp -a apache-mod_python3/* $RPM_BUILD_ROOT
276 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/60_mod_python3.conf
277 %endif
278
279 %py_postclean
280
281 %clean
282 rm -rf $RPM_BUILD_ROOT
283
284 %post
285 %service -q httpd restart
286
287 %postun
288 if [ "$1" = "0" ]; then
289         %service -q httpd restart
290 fi
291
292 %post -n apache-mod_python3
293 %service -q httpd restart
294
295 %postun -n apache-mod_python3
296 if [ "$1" = "0" ]; then
297         %service -q httpd restart
298 fi
299
300 %if %{with python2}
301 %files
302 %defattr(644,root,root,755)
303 %doc doc-html/* README.md COPYRIGHT NEWS CREDITS
304 %doc examples
305 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
306 %attr(755,root,root) %{_bindir}/mod_python
307 %attr(755,root,root) %{apachelibdir}/mod_python.so
308 %dir %{py_sitedir}/mod_%{mod_name}
309 %{py_sitedir}/mod_%{mod_name}-*.egg-info
310 %attr(755,root,root) %{py_sitedir}/mod_%{mod_name}/*.so
311 %{py_sitedir}/mod_%{mod_name}/*.py[co]
312 %endif
313
314 %if %{with python3}
315 %files -n apache-mod_python3
316 %defattr(644,root,root,755)
317 %doc doc-html/* README.md COPYRIGHT NEWS CREDITS
318 %doc examples
319 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}3.conf
320 %attr(755,root,root) %{_bindir}/mod_python3
321 %attr(755,root,root) %{apachelibdir}/mod_python3.so
322 %dir %{py3_sitedir}/mod_%{mod_name}
323 %{py3_sitedir}/mod_%{mod_name}-*.egg-info
324 %attr(755,root,root) %{py3_sitedir}/mod_%{mod_name}/*.so
325 %{py3_sitedir}/mod_%{mod_name}/__pycache__
326 %{py3_sitedir}/mod_%{mod_name}/*.py
327 %endif
This page took 0.059282 seconds and 3 git commands to generate.