]> git.pld-linux.org Git - packages/apache-mod_python.git/blob - apache-mod_python.spec
42a6bc5d0aec2de7960defe920b912a4c8e37fab
[packages/apache-mod_python.git] / apache-mod_python.spec
1
2 #
3 # todo:
4 # - configuration file in /etc/httpd/httpd.conf/ _directory_
5 #
6
7 %include        /usr/lib/rpm/macros.python
8 %define         mod_name        python
9 %define         apxs            /usr/sbin/apxs
10 Summary:        An embedded Python interpreter for the Apache Web server
11 Summary(cs):    Vestavìný interpret Pythonu pro WWW server Apache
12 Summary(da):    En indbygget Python-fortolker for webtjeneren Apache
13 Summary(de):    Ein eingebetteter Python-Interpreter für den Apache Web-Server
14 Summary(es):    Intérprete Perl para el servidor Web Apache
15 Summary(fr):    Interpréteur Python intégré pour le serveur Web Apache
16 Summary(id):    Interpreter Perl untuk web server Apache
17 Summary(is):    Perl túlkur fyrir Apache vefþjóninn
18 Summary(it):    Interprete Python integrato per il server Web Apache
19 Summary(ja):    Apache Web ¥µ¡¼¥Ð¡¼ÍѤÎÁȹþ¤ß Perl ¥¤¥ó¥¿¡¼¥×¥ê¥¿
20 Summary(no):    En Python-fortolker for webtjeneren Apache
21 Summary(pl):    Wbudowany interpreter Pythona dla serwera WWW Apache
22 Summary(pt):    Um interpretador de Perl embebido para o servidor Web Apache
23 Summary(ru):    ÷ÓÔÒÏÅÎÎÙÊ ÉÎÔÅÒÐÒÅÔÁÔÏÒ Perl ÄÌÑ WWW-ÓÅÒ×ÅÒÁ Apache
24 Summary(sk):    Interpreter jazyka Perl pre webový server Apache
25 Summary(sl):    Vkljuèeni pythonski tolmaè za spletni stre¾nik Apache
26 Summary(sv):    En inbyggd Python-interpretator för webbservern Apache
27 Name:           apache-mod_%{mod_name}
28 Version:        3.0.1
29 Release:        0.2
30 License:        Apache Group License
31 Group:          Networking/Daemons
32 Source0:        http://www.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
33 #Patch0:                %{name}-shared.patch
34 Patch1:         %{name}-DESTDIR.patch
35 Patch2:         %{name}-no-compile.patch
36 Patch3:         %{name}-cleanup.patch
37 # PLD keeps static libs in /usr/lib default python install stores them in .../config/
38 Patch4:         %{name}-static-lib-dir-fix.patch
39
40 URL:            http://www.modpython.org/
41 BuildRequires:  autoconf
42 BuildRequires:  automake
43 BuildRequires:  apache-devel >= 2.0.44
44 BuildRequires:  python-devel >= 2.2
45 BuildRequires:  rpm-pythonprov
46 BuildRequires:  %{apxs}
47 Prereq:         %{_sbindir}/apxs
48 Requires:       apache
49 %pyrequires_eq  python
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %define         apache_moddir   %(%{apxs} -q LIBEXECDIR)
53
54 %description
55 Mod_python is a module that embeds the Python language interpreter
56 within the server, allowing Apache handlers to be written in Python.
57
58 Mod_python brings together the versatility of Python and the power of
59 the Apache Web server for a considerable boost in flexibility and
60 performance over the traditional CGI approach.
61
62 %description -l cs
63 Balíèek mod_python obsahuje modul, který umo¾ní serveru Apache pøímo
64 interpretovat CGI skripty napsané v jazyce Python. To vede k výraznému
65 zvý¹ení rychlosti jejich provedení.
66
67 %description -l de
68 Mod_python ist ein Modul, das den Python-Sprachinterpreter innerhalb
69 des Servers einbettet und es den Apache-Handlern ermöglicht, in Python
70 geschrieben zu werden.
71
72 Mod_python verbindet die Vielseitigkeit von Python und die
73 Leistungsstärke des Apache Web-Servers, was eine enorme Steigerung der
74 Flexibilität und Leistung gegenüber dem traditionellen CGI-Ansatz
75 bedeutet.
76
77 %description -l es
78 Mod_python es un módulo que activa el intérprete de Python en el
79 servidor, permitiendo que se escriban gestores para Apache en Python.
80
81 Mod_python proporciona la versatilidad y el poder del servidor web
82 Apache para acelerar considerablemente la flexibilidad y prestaciones
83 en comparación a una aproximación tradicional con CGI.
84
85 %description -l fr
86 Mod_python est un module qui intègre l'interpréteur de langage Python
87 dans le serveur, permettant aux gestionnaires Apache d'être écrits en
88 Python.
89
90 Mod_python conjugue la versatilité de Python et la puissance du
91 serveur Web Apache de façon à augmenter considérablement la
92 flexibilité et la performance par rapport à une approche CGI
93 traditionnelle.
94
95 %description -l it
96 Mod_python è un modulo che integra nel server l'interprete del
97 linguaggio Python, in modo che i programmi di gestione possano essere
98 scritti in Python.
99
100 Mod_python unisce in sé la versatilità di Python e la potenza del
101 server Web Apache, con un conseguente accrescimento di flessibilità e
102 un miglioramento notevole nelle prestazioni rispetto all'approccio
103 tradizionale CGI.
104
105 %description -l ja
106 Mod_python ¤Ï¥µ¡¼¥Ð¡¼Æâ¤Ë Python
107 ¸À¸ì¥¤¥ó¥¿¡¼¥×¥ê¥¿¤òÁȤ߹þ¤ó¤À¥â¥¸¥å¡¼¥ë ¤Ç¤¹¡£¤³¤ì¤Ë¤è¤ê¡¢Apache
108 ¥Ï¥ó¥É¥é¤ò Python ¤Çµ­½Ò¤Ç¤­¤Þ¤¹¡£ Mod_python ¤Ï¡¢Python ¤ÎÈÆÍÑÀ­¤È
109 Apache Web ¥µ¡¼¥Ð¡¼¤Î¥Ñ¥ï¡¼¤òÁȤ߹ç¤ï¤»¤ë ¤³¤È¤Ë¤è¤ê¡¢½¾Íè¤Î CGI
110 ¥¢¥×¥í¡¼¥Á¤«¤é½ÀÆðÀ­¤È¥Ñ¥Õ¥©¡¼¥Þ¥ó¥¹¤òÂçÉý¤Ë¸þ¾å¤µ¤»¤Þ¤¹¡£
111
112 %description -l pl
113 mod_python jest modu³em osadzaj±cym interpreter jêzyka Python w
114 serwerze WWW Apache, umo¿liwiaj±c mu obs³ugê kodu napisanego w
115 Pythonie.
116
117 mod_python ³±czy wszechstronno¶æ Pythona i moc Apache'a jako serwera
118 WWW, co daje zwiêkszon± elastyczno¶æ i zauwa¿aln± poprawê wydajno¶ci w
119 stosunku do tradycyjnego rozwi±zania opartego na CGI.
120
121 %description -l sv
122 Mod_python är en modul som bygger in en interpretator för språket
123 Python i servern, och låter Apach-hanterare skrivas i Python.
124
125 Mod_python sammanför mångsidigheten hos Python och kraften hos
126 webbservern Apache till en avsevärd ökning av flexibiliteten och
127 prestandan jämfört med den traditionella CGI-metoden.
128
129 %prep
130 %setup -q -n mod_%{mod_name}-%{version}
131 # Patch reverted. Dynamic build makes apache segfault on all my i686 machines
132 # No working reports collected on IRC/mailing lists.
133 #%patch0 -p1
134 %patch1 -p1
135 %patch2 -p1
136 #%patch3 -p1
137 #%patch4 -p1
138
139 %build
140 %{__aclocal}
141 %{__autoconf}
142
143 # new apache needs it
144 CFLAGS="-DEAPI %{rpmcflags}"
145 %configure \
146         --with-apxs=%{apxs}
147
148 %{__make} dso
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152 install -d $RPM_BUILD_ROOT{%{apache_moddir},%{py_sitedir}/mod_%{mod_name}}
153
154 %{__make} install DESTDIR=$RPM_BUILD_ROOT
155
156 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
157 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post
163 if [ -f /var/lock/subsys/httpd ]; then
164         /etc/rc.d/init.d/httpd restart 1>&2
165 fi
166
167 %preun
168 if [ "$1" = "0" ]; then
169         if [ -f /var/lock/subsys/httpd ]; then
170                 /etc/rc.d/init.d/httpd restart 1>&2
171         fi
172 fi
173
174 %files
175 %defattr(644,root,root,755)
176 %doc doc-html/*
177 %doc README COPYRIGHT NEWS CREDITS
178 %attr(755,root,root) %{apache_moddir}/*
179 %dir %{py_sitedir}/mod_%{mod_name}
180 %{py_sitedir}/mod_%{mod_name}/*.py[co]
This page took 0.028137 seconds and 2 git commands to generate.