]> git.pld-linux.org Git - packages/apache-mod_python.git/blob - apache-mod_python.spec
- don't require runnable httpd
[packages/apache-mod_python.git] / apache-mod_python.spec
1 %define         mod_name        python
2 %define         apxs            /usr/sbin/apxs
3 Summary:        An embedded Python interpreter for the Apache Web server
4 Summary(cs):    Vestavìný interpret Pythonu pro WWW server Apache
5 Summary(da):    En indbygget Python-fortolker for webtjeneren Apache
6 Summary(de):    Ein eingebetteter Python-Interpreter für den Apache Web-Server
7 Summary(es):    Intérprete Perl para el servidor Web Apache
8 Summary(fr):    Interpréteur Python intégré pour le serveur Web Apache
9 Summary(id):    Interpreter Perl untuk web server Apache
10 Summary(is):    Perl túlkur fyrir Apache vefþjóninn
11 Summary(it):    Interprete Python integrato per il server Web Apache
12 Summary(ja):    Apache Web ¥µ¡¼¥Ð¡¼ÍѤÎÁȹþ¤ß Perl ¥¤¥ó¥¿¡¼¥×¥ê¥¿
13 Summary(nb):    En Python-fortolker for webtjeneren Apache
14 Summary(pl):    Wbudowany interpreter jêzyka Python dla serwera WWW Apache
15 Summary(pt):    Um interpretador de Perl embebido para o servidor Web Apache
16 Summary(ru):    ÷ÓÔÒÏÅÎÎÙÊ ÉÎÔÅÒÐÒÅÔÁÔÏÒ Perl ÄÌÑ WWW-ÓÅÒ×ÅÒÁ Apache
17 Summary(sk):    Interpreter jazyka Perl pre webový server Apache
18 Summary(sl):    Vkljuèeni pythonski tolmaè za spletni stre¾nik Apache
19 Summary(sv):    En inbyggd Python-interpretator för webbservern Apache
20 Name:           apache-mod_%{mod_name}
21 Version:        3.1.3
22 Release:        6
23 License:        Apache Group License
24 Group:          Networking/Daemons
25 Source0:        http://www.apache.org/dist/httpd/modpython/mod_%{mod_name}-%{version}.tgz
26 # Source0-md5:  2e1983e35edd428f308b0dfeb1c23bfe
27 Source1:        %{name}.conf
28 Patch0:         %{name}-lib64.patch
29 Patch1:         %{name}-apr-status-is-success.patch
30 Patch2:         %{name}-httpd-not-needed.patch
31 URL:            http://www.modpython.org/
32 BuildRequires:  %{apxs}
33 #BuildRequires: apache >= 2.0.44
34 BuildRequires:  apache-devel >= 2.0.52-7
35 BuildRequires:  apr-devel >= 1:1.0.0
36 BuildRequires:  autoconf
37 BuildRequires:  automake
38 BuildRequires:  flex >= 2.5.31
39 BuildRequires:  python
40 BuildRequires:  python-devel >= 2.2
41 BuildRequires:  rpm-pythonprov
42 Requires(post,preun):   %{apxs}
43 Requires:       apache >= 2.0.52-7
44 Requires:       apr >= 1:1.0.0
45 # apache.py uses pdb module
46 Requires:       python-devel-tools
47 %pyrequires_eq  python
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR)
51 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
52
53 %description
54 Mod_python is a module that embeds the Python language interpreter
55 within the server, allowing Apache handlers to be written in Python.
56
57 Mod_python brings together the versatility of Python and the power of
58 the Apache Web server for a considerable boost in flexibility and
59 performance over the traditional CGI approach.
60
61 %description -l cs
62 Balíèek mod_python obsahuje modul, který umo¾ní serveru Apache pøímo
63 interpretovat CGI skripty napsané v jazyce Python. To vede k výraznému
64 zvý¹ení rychlosti jejich provedení.
65
66 %description -l de
67 Mod_python ist ein Modul, das den Python-Sprachinterpreter innerhalb
68 des Servers einbettet und es den Apache-Handlern ermöglicht, in Python
69 geschrieben zu werden.
70
71 Mod_python verbindet die Vielseitigkeit von Python und die
72 Leistungsstärke des Apache Web-Servers, was eine enorme Steigerung der
73 Flexibilität und Leistung gegenüber dem traditionellen CGI-Ansatz
74 bedeutet.
75
76 %description -l es
77 Mod_python es un módulo que activa el intérprete de Python en el
78 servidor, permitiendo que se escriban gestores para Apache en Python.
79
80 Mod_python proporciona la versatilidad y el poder del servidor web
81 Apache para acelerar considerablemente la flexibilidad y prestaciones
82 en comparación a una aproximación tradicional con CGI.
83
84 %description -l fr
85 Mod_python est un module qui intègre l'interpréteur de langage Python
86 dans le serveur, permettant aux gestionnaires Apache d'être écrits en
87 Python.
88
89 Mod_python conjugue la versatilité de Python et la puissance du
90 serveur Web Apache de façon à augmenter considérablement la
91 flexibilité et la performance par rapport à une approche CGI
92 traditionnelle.
93
94 %description -l it
95 Mod_python è un modulo che integra nel server l'interprete del
96 linguaggio Python, in modo che i programmi di gestione possano essere
97 scritti in Python.
98
99 Mod_python unisce in sé la versatilità di Python e la potenza del
100 server Web Apache, con un conseguente accrescimento di flessibilità e
101 un miglioramento notevole nelle prestazioni rispetto all'approccio
102 tradizionale CGI.
103
104 %description -l ja
105 Mod_python ¤Ï¥µ¡¼¥Ð¡¼Æâ¤Ë Python
106 ¸À¸ì¥¤¥ó¥¿¡¼¥×¥ê¥¿¤òÁȤ߹þ¤ó¤À¥â¥¸¥å¡¼¥ë ¤Ç¤¹¡£¤³¤ì¤Ë¤è¤ê¡¢Apache
107 ¥Ï¥ó¥É¥é¤ò Python ¤Çµ­½Ò¤Ç¤­¤Þ¤¹¡£ Mod_python ¤Ï¡¢Python ¤ÎÈÆÍÑÀ­¤È
108 Apache Web ¥µ¡¼¥Ð¡¼¤Î¥Ñ¥ï¡¼¤òÁȤ߹ç¤ï¤»¤ë ¤³¤È¤Ë¤è¤ê¡¢½¾Íè¤Î CGI
109 ¥¢¥×¥í¡¼¥Á¤«¤é½ÀÆðÀ­¤È¥Ñ¥Õ¥©¡¼¥Þ¥ó¥¹¤òÂçÉý¤Ë¸þ¾å¤µ¤»¤Þ¤¹¡£
110
111 %description -l pl
112 mod_python jest modu³em osadzaj±cym interpreter jêzyka Python w
113 serwerze WWW Apache, umo¿liwiaj±c mu obs³ugê kodu napisanego w
114 Pythonie.
115
116 mod_python ³±czy wszechstronno¶æ Pythona i moc Apache'a jako serwera
117 WWW, co daje zwiêkszon± elastyczno¶æ i zauwa¿aln± poprawê wydajno¶ci w
118 stosunku do tradycyjnego rozwi±zania opartego na CGI.
119
120 %description -l sv
121 Mod_python är en modul som bygger in en interpretator för språket
122 Python i servern, och låter Apach-hanterare skrivas i Python.
123
124 Mod_python sammanför mångsidigheten hos Python och kraften hos
125 webbservern Apache till en avsevärd ökning av flexibiliteten och
126 prestandan jämfört med den traditionella CGI-metoden.
127
128 %prep
129 %setup -q -n mod_%{mod_name}-%{version}
130 %if "%{_libdir}" == "%{_prefix}/lib64"
131 %patch0
132 %endif
133 %patch1 -p1
134 %patch2 -p1
135
136 %build
137 %{__aclocal}
138 %{__autoconf}
139
140 # new apache needs it
141 CFLAGS="-DEAPI %{rpmcflags}"
142 %configure \
143         --with-apxs=%{apxs}
144
145 %{__make} dso
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149 install -d $RPM_BUILD_ROOT%{_pkglibdir} \
150         $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
151
152 %{__make} install \
153         DESTDIR=$RPM_BUILD_ROOT
154
155 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/60_mod_python.conf
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post
161 if [ -f /var/lock/subsys/httpd ]; then
162         /etc/rc.d/init.d/httpd restart 1>&2
163 fi
164
165 %preun
166 if [ "$1" = "0" ]; then
167         if [ -f /var/lock/subsys/httpd ]; then
168                 /etc/rc.d/init.d/httpd restart 1>&2
169         fi
170 fi
171
172 %files
173 %defattr(644,root,root,755)
174 %doc doc-html/* README COPYRIGHT NEWS CREDITS
175 %{_sysconfdir}/httpd.conf/60_mod_python.conf
176 %attr(755,root,root) %{_pkglibdir}/*.so
177 %dir %{py_sitedir}/mod_%{mod_name}
178 %attr(755,root,root) %{py_sitedir}/mod_%{mod_name}/*.so
179 %{py_sitedir}/mod_%{mod_name}/*.py[co]
This page took 0.04131 seconds and 3 git commands to generate.