]> git.pld-linux.org Git - packages/apache-mod_python.git/blob - apache-mod_python.spec
- cosmetics.
[packages/apache-mod_python.git] / apache-mod_python.spec
1 %define         mod_name        python
2 Summary:        A Python for the Apache Web server
3 Name:           apache-mod_%{mod_name}
4 Version:        2.4.1
5 Release:        1
6 License:        distributable
7 Group:          Networking/Daemons
8 Group(pl):      Sieciowe/Serwery
9 Source:         http://www.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
10 URL:            http://www.modpython.org/
11 Requires:       apache
12 Requires:       python 
13 BuildRequires:  apache
14 BuildRequires:  apache-devel
15 BuildRequires:  python-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define apache_moddir  %(/usr/sbin/apxs -q LIBEXECDIR)
19 %define python_prefix  %(echo `python -c "import sys; print sys.prefix"`)
20 %define python_version %(echo `python -c "import sys; print sys.version[:3]"`)
21 %define python_libdir      %{python_prefix}/lib/python%{python_version}
22 %define python_includedir  %{python_prefix}/include/python%{python_version}
23 %define python_sitedir     %{python_libdir}/site-packages
24
25 %description
26 mod_python allows embedding Python within the Apache Web server 
27 for a considerable boost in performance and added flexibility 
28 in designing web based applications. 
29
30 NOTE: This versions should still be considered Beta
31
32 %prep 
33 %setup -q -n mod_%{mod_name}-%{version}
34
35 %build
36 python %{python_libdir}/compileall.py lib/python/mod_python/
37
38 LDFLAGS=
39 # RH  
40 if [ -f %{python_libdir}/config/libpython%{python_version}.a ]; then 
41         LDFLAGS="$LDFLAGS -L%{python_libdir}/config/ -lpython%{python_version}"
42 # PLD 
43 else  
44         LDFLAGS="$LDFLAGS -lpython"
45 fi  
46  
47 if ldd %{python_prefix}/bin/python | grep libpthread >/dev/null; then 
48         LDFLAGS="$LDFLAGS -lpthread"
49 fi 
50
51 cd src
52 /usr/sbin/apxs -I%{python_includedir} $LDFLAGS -o mod_%{mod_name}.so -c mod_%{mod_name}.c
53 cd ..
54 gzip -9nf README COPYRIGHT NEWS CREDITS
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{%{apache_moddir},%{python_sitedir}/mod_%{mod_name}}
59
60 install src/mod_%{mod_name}.so $RPM_BUILD_ROOT%{apache_moddir}
61
62 strip --strip-unneeded $RPM_BUILD_ROOT%{apache_moddir}/* 
63
64 install lib/python/mod_python/* $RPM_BUILD_ROOT%{python_sitedir}/mod_%{mod_name}
65
66 %post
67 /usr/sbin/apxs -e -a -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
68 if [ -f /var/lock/subsys/httpd ]; then
69         /etc/rc.d/init.d/httpd restart 1>&2
70 fi
71
72 %preun
73 if [ "$1" = "0" ]; then
74         /usr/sbin/apxs -e -A -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
75         if [ -f /var/lock/subsys/httpd ]; then
76                 /etc/rc.d/init.d/httpd restart 1>&2
77         fi
78 fi
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc doc/*
86 %doc {README,COPYRIGHT,NEWS,CREDITS}.gz
87 %attr(755,root,root) %{apache_moddir}/*
88 %{python_sitedir}/mod_%{mod_name}
This page took 0.028902 seconds and 3 git commands to generate.