]> git.pld-linux.org Git - packages/apache-mod_python.git/blob - apache-mod_python.spec
- Fixes configure.in (different in PLD than oryginal python) static lib layout.
[packages/apache-mod_python.git] / apache-mod_python.spec
1 %include        /usr/lib/rpm/macros.python
2 %define         mod_name        python
3 %define         apxs            /usr/sbin/apxs
4 Summary:        An embedded Python interpreter for the Apache Web server
5 Summary(cs):    Vestavìný interpret Pythonu pro WWW server Apache
6 Summary(da):    En indbygget Python-fortolker for webtjeneren Apache
7 Summary(de):    Ein eingebetteter Python-Interpreter für den Apache Web-Server
8 Summary(es):    Intérprete Perl para el servidor Web Apache
9 Summary(fr):    Interpréteur Python intégré pour le serveur Web Apache
10 Summary(id):    Interpreter Perl untuk web server Apache
11 Summary(is):    Perl túlkur fyrir Apache vefþjóninn
12 Summary(it):    Interprete Python integrato per il server Web Apache
13 Summary(ja):    Apache Web ¥µ¡¼¥Ð¡¼ÍѤÎÁȹþ¤ß Perl ¥¤¥ó¥¿¡¼¥×¥ê¥¿
14 Summary(no):    En Python-fortolker for webtjeneren Apache
15 Summary(pl):    Wbudowany interpreter Pythona dla serwera WWW Apache
16 Summary(pt):    Um interpretador de Perl embebido para o servidor Web Apache
17 Summary(ru):    ÷ÓÔÒÏÅÎÎÙÊ ÉÎÔÅÒÐÒÅÔÁÔÏÒ Perl ÄÌÑ WWW-ÓÅÒ×ÅÒÁ Apache
18 Summary(sk):    Interpreter jazyka Perl pre webový server Apache
19 Summary(sl):    Vkljuèeni pythonski tolmaè za spletni stre¾nik Apache
20 Summary(sv):    En inbyggd Python-interpretator för webbservern Apache
21 Name:           apache-mod_%{mod_name}
22 Version:        2.7.8
23 Release:        4
24 License:        distributable
25 Group:          Networking/Daemons
26 Source0:        http://www.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
27 #Patch0:                %{name}-shared.patch
28 Patch1:         %{name}-DESTDIR.patch
29 Patch2:         %{name}-Makefile-in.patch
30 Patch3:         %{name}-cleanup.patch
31 URL:            http://www.modpython.org/
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 BuildRequires:  apache-devel
35 BuildRequires:  python-devel >= 2.2
36 # Necessary /usr/lib/python2.2/config/libpython2.2.a -> /usr/lib/libpython2.2.a added in 2.2.1-20
37 BuildRequires:  python-static >= 2.2.1-20
38 BuildRequires:  rpm-pythonprov
39 BuildRequires:  %{apxs}
40 Prereq:         %{_sbindir}/apxs
41 Requires:       apache
42 %pyrequires_eq  python
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         apache_moddir   %(%{apxs} -q LIBEXECDIR)
46
47 %description
48 Mod_python is a module that embeds the Python language interpreter
49 within the server, allowing Apache handlers to be written in Python.
50
51 Mod_python brings together the versatility of Python and the power of
52 the Apache Web server for a considerable boost in flexibility and
53 performance over the traditional CGI approach.
54
55 %description -l cs
56 Balíèek mod_python obsahuje modul, který umo¾ní serveru Apache pøímo
57 interpretovat CGI skripty napsané v jazyce Python. To vede k výraznému
58 zvý¹ení rychlosti jejich provedení.
59
60 %description -l de
61 Mod_python ist ein Modul, das den Python-Sprachinterpreter innerhalb
62 des Servers einbettet und es den Apache-Handlern ermöglicht, in Python
63 geschrieben zu werden.
64
65 Mod_python verbindet die Vielseitigkeit von Python und die
66 Leistungsstärke des Apache Web-Servers, was eine enorme Steigerung der
67 Flexibilität und Leistung gegenüber dem traditionellen CGI-Ansatz
68 bedeutet.
69
70 %description -l es
71 Mod_python es un módulo que activa el intérprete de Python en el
72 servidor, permitiendo que se escriban gestores para Apache en Python.
73
74 Mod_python proporciona la versatilidad y el poder del servidor web
75 Apache para acelerar considerablemente la flexibilidad y prestaciones
76 en comparación a una aproximación tradicional con CGI.
77
78 %description -l fr
79 Mod_python est un module qui intègre l'interpréteur de langage Python
80 dans le serveur, permettant aux gestionnaires Apache d'être écrits en
81 Python.
82
83 Mod_python conjugue la versatilité de Python et la puissance du
84 serveur Web Apache de façon à augmenter considérablement la
85 flexibilité et la performance par rapport à une approche CGI
86 traditionnelle.
87
88 %description -l it
89 Mod_python è un modulo che integra nel server l'interprete del
90 linguaggio Python, in modo che i programmi di gestione possano essere
91 scritti in Python.
92
93 Mod_python unisce in sé la versatilità di Python e la potenza del
94 server Web Apache, con un conseguente accrescimento di flessibilità e
95 un miglioramento notevole nelle prestazioni rispetto all'approccio
96 tradizionale CGI.
97
98 %description -l ja
99 Mod_python ¤Ï¥µ¡¼¥Ð¡¼Æâ¤Ë Python
100 ¸À¸ì¥¤¥ó¥¿¡¼¥×¥ê¥¿¤òÁȤ߹þ¤ó¤À¥â¥¸¥å¡¼¥ë ¤Ç¤¹¡£¤³¤ì¤Ë¤è¤ê¡¢Apache
101 ¥Ï¥ó¥É¥é¤ò Python ¤Çµ­½Ò¤Ç¤­¤Þ¤¹¡£ Mod_python ¤Ï¡¢Python ¤ÎÈÆÍÑÀ­¤È
102 Apache Web ¥µ¡¼¥Ð¡¼¤Î¥Ñ¥ï¡¼¤òÁȤ߹ç¤ï¤»¤ë ¤³¤È¤Ë¤è¤ê¡¢½¾Íè¤Î CGI
103 ¥¢¥×¥í¡¼¥Á¤«¤é½ÀÆðÀ­¤È¥Ñ¥Õ¥©¡¼¥Þ¥ó¥¹¤òÂçÉý¤Ë¸þ¾å¤µ¤»¤Þ¤¹¡£
104
105 %description -l pl
106 mod_python jest modu³em osadzaj±cym interpreter jêzyka Python w
107 serwerze WWW Apache, umo¿liwiaj±c mu obs³ugê kodu napisanego w
108 Pythonie.
109
110 mod_python ³±czy wszechstronno¶æ Pythona i moc Apache'a jako serwera
111 WWW, co daje zwiêkszon± elastyczno¶æ i zauwa¿aln± poprawê wydajno¶ci w
112 stosunku do tradycyjnego rozwi±zania opartego na CGI.
113
114 %description -l sv
115 Mod_python är en modul som bygger in en interpretator för språket
116 Python i servern, och låter Apach-hanterare skrivas i Python.
117
118 Mod_python sammanför mångsidigheten hos Python och kraften hos
119 webbservern Apache till en avsevärd ökning av flexibiliteten och
120 prestandan jämfört med den traditionella CGI-metoden.
121
122 %prep
123 %setup -q -n mod_%{mod_name}-%{version}
124 # Patch reverted. Dynamic build makes apache segfault on all my i686 machines
125 # No working reports collected on IRC/mailing lists.
126 #%patch0 -p1
127 %patch1 -p1
128 %patch2 -p1
129 %patch3 -p1
130
131 %build
132 %{__aclocal}
133 %{__autoconf}
134
135 # new apache needs it
136 CFLAGS="-DEAPI %{rpmcflags}"
137 %configure \
138         --with-apxs=%{apxs}
139
140 %{__make} dso
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144 install -d $RPM_BUILD_ROOT{%{apache_moddir},%{py_sitedir}/mod_%{mod_name}}
145
146 %{__make} install DESTDIR=$RPM_BUILD_ROOT
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post
152 %{apxs} -e -a -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
153 if [ -f /var/lock/subsys/httpd ]; then
154         /etc/rc.d/init.d/httpd restart 1>&2
155 fi
156
157 %preun
158 if [ "$1" = "0" ]; then
159         %{apxs} -e -A -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
160         if [ -f /var/lock/subsys/httpd ]; then
161                 /etc/rc.d/init.d/httpd restart 1>&2
162         fi
163 fi
164
165 %files
166 %defattr(644,root,root,755)
167 %doc doc-html/*
168 %doc README COPYRIGHT NEWS CREDITS
169 %attr(755,root,root) %{apache_moddir}/*
170 %{py_sitedir}/mod_%{mod_name}
This page took 0.032528 seconds and 3 git commands to generate.