]> git.pld-linux.org Git - packages/apache-mod_python.git/blame_incremental - apache-mod_python.spec
- one more git call removed
[packages/apache-mod_python.git] / apache-mod_python.spec
... / ...
CommitLineData
1%define mod_name python
2%define apxs /usr/sbin/apxs
3Summary: An embedded Python interpreter for the Apache Web server
4Summary(cs.UTF-8): Vestavěný interpret Pythonu pro WWW server Apache
5Summary(da.UTF-8): En indbygget Python-fortolker for webtjeneren Apache
6Summary(de.UTF-8): Ein eingebetteter Python-Interpreter für den Apache Web-Server
7Summary(es.UTF-8): Intérprete Perl para el servidor Web Apache
8Summary(fr.UTF-8): Interpréteur Python intégré pour le serveur Web Apache
9Summary(id.UTF-8): Interpreter Perl untuk web server Apache
10Summary(is.UTF-8): Perl túlkur fyrir Apache vefþjóninn
11Summary(it.UTF-8): Interprete Python integrato per il server Web Apache
12Summary(ja.UTF-8): Apache Web サーバー用の組込み Perl インタープリタ
13Summary(nb.UTF-8): En Python-fortolker for webtjeneren Apache
14Summary(pl.UTF-8): Wbudowany interpreter języka Python dla serwera WWW Apache
15Summary(pt.UTF-8): Um interpretador de Perl embebido para o servidor Web Apache
16Summary(ru.UTF-8): Встроенный интерпретатор Perl для WWW-сервера Apache
17Summary(sk.UTF-8): Interpreter jazyka Perl pre webový server Apache
18Summary(sl.UTF-8): Vključeni pythonski tolmač za spletni strežnik Apache
19Summary(sv.UTF-8): En inbyggd Python-interpretator för webbservern Apache
20Name: apache-mod_%{mod_name}
21Version: 3.4.1
22Release: 4
23License: Apache
24Group: Networking/Daemons/HTTP
25Source0: http://dist.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
26# Source0-md5: d27804354f1808ad55d432fd76ed9d05
27Source1: %{name}.conf
28Patch0: %{name}-httpd-not-needed.patch
29Patch1: no-git.patch
30URL: http://www.modpython.org/
31BuildRequires: apache-devel >= 2.0.52-7
32BuildRequires: apr-devel >= 1:1.0.0
33BuildRequires: autoconf
34BuildRequires: automake
35BuildRequires: flex >= 2.5.31
36BuildRequires: python
37BuildRequires: python-devel >= 2.2
38BuildRequires: rpm-pythonprov
39BuildRequires: rpmbuild(macros) >= 1.268
40Requires: apache(modules-api) = %apache_modules_api
41Requires: apr >= 1:1.0.0
42# apache.py uses pdb module
43Requires: python-devel-tools
44%requires_eq python-libs
45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
48%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
49
50%description
51Mod_python is a module that embeds the Python language interpreter
52within the server, allowing Apache handlers to be written in Python.
53
54Mod_python brings together the versatility of Python and the power of
55the Apache Web server for a considerable boost in flexibility and
56performance over the traditional CGI approach.
57
58%description -l cs.UTF-8
59Balíček mod_python obsahuje modul, který umožní serveru Apache přímo
60interpretovat CGI skripty napsané v jazyce Python. To vede k výraznému
61zvýšení rychlosti jejich provedení.
62
63%description -l de.UTF-8
64Mod_python ist ein Modul, das den Python-Sprachinterpreter innerhalb
65des Servers einbettet und es den Apache-Handlern ermöglicht, in Python
66geschrieben zu werden.
67
68Mod_python verbindet die Vielseitigkeit von Python und die
69Leistungsstärke des Apache Web-Servers, was eine enorme Steigerung der
70Flexibilität und Leistung gegenüber dem traditionellen CGI-Ansatz
71bedeutet.
72
73%description -l es.UTF-8
74Mod_python es un módulo que activa el intérprete de Python en el
75servidor, permitiendo que se escriban gestores para Apache en Python.
76
77Mod_python proporciona la versatilidad y el poder del servidor web
78Apache para acelerar considerablemente la flexibilidad y prestaciones
79en comparación a una aproximación tradicional con CGI.
80
81%description -l fr.UTF-8
82Mod_python est un module qui intègre l'interpréteur de langage Python
83dans le serveur, permettant aux gestionnaires Apache d'être écrits en
84Python.
85
86Mod_python conjugue la versatilité de Python et la puissance du
87serveur Web Apache de façon à augmenter considérablement la
88flexibilité et la performance par rapport à une approche CGI
89traditionnelle.
90
91%description -l it.UTF-8
92Mod_python è un modulo che integra nel server l'interprete del
93linguaggio Python, in modo che i programmi di gestione possano essere
94scritti in Python.
95
96Mod_python unisce in sé la versatilità di Python e la potenza del
97server Web Apache, con un conseguente accrescimento di flessibilità e
98un miglioramento notevole nelle prestazioni rispetto all'approccio
99tradizionale CGI.
100
101%description -l ja.UTF-8
102Mod_python はサーバー内に Python
103言語インタープリタを組み込んだモジュール です。これにより、Apache
104ハンドラを Python で記述できます。 Mod_python は、Python の汎用性と
105Apache Web サーバーのパワーを組み合わせる ことにより、従来の CGI
106アプローチから柔軟性とパフォーマンスを大幅に向上させます。
107
108%description -l pl.UTF-8
109mod_python jest modułem osadzającym interpreter języka Python w
110serwerze WWW Apache, umożliwiając mu obsługę kodu napisanego w
111Pythonie.
112
113mod_python łączy wszechstronność Pythona i moc Apache'a jako serwera
114WWW, co daje zwiększoną elastyczność i zauważalną poprawę wydajności w
115stosunku do tradycyjnego rozwiązania opartego na CGI.
116
117%description -l sv.UTF-8
118Mod_python är en modul som bygger in en interpretator för språket
119Python i servern, och låter Apach-hanterare skrivas i Python.
120
121Mod_python sammanför mångsidigheten hos Python och kraften hos
122webbservern Apache till en avsevärd ökning av flexibiliteten och
123prestandan jämfört med den traditionella CGI-metoden.
124
125%prep
126%setup -q -n mod_%{mod_name}-%{version}
127%patch0 -p1
128%patch1 -p1
129
130%build
131%{__aclocal}
132%{__autoconf}
133%configure \
134 --with-apxs=%{apxs}
135%{__make} dso
136
137%install
138rm -rf $RPM_BUILD_ROOT
139install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir},%{_bindir}}
140
141%{__make} install \
142 DESTDIR=$RPM_BUILD_ROOT
143
144install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/60_mod_python.conf
145%py_postclean
146
147%clean
148rm -rf $RPM_BUILD_ROOT
149
150%post
151%service -q httpd restart
152
153%postun
154if [ "$1" = "0" ]; then
155 %service -q httpd restart
156fi
157
158%files
159%defattr(644,root,root,755)
160%doc doc-html/* README.md COPYRIGHT NEWS CREDITS
161%doc examples
162%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
163%attr(755,root,root) %{_bindir}/mod_python
164%attr(755,root,root) %{apachelibdir}/*.so
165%dir %{py_sitedir}/mod_%{mod_name}
166%if "%{py_ver}" > "2.4"
167%{py_sitedir}/mod_%{mod_name}-*.egg-info
168%endif
169%attr(755,root,root) %{py_sitedir}/mod_%{mod_name}/*.so
170%{py_sitedir}/mod_%{mod_name}/*.py[co]
This page took 0.034225 seconds and 4 git commands to generate.