]> git.pld-linux.org Git - packages/apache-mod_python.git/blame_incremental - apache-mod_python.spec
- release 9
[packages/apache-mod_python.git] / apache-mod_python.spec
... / ...
CommitLineData
1%define mod_name python
2%define apxs /usr/sbin/apxs
3Summary: An embedded Python interpreter for the Apache Web server
4Summary(cs.UTF-8): Vestavěný interpret Pythonu pro WWW server Apache
5Summary(da.UTF-8): En indbygget Python-fortolker for webtjeneren Apache
6Summary(de.UTF-8): Ein eingebetteter Python-Interpreter für den Apache Web-Server
7Summary(es.UTF-8): Intérprete Perl para el servidor Web Apache
8Summary(fr.UTF-8): Interpréteur Python intégré pour le serveur Web Apache
9Summary(id.UTF-8): Interpreter Perl untuk web server Apache
10Summary(is.UTF-8): Perl túlkur fyrir Apache vefþjóninn
11Summary(it.UTF-8): Interprete Python integrato per il server Web Apache
12Summary(ja.UTF-8): Apache Web サーバー用の組込み Perl インタープリタ
13Summary(nb.UTF-8): En Python-fortolker for webtjeneren Apache
14Summary(pl.UTF-8): Wbudowany interpreter języka Python dla serwera WWW Apache
15Summary(pt.UTF-8): Um interpretador de Perl embebido para o servidor Web Apache
16Summary(ru.UTF-8): Встроенный интерпретатор Perl для WWW-сервера Apache
17Summary(sk.UTF-8): Interpreter jazyka Perl pre webový server Apache
18Summary(sl.UTF-8): Vključeni pythonski tolmač za spletni strežnik Apache
19Summary(sv.UTF-8): En inbyggd Python-interpretator för webbservern Apache
20Name: apache-mod_%{mod_name}
21Version: 3.3.1
22Release: 9
23License: Apache Group License
24Group: Networking/Daemons/HTTP
25Source0: http://www.apache.org/dist/httpd/modpython/mod_%{mod_name}-%{version}.tgz
26# Source0-md5: a3b0150176b726bd2833dac3a7837dc5
27Source1: %{name}.conf
28Patch0: %{name}-httpd-not-needed.patch
29Patch1: %{name}-ldflags.patch
30Patch2: %{name}-apr_brigade_sentinel.patch
31URL: http://www.modpython.org/
32BuildRequires: %{apxs}
33BuildRequires: apache-devel >= 2.0.52-7
34BuildRequires: apr-devel >= 1:1.0.0
35BuildRequires: autoconf
36BuildRequires: automake
37BuildRequires: flex >= 2.5.31
38BuildRequires: python
39BuildRequires: python-devel >= 2.2
40BuildRequires: rpm-pythonprov
41BuildRequires: rpmbuild(macros) >= 1.268
42Requires: apache(modules-api) = %apache_modules_api
43Requires: apr >= 1:1.0.0
44# apache.py uses pdb module
45Requires: python-devel-tools
46%requires_eq python-libs
47BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
50%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
51
52%description
53Mod_python is a module that embeds the Python language interpreter
54within the server, allowing Apache handlers to be written in Python.
55
56Mod_python brings together the versatility of Python and the power of
57the Apache Web server for a considerable boost in flexibility and
58performance over the traditional CGI approach.
59
60%description -l cs.UTF-8
61Balíček mod_python obsahuje modul, který umožní serveru Apache přímo
62interpretovat CGI skripty napsané v jazyce Python. To vede k výraznému
63zvýšení rychlosti jejich provedení.
64
65%description -l de.UTF-8
66Mod_python ist ein Modul, das den Python-Sprachinterpreter innerhalb
67des Servers einbettet und es den Apache-Handlern ermöglicht, in Python
68geschrieben zu werden.
69
70Mod_python verbindet die Vielseitigkeit von Python und die
71Leistungsstärke des Apache Web-Servers, was eine enorme Steigerung der
72Flexibilität und Leistung gegenüber dem traditionellen CGI-Ansatz
73bedeutet.
74
75%description -l es.UTF-8
76Mod_python es un módulo que activa el intérprete de Python en el
77servidor, permitiendo que se escriban gestores para Apache en Python.
78
79Mod_python proporciona la versatilidad y el poder del servidor web
80Apache para acelerar considerablemente la flexibilidad y prestaciones
81en comparación a una aproximación tradicional con CGI.
82
83%description -l fr.UTF-8
84Mod_python est un module qui intègre l'interpréteur de langage Python
85dans le serveur, permettant aux gestionnaires Apache d'être écrits en
86Python.
87
88Mod_python conjugue la versatilité de Python et la puissance du
89serveur Web Apache de façon à augmenter considérablement la
90flexibilité et la performance par rapport à une approche CGI
91traditionnelle.
92
93%description -l it.UTF-8
94Mod_python è un modulo che integra nel server l'interprete del
95linguaggio Python, in modo che i programmi di gestione possano essere
96scritti in Python.
97
98Mod_python unisce in sé la versatilità di Python e la potenza del
99server Web Apache, con un conseguente accrescimento di flessibilità e
100un miglioramento notevole nelle prestazioni rispetto all'approccio
101tradizionale CGI.
102
103%description -l ja.UTF-8
104Mod_python はサーバー内に Python
105言語インタープリタを組み込んだモジュール です。これにより、Apache
106ハンドラを Python で記述できます。 Mod_python は、Python の汎用性と
107Apache Web サーバーのパワーを組み合わせる ことにより、従来の CGI
108アプローチから柔軟性とパフォーマンスを大幅に向上させます。
109
110%description -l pl.UTF-8
111mod_python jest modułem osadzającym interpreter języka Python w
112serwerze WWW Apache, umożliwiając mu obsługę kodu napisanego w
113Pythonie.
114
115mod_python łączy wszechstronność Pythona i moc Apache'a jako serwera
116WWW, co daje zwiększoną elastyczność i zauważalną poprawę wydajności w
117stosunku do tradycyjnego rozwiązania opartego na CGI.
118
119%description -l sv.UTF-8
120Mod_python är en modul som bygger in en interpretator för språket
121Python i servern, och låter Apach-hanterare skrivas i Python.
122
123Mod_python sammanför mångsidigheten hos Python och kraften hos
124webbservern Apache till en avsevärd ökning av flexibiliteten och
125prestandan jämfört med den traditionella CGI-metoden.
126
127%prep
128%setup -q -n mod_%{mod_name}-%{version}
129%patch0 -p1
130%patch1 -p1
131%patch2 -p1
132
133%build
134%{__aclocal}
135%{__autoconf}
136%configure \
137 --with-apxs=%{apxs}
138%{__make} dso
139
140%install
141rm -rf $RPM_BUILD_ROOT
142install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir}}
143
144%{__make} install \
145 DESTDIR=$RPM_BUILD_ROOT
146
147install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/60_mod_python.conf
148%py_postclean
149
150%clean
151rm -rf $RPM_BUILD_ROOT
152
153%post
154%service -q httpd restart
155
156%postun
157if [ "$1" = "0" ]; then
158 %service -q httpd restart
159fi
160
161%files
162%defattr(644,root,root,755)
163%doc doc-html/* README COPYRIGHT NEWS CREDITS
164%doc examples
165%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
166%attr(755,root,root) %{apachelibdir}/*.so
167%dir %{py_sitedir}/mod_%{mod_name}
168%attr(755,root,root) %{py_sitedir}/mod_%{mod_name}/*.so
169%{py_sitedir}/mod_%{mod_name}/*.py[co]
This page took 0.024616 seconds and 4 git commands to generate.