]> git.pld-linux.org Git - packages/apache-mod_python.git/blame_incremental - apache-mod_python.spec
- updated to 3.4.1
[packages/apache-mod_python.git] / apache-mod_python.spec
... / ...
CommitLineData
1%define mod_name python
2%define apxs /usr/sbin/apxs
3Summary: An embedded Python interpreter for the Apache Web server
4Summary(cs.UTF-8): Vestavěný interpret Pythonu pro WWW server Apache
5Summary(da.UTF-8): En indbygget Python-fortolker for webtjeneren Apache
6Summary(de.UTF-8): Ein eingebetteter Python-Interpreter für den Apache Web-Server
7Summary(es.UTF-8): Intérprete Perl para el servidor Web Apache
8Summary(fr.UTF-8): Interpréteur Python intégré pour le serveur Web Apache
9Summary(id.UTF-8): Interpreter Perl untuk web server Apache
10Summary(is.UTF-8): Perl túlkur fyrir Apache vefþjóninn
11Summary(it.UTF-8): Interprete Python integrato per il server Web Apache
12Summary(ja.UTF-8): Apache Web サーバー用の組込み Perl インタープリタ
13Summary(nb.UTF-8): En Python-fortolker for webtjeneren Apache
14Summary(pl.UTF-8): Wbudowany interpreter języka Python dla serwera WWW Apache
15Summary(pt.UTF-8): Um interpretador de Perl embebido para o servidor Web Apache
16Summary(ru.UTF-8): Встроенный интерпретатор Perl для WWW-сервера Apache
17Summary(sk.UTF-8): Interpreter jazyka Perl pre webový server Apache
18Summary(sl.UTF-8): Vključeni pythonski tolmač za spletni strežnik Apache
19Summary(sv.UTF-8): En inbyggd Python-interpretator för webbservern Apache
20Name: apache-mod_%{mod_name}
21Version: 3.4.1
22Release: 1
23License: Apache
24Group: Networking/Daemons/HTTP
25Source0: http://dist.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
26# Source0-md5: d27804354f1808ad55d432fd76ed9d05
27Source1: %{name}.conf
28Patch0: %{name}-httpd-not-needed.patch
29URL: http://www.modpython.org/
30BuildRequires: apache-devel >= 2.0.52-7
31BuildRequires: apr-devel >= 1:1.0.0
32BuildRequires: autoconf
33BuildRequires: automake
34BuildRequires: flex >= 2.5.31
35BuildRequires: python
36BuildRequires: python-devel >= 2.2
37BuildRequires: rpm-pythonprov
38BuildRequires: rpmbuild(macros) >= 1.268
39Requires: apache(modules-api) = %apache_modules_api
40Requires: apr >= 1:1.0.0
41# apache.py uses pdb module
42Requires: python-devel-tools
43%requires_eq python-libs
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
47%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
48
49%description
50Mod_python is a module that embeds the Python language interpreter
51within the server, allowing Apache handlers to be written in Python.
52
53Mod_python brings together the versatility of Python and the power of
54the Apache Web server for a considerable boost in flexibility and
55performance over the traditional CGI approach.
56
57%description -l cs.UTF-8
58Balíček mod_python obsahuje modul, který umožní serveru Apache přímo
59interpretovat CGI skripty napsané v jazyce Python. To vede k výraznému
60zvýšení rychlosti jejich provedení.
61
62%description -l de.UTF-8
63Mod_python ist ein Modul, das den Python-Sprachinterpreter innerhalb
64des Servers einbettet und es den Apache-Handlern ermöglicht, in Python
65geschrieben zu werden.
66
67Mod_python verbindet die Vielseitigkeit von Python und die
68Leistungsstärke des Apache Web-Servers, was eine enorme Steigerung der
69Flexibilität und Leistung gegenüber dem traditionellen CGI-Ansatz
70bedeutet.
71
72%description -l es.UTF-8
73Mod_python es un módulo que activa el intérprete de Python en el
74servidor, permitiendo que se escriban gestores para Apache en Python.
75
76Mod_python proporciona la versatilidad y el poder del servidor web
77Apache para acelerar considerablemente la flexibilidad y prestaciones
78en comparación a una aproximación tradicional con CGI.
79
80%description -l fr.UTF-8
81Mod_python est un module qui intègre l'interpréteur de langage Python
82dans le serveur, permettant aux gestionnaires Apache d'être écrits en
83Python.
84
85Mod_python conjugue la versatilité de Python et la puissance du
86serveur Web Apache de façon à augmenter considérablement la
87flexibilité et la performance par rapport à une approche CGI
88traditionnelle.
89
90%description -l it.UTF-8
91Mod_python è un modulo che integra nel server l'interprete del
92linguaggio Python, in modo che i programmi di gestione possano essere
93scritti in Python.
94
95Mod_python unisce in sé la versatilità di Python e la potenza del
96server Web Apache, con un conseguente accrescimento di flessibilità e
97un miglioramento notevole nelle prestazioni rispetto all'approccio
98tradizionale CGI.
99
100%description -l ja.UTF-8
101Mod_python はサーバー内に Python
102言語インタープリタを組み込んだモジュール です。これにより、Apache
103ハンドラを Python で記述できます。 Mod_python は、Python の汎用性と
104Apache Web サーバーのパワーを組み合わせる ことにより、従来の CGI
105アプローチから柔軟性とパフォーマンスを大幅に向上させます。
106
107%description -l pl.UTF-8
108mod_python jest modułem osadzającym interpreter języka Python w
109serwerze WWW Apache, umożliwiając mu obsługę kodu napisanego w
110Pythonie.
111
112mod_python łączy wszechstronność Pythona i moc Apache'a jako serwera
113WWW, co daje zwiększoną elastyczność i zauważalną poprawę wydajności w
114stosunku do tradycyjnego rozwiązania opartego na CGI.
115
116%description -l sv.UTF-8
117Mod_python är en modul som bygger in en interpretator för språket
118Python i servern, och låter Apach-hanterare skrivas i Python.
119
120Mod_python sammanför mångsidigheten hos Python och kraften hos
121webbservern Apache till en avsevärd ökning av flexibiliteten och
122prestandan jämfört med den traditionella CGI-metoden.
123
124%prep
125%setup -q -n mod_%{mod_name}-%{version}
126%patch0 -p1
127
128%build
129%{__aclocal}
130%{__autoconf}
131%configure \
132 --with-apxs=%{apxs}
133%{__make} dso
134
135%install
136rm -rf $RPM_BUILD_ROOT
137install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir},%{_bindir}}
138
139%{__make} install \
140 DESTDIR=$RPM_BUILD_ROOT
141
142install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/60_mod_python.conf
143%py_postclean
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%post
149%service -q httpd restart
150
151%postun
152if [ "$1" = "0" ]; then
153 %service -q httpd restart
154fi
155
156%files
157%defattr(644,root,root,755)
158%doc doc-html/* README.md COPYRIGHT NEWS CREDITS
159%doc examples
160%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
161%attr(755,root,root) %{_bindir}/mod_python
162%attr(755,root,root) %{apachelibdir}/*.so
163%dir %{py_sitedir}/mod_%{mod_name}
164%if "%{py_ver}" > "2.4"
165%{py_sitedir}/mod_%{mod_name}-*.egg-info
166%endif
167%attr(755,root,root) %{py_sitedir}/mod_%{mod_name}/*.so
168%{py_sitedir}/mod_%{mod_name}/*.py[co]
This page took 0.029836 seconds and 4 git commands to generate.