]> git.pld-linux.org Git - packages/apache-mod_proctitle.git/blobdiff - apache-mod_proctitle.spec
Some ancient file.
[packages/apache-mod_proctitle.git] / apache-mod_proctitle.spec
index 71a4ba9df0b4689642d2ca4ac2a48ab03a049c17..66dfc6d13201e1f34ea1cfc5ec83ad7b9fa2920a 100644 (file)
@@ -2,14 +2,18 @@
 %define        apxs            /usr/sbin/apxs
 Summary:       Apache module: set process name to currently serverd virtual host
 Name:          apache-mod_%{mod_name}
-Version:       0.1
-Release:       0.20080707.2
-License:       Apache v2.0
+Version:       0.4
+Release:       6
+License:       BSD
 Group:         Networking/Daemons/HTTP
-Source0:       mod_proctitle.c
+Source0:       https://github.com/stass/mod_proctitle/archive/0.4.tar.gz
+# Source0-md5: 83043432da02f0ebf6de4badbe404dcd
+Patch0:                setproctitle.patch
+URL:           https://github.com/stass/mod_proctitle
 BuildRequires: %{apxs}
 BuildRequires: apache-devel >= 2.0
 BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: setproctitle-devel
 Requires:      apache(modules-api) = %apache_modules_api
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -21,19 +25,32 @@ mod_proctitle is an experimental module for Apache httpd 2.x which
 changes process name to currently served virtual host.
 
 %prep
-%setup -q -c -T
-install %{SOURCE0} .
+%setup -q -n mod_%{mod_name}-%{version}
+%patch0 -p1
 
 %build
-%{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.la
+%{__libtoolize}
+%{__aclocal}
+%{__autoheader}
+%{__autoconf}
+%{__automake}
+
+CPPFLAGS="%{rpmcppflags} -D__unused='__attribute__ ((__unused__))'" \
+APXS="%{apxs}" \
+%configure
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
-install -p .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
+install -d $RPM_BUILD_ROOT%{_sysconfdir}
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 cat > $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf << 'EOF'
 LoadModule %{mod_name}_module modules/mod_%{mod_name}.so
+ProctitleEnable On
+# ProctitleUriSep ::
 EOF
 
 %clean
@@ -49,5 +66,6 @@ fi
 
 %files
 %defattr(644,root,root,755)
+%doc AUTHORS README 
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
-%attr(755,root,root) %{_pkglibdir}/*.so
+%attr(755,root,root) %{_pkglibdir}/mod_proctitle.so
This page took 0.076501 seconds and 4 git commands to generate.