]> git.pld-linux.org Git - packages/apache-mod_proctitle.git/blob - apache-mod_proctitle.spec
Some ancient file.
[packages/apache-mod_proctitle.git] / apache-mod_proctitle.spec
1 %define         mod_name        proctitle
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache module: set process name to currently serverd virtual host
4 Name:           apache-mod_%{mod_name}
5 Version:        0.4
6 Release:        6
7 License:        BSD
8 Group:          Networking/Daemons/HTTP
9 Source0:        https://github.com/stass/mod_proctitle/archive/0.4.tar.gz
10 # Source0-md5:  83043432da02f0ebf6de4badbe404dcd
11 Patch0:         setproctitle.patch
12 URL:            https://github.com/stass/mod_proctitle
13 BuildRequires:  %{apxs}
14 BuildRequires:  apache-devel >= 2.0
15 BuildRequires:  rpmbuild(macros) >= 1.268
16 BuildRequires:  setproctitle-devel
17 Requires:       apache(modules-api) = %apache_modules_api
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
21 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
22
23 %description
24 mod_proctitle is an experimental module for Apache httpd 2.x which
25 changes process name to currently served virtual host.
26
27 %prep
28 %setup -q -n mod_%{mod_name}-%{version}
29 %patch0 -p1
30
31 %build
32 %{__libtoolize}
33 %{__aclocal}
34 %{__autoheader}
35 %{__autoconf}
36 %{__automake}
37
38 CPPFLAGS="%{rpmcppflags} -D__unused='__attribute__ ((__unused__))'" \
39 APXS="%{apxs}" \
40 %configure
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT%{_sysconfdir}
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 cat > $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf << 'EOF'
51 LoadModule %{mod_name}_module modules/mod_%{mod_name}.so
52 ProctitleEnable On
53 # ProctitleUriSep ::
54 EOF
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 %service -q httpd restart
61
62 %postun
63 if [ "$1" = "0" ]; then
64         %service -q httpd restart
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %doc AUTHORS README 
70 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
71 %attr(755,root,root) %{_pkglibdir}/mod_proctitle.so
This page took 0.044026 seconds and 3 git commands to generate.