]> git.pld-linux.org Git - packages/apache-mod_proctitle.git/blame - apache-mod_proctitle.spec
- rel 2; force apxs setting
[packages/apache-mod_proctitle.git] / apache-mod_proctitle.spec
CommitLineData
d63b6576
AM
1%define mod_name proctitle
2%define apxs /usr/sbin/apxs
3Summary: Apache module: set process name to currently serverd virtual host
4Name: apache-mod_%{mod_name}
1407fa5c 5Version: 0.4
9e16dbc9 6Release: 2
d63b6576 7License: Apache v2.0
c65d608a 8Group: Networking/Daemons/HTTP
1407fa5c
AM
9Source0: https://github.com/stass/mod_proctitle/archive/0.4.tar.gz
10# Source0-md5: 83043432da02f0ebf6de4badbe404dcd
11Patch0: setproctitle.patch
12URL: https://github.com/stass/mod_proctitle
d63b6576
AM
13BuildRequires: %{apxs}
14BuildRequires: apache-devel >= 2.0
15BuildRequires: rpmbuild(macros) >= 1.268
1407fa5c 16BuildRequires: setproctitle-devel
d63b6576
AM
17Requires: apache(modules-api) = %apache_modules_api
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
5d018c58 21%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
d63b6576
AM
22
23%description
24mod_proctitle is an experimental module for Apache httpd 2.x which
25changes process name to currently served virtual host.
26
27%prep
1407fa5c
AM
28%setup -q -n mod_%{mod_name}-%{version}
29%patch0 -p1
d63b6576
AM
30
31%build
1407fa5c
AM
32%{__libtoolize}
33%{__aclocal}
34%{__autoheader}
35%{__autoconf}
36%{__automake}
37
38CPPFLAGS="%{rpmcppflags} -D__unused='__attribute__ ((__unused__))'" \
9e16dbc9 39APXS="%{apxs}" \
1407fa5c
AM
40%configure
41%{__make}
d63b6576
AM
42
43%install
44rm -rf $RPM_BUILD_ROOT
1407fa5c
AM
45install -d $RPM_BUILD_ROOT%{_sysconfdir}
46
47%{__make} install \
48 DESTDIR=$RPM_BUILD_ROOT
d63b6576 49
5d018c58 50cat > $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf << 'EOF'
d63b6576 51LoadModule %{mod_name}_module modules/mod_%{mod_name}.so
1407fa5c
AM
52ProctitileEnable On
53# ProctitleUriSep ::
d63b6576
AM
54EOF
55
56%clean
57rm -rf $RPM_BUILD_ROOT
58
59%post
60%service -q httpd restart
61
62%postun
63if [ "$1" = "0" ]; then
64 %service -q httpd restart
65fi
66
67%files
68%defattr(644,root,root,755)
5d018c58 69%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
1407fa5c 70%attr(755,root,root) %{_pkglibdir}/mod_proctitle.so
This page took 0.076137 seconds and 4 git commands to generate.