]> git.pld-linux.org Git - packages/amanda.git/commitdiff
- partial update to 3.5.1; builds, installs but files need update
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 20 Sep 2018 07:09:16 +0000 (09:09 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 20 Sep 2018 07:09:16 +0000 (09:09 +0200)
amanda-amstar-device.patch [deleted file]
amanda-amstar-exclude-fix.patch [deleted file]
amanda-chg-zd-mtx-sh.patch [deleted file]
amanda-common.patch
amanda-krb5-auth.patch
amanda.spec

diff --git a/amanda-amstar-device.patch b/amanda-amstar-device.patch
deleted file mode 100644 (file)
index 8a894a2..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
---- amanda-3.2.3/application-src/amstar.c.orig 2012-05-09 14:36:45.583768213 +0200
-+++ amanda-3.2.3/application-src/amstar.c      2012-05-10 14:41:43.738866665 +0200
-@@ -454,7 +454,9 @@
-     }
-     set_root_privs(1);
--    if (argument->dle.device) {
-+    if (star_directory) {
-+      check_dir(star_directory, R_OK);
-+    } else if (argument->dle.device) {
-       check_dir(argument->dle.device, R_OK);
-     }
-     set_root_privs(0);
-@@ -499,9 +501,13 @@
-       fprintf(stderr, "ERROR include-list not supported for backup\n");
-     }
--    if (check_device(argument) == 0) {
--      return;
-+    set_root_privs(1);
-+    if (star_directory) {
-+      check_dir(star_directory, R_OK|X_OK);
-+    } else if (argument->dle.device) {
-+      check_dir(argument->dle.device, R_OK|X_OK);
-     }
-+    set_root_privs(0);
-     qdisk = quote_string(argument->dle.disk);
-     if (argument->calcsize) {
diff --git a/amanda-amstar-exclude-fix.patch b/amanda-amstar-exclude-fix.patch
deleted file mode 100644 (file)
index 15105d5..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- amanda/application-src/amstar.c    2010/09/24 21:46:25     3449
-+++ amanda/application-src/amstar.c    2010/11/10 11:22:58     3609
-@@ -993,7 +993,7 @@
-       for (excl = argument->dle.exclude_file->first; excl != NULL;
-            excl = excl->next) {
-           char *ex;
--          if (strcmp(excl->name, "./") == 0) {
-+          if (strncmp(excl->name, "./", 2) == 0) {
-               ex = g_strdup_printf("pat=%s", excl->name+2);
-           } else {
-               ex = g_strdup_printf("pat=%s", excl->name);
-@@ -1013,7 +1013,7 @@
-               while ((aexc = agets(exclude)) != NULL) {
-                   if (aexc[0] != '\0') {
-                       char *ex;
--                      if (strcmp(aexc, "./") == 0) {
-+                      if (strncmp(aexc, "./", 2) == 0) {
-                           ex = g_strdup_printf("pat=%s", aexc+2);
-                       } else {
-                           ex = g_strdup_printf("pat=%s", aexc);
diff --git a/amanda-chg-zd-mtx-sh.patch b/amanda-chg-zd-mtx-sh.patch
deleted file mode 100644 (file)
index f18074a..0000000
+++ /dev/null
@@ -1,446 +0,0 @@
-diff -ur amanda-2.6.1p1/changer-src/chg-zd-mtx.sh amanda-2.6.1p1-sh/changer-src/chg-zd-mtx.sh
---- amanda-2.6.1p1/changer-src/chg-zd-mtx.sh   2008-12-16 21:46:41.000000000 +0100
-+++ amanda-2.6.1p1-sh/changer-src/chg-zd-mtx.sh        2009-07-03 21:00:25.379617588 +0200
-@@ -364,7 +364,7 @@
- internal_call=0
- Exit() {
--      if [ $internal_call -gt 0 ]; then
-+      if [ "$internal_call" -gt 0 ]; then
-               call_type=Return
-       else
-               call_type=Exit
-@@ -376,7 +376,7 @@
-       exit_answer="$@"
-       Log $call_type "($code) -> $exit_slot $@"
-       echo "$exit_slot" "$@"
--      if [ $call_type = Return ]; then
-+      if [ "$call_type" = "Return" ]; then
-               return $code
-       fi
-       amgetconf dbclose.$myname:$DBGFILE > /dev/null 2>&1
-@@ -393,12 +393,12 @@
-       "$@" > $stdout 2> $stderr
-       exitcode=$?
-       Log `_ 'Exit code: %s' "$exitcode"`
--      if [ -s $stdout ]
-+      if [ -s "$stdout" ]
-       then
-               LogAppend Stdout:
-               cat $stdout >> $DBGFILE
-       fi
--      if [ -s $stderr ]
-+      if [ -s "$stderr" ]
-       then
-               LogAppend Stderr:
-               cat $stderr >> $DBGFILE
-@@ -425,13 +425,13 @@
- mtx_status_valid=0
- get_mtx_status() {
-       test -n "$DEBUG" && set -x
--      if [ $mtx_status_valid -ne 0 ]; then
-+      if [ "$mtx_status_valid" -ne 0 ]; then
-               return 0
-       fi
-       rm -f $mtx_status
-       Run $MTX status > $mtx_status 2>&1
-       status=$?
--      if [ $status -eq 0 ]; then
-+      if [ "$status" -eq 0 ]; then
-               mtx_status_valid=1
-       fi
-@@ -503,7 +503,7 @@
-       fi
-       #Use the current slot if it's empty and we don't know which slot is loaded'
--      if [ $loadedslot -eq -2 ]; then
-+      if [ "$loadedslot" -eq -2 ]; then
-               set x `sed -n '
- {
-     /^.*Storage Element '$currentslot':Empty/ {
-@@ -526,13 +526,13 @@
- ' < $mtx_status 2>& 1`
-               shift                           # get rid of the "x"
-               loadedslotx=$1
--              if [ ! -z $loadedslotx ]; then
-+              if [ ! -z "$loadedslotx" ]; then
-                       loadedslot=$loadedslotx
-               fi
-       fi
-       #Use the first empty slot if we don't know which slot is loaded'
--      if [ $loadedslot -eq -2 ]; then
-+      if [ "$loadedslot" -eq -2 ]; then
-               set x `sed -n '
- {
-     /^.*Storage Element \([0-9][0-9]*\):Empty/ {
-@@ -606,27 +606,27 @@
- }
- ' < $mtx_status 2>&1 | grep -v "^${cleanslot}\$" | sort -n`
-       slot_list=`echo $slot_list`             # remove the newlines
--      if [ $firstslot -lt 0 -o $lastslot -lt 0 ]; then
-+      if [ "$firstslot" -lt 0 -o "$lastslot" -lt 0 ]; then
-               last=$lastslot
-               for slot in $slot_list; do
--                      if [ $firstslot -lt 0 ]; then
-+                      if [ "$firstslot" -lt 0 ]; then
-                               Log `_ 'SLOTLIST -> firstslot set to %s' "$slot"`
-                               firstslot=$slot
-                       fi
--                      if [ $lastslot -lt 0 ]; then
-+                      if [ "$lastslot" -lt 0 ]; then
-                               last=$slot
-                       fi
-               done
--              if [ $lastslot -lt 0 -a $last -ge 0 ]; then
-+              if [ "$lastslot" -lt 0 -a "$last" -ge 0 ]; then
-                       Log `_ 'SLOTLIST -> lastslot set to %s' "$last"`
-                       lastslot=$last
-               fi
--              if [ $firstslot -lt 0 ]; then
-+              if [ "$firstslot" -lt 0 ]; then
-                       Exit 2 \
-                            `_ '<none>'` \
-                            `_ 'cannot determine first slot'`
-                       return $?               # in case we are internal
--              elif [ $lastslot -lt 0 ]; then
-+              elif [ "$lastslot" -lt 0 ]; then
-                       Exit 2 \
-                            `_ '<none>'` \
-                            `_ 'cannot determine last slot'`
-@@ -635,7 +635,7 @@
-       fi
-       amanda_slot_list=
-       for slot in $slot_list; do
--              if [ $slot -ge $firstslot -a $slot -le $lastslot ]; then
-+              if [ "$slot" -ge "$firstslot" -a "$slot" -le "$lastslot" ]; then
-                       amanda_slot_list="$amanda_slot_list $slot"
-               fi
-       done
-@@ -671,7 +671,7 @@
-                            `_ 'Line %s malformed in %s: %s %s %s' "$line" "$labelfile" "$lbl" "$bc" "$junk"`
-                       return $?               # in case we are internal
-               fi
--              if [ $lbl = "$lbl_search" -o $bc = "$bc_search" ]; then
-+              if [ "$lbl" = "$lbl_search" -o "$bc" = "$bc_search" ]; then
-                       if [ $labelfile_entry_found -ne 0 ]; then
-                               Log       `_ 'ERROR    -> Duplicate entries: %s line %s' "$labelfile" "$line"`
-                               LogAppend `_ '         -> Remove %s and run "%s %s update"' "$labelfile" "$sbindir/amtape" "$config"`
-@@ -860,7 +860,7 @@
-         Exit 2 \
-              ` _ '<none>'` \
-              "tapedev $rawtape is not a tape device."
--elif [ $tape = "/dev/null" -o `expr "$tape" : 'null:'` -eq 5 ]; then
-+elif [ "$tape" = "/dev/null" -o "`expr "$tape" : 'null:'`" -eq 5 ]; then
-       Exit 2 \
-            `_ '<none>'` \
-            "tapedev ($tape) may not be the null device"
-@@ -871,7 +871,7 @@
-       Exit 2 \
-            `_ '<none>'` \
-            "changerdev may not be empty"
--elif [ $TAPE = "/dev/null" ]; then
-+elif [ "$TAPE" = "/dev/null" ]; then
-       Exit 2 \
-            `_ '<none>'` \
-            "changerdev ($TAPE) may not be the null device"
-@@ -884,19 +884,19 @@
- #### Set up the various config files.
- conf_match=`expr "$changerfile" : .\*\.conf\$`
--if [ $conf_match -ge 6 ]; then
-+if [ "$conf_match" -ge 6 ]; then
-       configfile=$changerfile
-       changerfile=`echo $changerfile | sed 's/.conf$//g'`
- else
-       configfile=$changerfile.conf
- fi
--if [ ! -e $configfile ]; then
-+if [ ! -e "$configfile" ]; then
-       Exit 2 \
-            `_ '<none>'` \
-            "configuration file \"$configfile\" doesn't exist"
- fi
--if [ ! -f $configfile ]; then
-+if [ ! -f "$configfile" ]; then
-       Exit 2 \
-            `_ '<none>'` \
-            "configuration file \"$configfile\" is not a file"
-@@ -907,10 +907,10 @@
- slotfile=$changerfile-slot
- labelfile=$changerfile-barcodes
- slotinfofile=""
--[ ! -s $cleanfile ] && echo 0 > $cleanfile
--[ ! -s $accessfile ] && echo 0 > $accessfile
--[ ! -s $slotfile ] && echo -1 > $slotfile
--[ ! -f $labelfile ] && > $labelfile
-+[ ! -s "$cleanfile" ] && echo 0 > $cleanfile
-+[ ! -s "$accessfile" ] && echo 0 > $accessfile
-+[ ! -s "$slotfile" ] && echo -1 > $slotfile
-+[ ! -f "$labelfile" ] && > $labelfile
- cleancount=`cat $cleanfile`
- accesscount=`cat $accessfile`
-@@ -957,7 +957,7 @@
- # Get DBGFILE set if it is not already.
--if [ $DBGFILE = /dev/null ]; then
-+if [ "$DBGFILE" = /dev/null ]; then
-       if [ -d "$DBGDIR" ]; then
-               DBGFILE=$DBGDIR/changer.debug.drive$driveslot
-       else
-@@ -1037,9 +1037,9 @@
- Log `_ "Config info:"`
- for var in $varlist; do
--      if [ $var = "OFFLINE_BEFORE_UNLOAD" ]; then
-+      if [ "$var" = "OFFLINE_BEFORE_UNLOAD" ]; then
-               continue                        # old name
--      elif [ $var = "AUTOCLEAN" ]; then
-+      elif [ "$var" = "AUTOCLEAN" ]; then
-               continue                        # old name
-       elif [ $var = "slotinfofile" ]; then
-               continue                        # not numeric
-@@ -1062,12 +1062,12 @@
- # Run the rest of the config file sanity checks.
--if [ $firstslot -gt $lastslot ]; then
-+if [ "$firstslot" -gt "$lastslot" ]; then
-       Exit 2 \
-            `_ '<none>'` \
-            `_ 'firstslot (%s) greater than lastslot (%s) in %s' "$firstslot" "$lastslot" "$configfile"`
- fi
--if [ $autoclean -ne 0 -a $cleanslot -lt 0 ]; then
-+if [ "$autoclean" -ne 0 -a "$cleanslot" -lt 0 ]; then
-       Exit 2 \
-            `_ '<none>'` \
-            `_ 'autoclean set but cleanslot not valid (%s)' "$cleanslot"`
-@@ -1077,10 +1077,10 @@
- currentslot=`cat $slotfile`
- if IsNumeric "$currentslot" ; then
--      if [ $currentslot -lt $firstslot ]; then
-+      if [ "$currentslot" -lt "$firstslot" ]; then
-               Log `_ 'SETUP    -> current slot %s less than %s ... resetting to %s' "$currentslot" "$firstslot" "$firstslot"`
-               currentslot=$firstslot
--      elif [ $currentslot -gt $lastslot ]; then
-+      elif [ "$currentslot" -gt "$lastslot" ]; then
-               Log `_ 'SETUP    -> current slot %s greater than %s ... resetting to %s' "$currentslot" "$lastslot" "$lastslot"`
-               currentslot=$lastslot
-       fi
-@@ -1093,19 +1093,19 @@
- first_slot_in_list=-1
- next_slot_after_current=-1
- for slot in $slot_list; do
--      if [ $first_slot_in_list -lt 0 ]; then
-+      if [ "$first_slot_in_list" -lt 0 ]; then
-               first_slot_in_list=$slot        # in case $firstslot is missing
-       fi
--      if [ $slot -eq $currentslot ]; then
-+      if [ "$slot" -eq "$currentslot" ]; then
-               found_current=1
-               break
--      elif [ $slot -gt $currentslot ]; then
-+      elif [ "$slot" -gt "$currentslot" ]; then
-               next_slot_after_current=$slot   # $currentslot is missing
-               break
-       fi
- done
--if [ $found_current -eq 0 ]; then
--      if [ $next_slot_after_current -lt 0 ]; then
-+if [ "$found_current" -eq 0 ]; then
-+      if [ "$next_slot_after_current" -lt 0 ]; then
-               new_currentslot=$first_slot_in_list
-       else
-               new_currentslot=$next_slot_after_current
-@@ -1124,9 +1124,9 @@
-       test -n "$DEBUG" && set -x
-       Log `_ 'EJECT    -> ejecting tape from %s' "$tape"`
-       get_loaded_info 
--      if [ $loadedslot -gt 0 ]; then
-+      if [ "$loadedslot" -gt 0 ]; then
-               Log `_ 'EJECT    -> moving tape from drive %s to storage slot %s' "$driveslot" "$loadedslot"`
--              if [ $offline_before_unload -ne 0 ]; then
-+              if [ "$offline_before_unload" -ne 0 ]; then
-                         Run try_eject_device $tape
-               fi
-               sleep $unloadpause
-@@ -1134,7 +1134,7 @@
-               status=$?
-               Log `_ '         -> status %s, result "%s"' "$status" "$result"`
-               mtx_status_valid=0
--              if [ $status -ne 0 ]; then
-+              if [ "$status" -ne 0 ]; then
-                       answer="$result"
-                       code=2
-               else
-@@ -1213,7 +1213,7 @@
-       prev_slot=$1
-       shift
-       while [ $# -gt 0 ]; do
--              if [ $1 -eq $find_slot ]; then
-+              if [ "$1" -eq "$find_slot" ]; then
-                       break
-               fi
-               prev_slot=$1
-@@ -1242,15 +1242,15 @@
-       # If the desired slot is already loaded, we are done.  Only update
-       # current slot if this is not the cleaning slot.
-       get_loaded_info
--      if [ $loadslot = $loadedslot ]; then
--              if [ $loadslot -ne $cleanslot ]; then
-+      if [ "$loadslot" = "$loadedslot" ]; then
-+              if [ "$loadslot" -ne "$cleanslot" ]; then
-                       rm -f $slotfile
-                       echo $loadslot > $slotfile
-               fi
-               Exit 0 "$loadedslot" "$rawtape"
-               return $?                       # in case we are internal
-       fi
--      if [ $loadedslot -eq -2 ]; then
-+      if [ "$loadedslot" -eq -2 ]; then
-               Exit 0 "$loadedslot" "$rawtape"
-               return $?                       # in case we are internal
-         fi
-@@ -1258,20 +1258,20 @@
-       # If we are loading the cleaning tape, bump the cleaning count
-       # and reset the access count.  Otherwise, bump the access count
-       # and see if it is time to do a cleaning.
--      if [ $loadslot = $cleanslot ]; then
-+      if [ "$loadslot" = "$cleanslot" ]; then
-               rm -f $cleanfile $accessfile
-               expr $cleancount + 1 > $cleanfile
-               echo 0 > $accessfile
-       else
-               rm -f $accessfile
-               expr $accesscount + 1 > $accessfile
--              if [ $autoclean -ne 0 -a $accesscount -gt $autocleancount ]
-+              if [ "$autoclean" -ne 0 -a "$accesscount" -gt "$autocleancount" ]
-               then
-                       internal_call=`expr $internal_call + 1`
-                       loadslot clean > /dev/null 2>&1
-                       status=$?
-                       internal_call=`expr $internal_call - 1`
--                      if [ $status -ne 0 ]; then
-+                      if [ "$status" -ne 0 ]; then
-                               Exit $status "$loadslot" "$exit_answer"
-                               return $?       # in case we are internal
-                       fi
-@@ -1291,14 +1291,14 @@
-       eject > /dev/null 2>&1
-       status=$?
-       internal_call=`expr $internal_call - 1`
--      if [ $status -gt 1 ]; then
-+      if [ "$status" -gt 1 ]; then
-               Exit $status "$exit_slot" "$exit_answer"
-               return $?                       # in case we are internal
-       fi
-       # If we were doing an "advance", we are done.
--      if [ $whichslot = advance ]; then
--              if [ $loadslot -ne $cleanslot ]; then
-+      if [ "$whichslot" = "advance" ]; then
-+              if [ "$loadslot" -ne "$cleanslot" ]; then
-                       rm -f $slotfile
-                       echo $loadslot > $slotfile
-               fi
-@@ -1312,7 +1312,7 @@
-       status=$?
-       Log `_ '         -> status %s, result "%s"' "$status" "$result"`
-       mtx_status_valid=0
--      if [ $status -ne 0 ]; then
-+      if [ "$status" -ne 0 ]; then
-               Exit 2 "$loadslot" "$result"
-               return $?                       # in case we are internal
-       fi
-@@ -1322,7 +1322,7 @@
-       # for "long enough" (as determined empirically by the user),
-       # then return success.
-       ###
--      if [ $loadslot -eq $cleanslot ]; then
-+      if [ "$loadslot" -eq "$cleanslot" ]; then
-               Run sleep $cleancycle
-               Exit 0 "$loadslot" "$rawtape"
-               return $?                       # in case we are internal
-@@ -1334,7 +1334,7 @@
-       waittime=0
-       ready=0
-       sleep $initial_poll_delay
--      while [ $waittime -lt $max_drive_wait ]; do
-+      while [ "$waittime" -lt "$max_drive_wait" ]; do
-                 amdevcheck_status $tape
-               if [ $? -eq 0 ]; then
-                       ready=1
-@@ -1343,12 +1343,12 @@
-               sleep $poll_drive_ready
-               waittime=`expr $waittime + $poll_drive_ready`
-       done
--      if [ $ready -eq 0 ]; then
-+      if [ "$ready" -eq 0 ]; then
-               Exit 2 "$loadslot" `_ 'Drive not ready after %s seconds: %s' "$max_drive_wait" "$amdevcheck_message"`
-               return $?                       # in case we are internal
-       fi
--      if [ $loadslot -ne $cleanslot ]; then
-+      if [ "$loadslot" -ne "$cleanslot" ]; then
-               rm -f $slotfile
-               echo $loadslot > $slotfile
-       fi
-@@ -1379,11 +1379,11 @@
-       # can search based on barcodes.
-       ###
-       reader=
--        if [ $havereader -eq 1 ]; then
-+        if [ "$havereader" -eq 1 ]; then
-               reader=1
-         fi
--      if [ $currentslot -lt $firstslot -o $currentslot -gt $lastslot ]; then
-+      if [ "$currentslot" -lt "$firstslot" -o "$currentslot" -gt "$lastslot" ]; then
-               currentslot=$firstslot          # what "current" will get
-       fi
-       numslots=`expr $lastslot - $firstslot + 1`
-@@ -1404,12 +1404,12 @@
-       fi
-         tapelabel=$1
-         get_loaded_info
--      if [ $loadedslot -lt 0 ]; then
-+      if [ "$loadedslot" -lt 0 ]; then
-               Exit 1 `_ '<none>'` `_ 'No tape currently loaded'`
-               return $?                       # in case we are internal
-       fi
-       record_label_in_slot "$tapelabel" "$loadedslot"
--      if [ $havereader -eq 0 ]; then
-+      if [ "$havereader" -eq 0 ]; then
-               Exit 0 "$loadedslot" "$rawtape" # that's all we needed
-               return $?                       # in case we are internal
-       fi
-@@ -1419,7 +1419,7 @@
-       fi
-       Log       `_ 'LABEL    -> Adding label "%s" with barcode "%s" for slot %s into %s' "$tapelabel" "$loadedbarcode" "$loadedslot" "$labelfile"`
-       read_labelfile "$tapelabel" "$loadedbarcode" < $labelfile
--      if [ $labelfile_entry_found -ne 0 ]; then
-+      if [ "$labelfile_entry_found" -ne 0 ]; then
-               lf_val=
-               if [ "$labelfile_barcode" != "$loadedbarcode" ]; then
-                       lf_type=label
-@@ -1465,13 +1465,13 @@
-               return $?                       # in case we are internal
-       fi
-         tapelabel=$1
--      if [ $havereader -eq 0 ]; then
-+      if [ "$havereader" -eq 0 ]; then
-               Exit 2 `_ '<none>'` `_ 'Not configured with barcode reader'`
-               return $?                       # in case we are internal
-       fi
-       Log `_ 'SEARCH   -> Hunting for label "%s"' "$tapelabel"`
-       read_labelfile "$tapelabel" "" < $labelfile
--      if [ $labelfile_entry_found -eq 0 ]; then
-+      if [ "$labelfile_entry_found" -eq 0 ]; then
-               LogAppend `_ '         -> !!! label "%s" not found in %s !!!' "$tapelabel" "$labelfile"`
-               LogAppend `_ '         -> Remove %s and run "%s %s update"' "$labelfile" "$sbindir/amtape" "$config"`
-               Exit 2 \
index 8f1f0fd919311fa12161b9f0d6daa63e92b59ed9..64005024b278fa220886e168eda91a988cbe02c0 100644 (file)
@@ -1,26 +1,18 @@
---- amanda-3.2.0/man/Makefile.am~      2010-10-06 18:36:29.000000000 +0200
-+++ amanda-3.2.0/man/Makefile.am       2010-11-25 13:40:20.848191192 +0100
-@@ -14,6 +14,13 @@
-                   amanda-auth.7 \
-                   amanda-match.7 \
-                   amarchiver.8 \
-+                  amaespipe.8 \
+--- amanda-3.5.1/man/Makefile.am~      2017-12-01 14:26:28.000000000 +0100
++++ amanda-3.5.1/man/Makefile.am       2018-09-20 08:56:14.538624065 +0200
+@@ -19,6 +19,11 @@ COMMON_MAN_PAGES =  amanda.8 \
+                   amgetconf.8 \
+                   amservice.8 \
+                   amssl.8 \
 +                  amcrypt-ossl-asym.8 \
 +                  amcrypt-ossl.8   \
 +                  amcrypt.8 \
 +                  amcryptsimple.8  \
-+                  amgetconf.8 \
 +                  amgpgcrypt.8 \
-                   amservice.8 \
                    script-email.8
  
-@@ -34,21 +40,14 @@
-     amanda-taperscan.7 \
-     amaddclient.8    \
-     amadmin.8 \
--    amaespipe.8 \
-     amcheck.8 \
-     amcheckdb.8 \
+ CLIENT_MAN_PAGES = \
+@@ -49,14 +54,9 @@ SERVER_MAN_PAGES =  \
      amcheckdump.8 \
      amcleanup.8 \
      amcleanupdisk.8 \
@@ -31,8 +23,7 @@
      amdevcheck.8 \
      amdump.8 \
      amflush.8 \
--    amgetconf.8 \
 -    amgpgcrypt.8 \
      amlabel.8 \
      amoverview.8 \
-     amreport.8 \
+     amreindex.8 \
index 040d06d5957f22fcd275ae8adc7cdd61b11f1ee2..1545dd3e7cbdbf4dc72a17dc5bafea03996873c7 100644 (file)
      /*
       * Schedule to call protocol_accept() when new security handles
       * are created on stdin.
---- amanda-3.2.0/common-src/krb5-security.c~   2010-11-29 14:24:29.826165323 +0100
-+++ amanda-3.2.0/common-src/krb5-security.c    2010-11-29 14:45:41.683165324 +0100
-@@ -46,7 +46,7 @@
- #include "et/com_err.h"
- #endif
--#define BROKEN_MEMORY_CCACHE
-+#undef BROKEN_MEMORY_CCACHE
- #ifdef BROKEN_MEMORY_CCACHE
- /*
-@@ -712,7 +712,7 @@
-     beenhere = 1;
- #ifndef BROKEN_MEMORY_CCACHE
--    putenv(stralloc("KRB5_ENV_CCNAME=MEMORY:amanda_ccache"));
-+    putenv(stralloc(KRB5_ENV_CCNAME"=MEMORY:amanda_ccache"));
- #else
-     /*
-      * MEMORY ccaches seem buggy and cause a lot of internal heap
-@@ -727,7 +727,7 @@
-       char *ccache;
-       ccache = malloc(128);
-       g_snprintf(ccache, SIZEOF(ccache),
--               "KRB5_ENV_CCNAME=FILE:/tmp/amanda_ccache.%ld.%ld",
-+               KRB5_ENV_CCNAME"=FILE:/tmp/amanda_ccache.%ld.%ld",
-                (long)geteuid(), (long)getpid());
-       putenv(ccache);
-     }
index 3651cd29ba1db3341636acb272d3b3708244c737..8944cb9311f3cd3df7ef5ca46ca5f917a2f5517f 100644 (file)
@@ -9,12 +9,12 @@
 Summary:       A network-capable tape backup solution
 Summary(pl.UTF-8):     Sieciowo zorientowany system tworzenia kopii zapasowych
 Name:          amanda
-Version:       3.3.6
-Release:       13
+Version:       3.5.1
+Release:       0.1
 License:       BSD
 Group:         Networking/Utilities
 Source0:       http://downloads.sourceforge.net/amanda/%{name}-%{version}.tar.gz
-# Source0-md5: 99559bd84b358701cf943fcc347d8914
+# Source0-md5: f57307959f79e722b1dcb3f985ebb0d0
 Source1:       %{name}-srv.crontab
 Source2:       %{name}.inetd
 Source3:       %{name}idx.inetd
@@ -28,7 +28,7 @@ Source8:      amlvm-snapshot.conf
 Source9:       amlvm-snapshot.pl
 Source10:      amlvm-snapshot.README
 Patch0:                %{name}-no_libnsl.patch
-Patch1:                %{name}-chg-zd-mtx-sh.patch
+
 Patch2:                %{name}-tar.patch
 Patch3:                %{name}-common.patch
 Patch4:                %{name}-as_needed.patch
@@ -37,9 +37,9 @@ Patch6:               %{name}-FHS.patch
 Patch7:                %{name}-no-buildtime-ipv6.patch
 Patch8:                %{name}-heimdal.patch
 Patch9:                %{name}-ac.patch
-Patch11:       %{name}-amstar-exclude-fix.patch
+
 Patch12:       %{name}-krb5-auth.patch
-Patch13:       %{name}-amstar-device.patch
+
 Patch14:       swig.patch
 Patch15:       krb5-ac.patch
 URL:           http://www.amanda.org/
@@ -203,7 +203,7 @@ typu streamer).
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
+
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
@@ -212,9 +212,9 @@ typu streamer).
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
-%patch11 -p1
+
 %patch12 -p1
-%patch13 -p1
+
 %patch14 -p1
 %patch15 -p1
 cp -a %{SOURCE10} .
@@ -539,11 +539,6 @@ EOF
 %attr(755,root,root) %{_libexecdir}/amanda/amplot.gp
 %attr(755,root,root) %{_libexecdir}/amanda/amtrmidx
 %attr(755,root,root) %{_libexecdir}/amanda/amtrmlog
-%attr(755,root,root) %{_libexecdir}/amanda/chg-disk
-%attr(755,root,root) %{_libexecdir}/amanda/chg-lib.sh
-%attr(755,root,root) %{_libexecdir}/amanda/chg-manual
-%attr(755,root,root) %{_libexecdir}/amanda/chg-multi
-%attr(755,root,root) %{_libexecdir}/amanda/chg-zd-mtx
 %attr(755,root,root) %{_libexecdir}/amanda/chunker
 %attr(755,root,root) %{_libexecdir}/amanda/driver
 %attr(4750,root,amanda) %{_libexecdir}/amanda/dumper
This page took 0.152495 seconds and 4 git commands to generate.