]> git.pld-linux.org Git - packages/agg.git/blob - agg.spec
- cxx fixes for gcc 8
[packages/agg.git] / agg.spec
1 Summary:        A High Quality Rendering Engine for C++
2 Summary(pl.UTF-8):      Silnik renderujący wysokiej jakości dla C++
3 Name:           agg
4 Version:        2.5
5 Release:        8
6 License:        GPL v2+
7 Group:          Libraries
8 Source0:        http://www.antigrain.com/%{name}-%{version}.tar.gz
9 # Source0-md5:  ddc67cbdc7d51e1ec984c2ac2724c08a
10 Patch0:         %{name}-depends.patch
11 Patch1:         ac.patch
12 Patch2:         cxx.patch
13 URL:            http://www.antigrain.com/
14 BuildRequires:  SDL-devel
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  freetype-devel
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool
20 BuildRequires:  pkgconfig
21 BuildRequires:  xorg-lib-libX11-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 # Unresolved symbol: _Z8agg_mainiPPc
25 %define         skip_post_check_so      libaggplatformsdl.so.*.*.* libaggplatformX11.so.*.*.* libaggplatformsdl.so.*.*.*
26
27 %description
28 Anti-Grain Geometry (AGG) is a general purpose graphical toolkit
29 written completely in standard and platform independent C++. It can be
30 used in many areas of computer programming where high quality 2D
31 graphics is an essential part of the project.
32
33 AGG uses only C++ and standard C runtime functions, such as memcpy,
34 sin, cos, sqrt, etc. The basic algorithms don't even use C++ Standard
35 Template Library. Thus, AGG can be used in a very large number of
36 applications, including embedded systems.
37
38 %description -l pl.UTF-8
39 Anti-Grain Geometry (AGG) to toolkit graficzny ogólnego przeznaczenia
40 napisany całkowicie w standardowym i niezależnym od platformy C++.
41 Może być używany w wielu zastosowaniach z zakresu programowania gdzie
42 zasadniczą częścią projektu jest wysokiej jakości grafika 2D.
43
44 AGG używa tylko C++ i standardowych funkcji C, takich jak memcpy, sin,
45 cos, sqrt itp. Podstawowe algorytmy nie używają nawet standardowej
46 biblioteki C++. W ten sposób AGG może być używany w bardzo wielu
47 zastosowaniach, także na systemach wbudowanych.
48
49 %package devel
50 Summary:        Support files necessary to compile applications with agg
51 Summary(pl.UTF-8):      Pliki potrzebne do kompilowania aplikacji z użyciem agg
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       libstdc++-devel
55 # libaggfontfreetype R: freetype-devel
56 # libaggplatformX11 R: xorg-lib-libX11-devel
57 # libaggplatformsdl R: SDL-devel
58
59 %description devel
60 Header and support files necessary to compile applications using agg.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe i pomocnicze potrzebne do kompilowania aplikacji z
64 użyciem agg.
65
66 %package static
67 Summary:        Static agg library
68 Summary(pl.UTF-8):      Statyczna biblioteka agg
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static agg library.
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka agg.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81 %patch1 -p1
82 %patch2 -p1
83
84 %build
85 %{__libtoolize}
86 %{__aclocal}
87 %{__autoheader}
88 %{__autoconf}
89 %{__automake}
90 %configure \
91         --disable-gpc \
92         --disable-examples
93
94 %{__make} -j1
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc authors copying readme
111 %attr(755,root,root) %{_libdir}/libagg.so.*.*.*
112 %ghost %{_libdir}/libagg.so.2
113 %attr(755,root,root) %{_libdir}/libaggfontfreetype.so.*.*.*
114 %ghost %{_libdir}/libaggfontfreetype.so.2
115 %attr(755,root,root) %{_libdir}/libaggplatformX11.so.*.*.*
116 %ghost %{_libdir}/libaggplatformX11.so.2
117 %attr(755,root,root) %{_libdir}/libaggplatformsdl.so.*.*.*
118 %ghost %{_libdir}/libaggplatformsdl.so.2
119
120 %files devel
121 %defattr(644,root,root,755)
122 %{_libdir}/libagg.so
123 %{_libdir}/libaggfontfreetype.so
124 %{_libdir}/libaggplatformX11.so
125 %{_libdir}/libaggplatformsdl.so
126 %{_libdir}/libagg.la
127 %{_libdir}/libaggfontfreetype.la
128 %{_libdir}/libaggplatformX11.la
129 %{_libdir}/libaggplatformsdl.la
130 %{_includedir}/agg2
131 %{_pkgconfigdir}/libagg.pc
132 %{_aclocaldir}/libagg.m4
133
134 %files static
135 %defattr(644,root,root,755)
136 %{_libdir}/libagg.a
137 %{_libdir}/libaggfontfreetype.a
138 %{_libdir}/libaggplatformX11.a
139 %{_libdir}/libaggplatformsdl.a
This page took 0.071778 seconds and 4 git commands to generate.