]> git.pld-linux.org Git - packages/Zope-CookieCrumbler.git/blob - Zope-CookieCrumbler.spec
- cleaning
[packages/Zope-CookieCrumbler.git] / Zope-CookieCrumbler.spec
1 %include        /usr/lib/rpm/macros.python
2 %define         zope_subname    CookieCrumbler
3 Summary:        Zope product that enables cookie-based authentication
4 Summary(pl):    Dodatek do Zope umo¿liwiaj±cy uwierzytelnianie przez cookies
5 Name:           Zope-%{zope_subname}
6 Version:        1.1
7 Release:        2
8 License:        ZPL 2.0
9 Group:          Development/Tools
10 Source0:        http://hathaway.freezope.org/Software/%{zope_subname}/%{zope_subname}-%{version}.tar.gz
11 # Source0-md5:  427421815e94601c04c87326fc6819c1
12 URL:            http://hathaway.freezope.org/Software/%{zope_subname}
13 %pyrequires_eq  python-modules
14 Requires:       Zope
15 Requires(post,postun):  /usr/sbin/installzopeproduct
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 CookieCrumbler is Zope product that enables cookie-based
21 authentication.
22
23 %description -l pl
24 CookieCrumbler jest dodatkiem do Zope umo¿liwiaj±cym uwierzytelnianie
25 przez cookies.
26
27 %prep
28 %setup -q -n %{zope_subname}
29
30 %build
31 mkdir docs
32 mv -f {CHANGES.txt,README.txt} docs
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
37 cp -af * $RPM_BUILD_ROOT%{_datadir}/%{name}
38
39 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
40 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
41
42 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
43 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %post
49 /usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
50 if [ -f /var/lock/subsys/zope ]; then
51         /etc/rc.d/init.d/zope restart >&2
52 fi
53
54 %postun
55 if [ "$1" = "0" ]; then
56         /usr/sbin/installzopeproduct -d %{zope_subname} 
57         if [ -f /var/lock/subsys/zope ]; then
58                 /etc/rc.d/init.d/zope restart >&2
59         fi
60 fi
61
62 %files
63 %defattr(644,root,root,755)
64 %doc docs/*
65 %{_datadir}/%{name}
This page took 0.06063 seconds and 3 git commands to generate.