]> git.pld-linux.org Git - packages/WireGuard.git/commitdiff
- tools had been split by upstram to wireguard-tools package auto/th/WireGuard-1.0.20200429-1
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 4 May 2020 06:47:53 +0000 (08:47 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 4 May 2020 06:47:53 +0000 (08:47 +0200)
- switch sources to wireguard-linux-compat for Linux 3.10 - 5.5
- updated to 1.0.20200429

WireGuard.spec
kernel-5.4.29.patch [deleted file]

index 7035ef3964c09a8fee514cd4d377b2c6862bc36a..6c6ddbb5a17f16a265f5f1ecad555edcdeef9dc6 100644 (file)
@@ -1,31 +1,17 @@
-# Conditional build:
-%bcond_without kernel          # don't build kernel modules
-%bcond_without userspace       # don't build userspace tools
-
-%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
-%{error:kernel and userspace cannot be built at the same time on PLD builders}
-exit 1
-%endif
-
-%if %{without userspace}
 # nothing to be placed to debuginfo package
 %define                _enable_debug_packages  0
-%endif
 
-%define                rel     2
-%define                pname   WireGuard
+%define                rel     1
 Summary:       WireGuard is an extremely simple yet fast and modern VPN that utilizes state-of-the-art cryptography
-Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
-Version:       0.0.20191219
+Name:          WireGuard%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
+Version:       1.0.20200429
 Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 License:       GPL v2
 Group:         Networking/Daemons
-Source0:       https://git.zx2c4.com/WireGuard/snapshot/%{pname}-%{version}.tar.xz
-# Source0-md5: 5175ca88850993dc88a4c9d924ee79d4
-Patch0:                kernel-5.4.29.patch
+Source0:       https://git.zx2c4.com/wireguard-linux-compat/snapshot/wireguard-linux-compat-%{version}.tar.xz
+# Source0-md5: 7cf7fdcf51fbeb0517f67d04474f7819
 URL:           https://www.wireguard.com/
-%{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:3.10}}
-BuildRequires: libmnl-devel
+%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:3.10}
 BuildRequires: rpmbuild(macros) >= 1.701
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -37,9 +23,6 @@ intends to be considerably more performant than OpenVPN. WireGuard is
 designed as a general purpose VPN for running on embedded interfaces
 and super computers alike, fit for many different circumstances.
 
-This package contains user space tools. You need to also install
-kernel module from kernel-*-misc-wireguard package.
-
 %define        kernel_pkg()\
 %package -n kernel%{_alt_kernel}-misc-wireguard\
 Summary:       WireGuard kernel module\
@@ -51,11 +34,10 @@ Requires(postun):   %releq_kernel\
 \
 %description -n kernel%{_alt_kernel}-misc-wireguard\
 WireGuard kernel module.\
-%if %{with kernel}\
+\
 %files -n kernel%{_alt_kernel}-misc-wireguard\
 %defattr(644,root,root,755)\
 /lib/modules/%{_kernel_ver}/misc/*.ko*\
-%endif\
 \
 %post  -n kernel%{_alt_kernel}-misc-wireguard\
 %depmod %{_kernel_ver}\
@@ -69,49 +51,19 @@ WireGuard kernel module.\
 %install_kernel_modules -D installed -m src/wireguard -d misc\
 %{nil}
 
-%{?with_kernel:%{expand:%create_kernel_packages}}
+%{expand:%create_kernel_packages}
 
 %prep
-%setup -q -n %{pname}-%{version}
-%patch0 -p1
+%setup -q -n wireguard-linux-compat-%{version}
 
 %build
-%{?with_kernel:%{expand:%build_kernel_packages}}
-
-%if %{with userspace}
-%{make} -C src/tools
-%endif
+%{expand:%build_kernel_packages}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%if %{with kernel}
 install -d $RPM_BUILD_ROOT
 cp -a installed/* $RPM_BUILD_ROOT
-%endif
-
-%if %{with userspace}
-%{make} -C src/tools install \
-       PREFIX=$RPM_BUILD_ROOT%{_prefix} \
-       SYSCONFDIR=$RPM_BUILD_ROOT%{_sysconfdir} \
-       SYSTEMDUNITDIR=$RPM_BUILD_ROOT%{systemdunitdir} \
-       WITH_SYSTEMDUNITS=yes
-%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
-
-%postun
-%systemd_reload
-
-%if %{with userspace}
-%files
-%defattr(644,root,root,755)
-%doc contrib/examples README.md
-%attr(755,root,root) %{_bindir}/wg
-%attr(755,root,root) %{_bindir}/wg-quick
-%dir %{_sysconfdir}/wireguard
-%{systemdunitdir}/wg-quick@.service
-%{_mandir}/man8/wg-quick.8*
-%{_mandir}/man8/wg.8*
-%endif
diff --git a/kernel-5.4.29.patch b/kernel-5.4.29.patch
deleted file mode 100644 (file)
index a3c7d4f..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- WireGuard-0.0.20191219/src/queueing.h~     2019-12-19 01:12:35.000000000 +0100
-+++ WireGuard-0.0.20191219/src/queueing.h      2020-04-05 10:52:10.887319410 +0200
-@@ -97,7 +97,11 @@
-       skb->dev = NULL;
- #ifdef CONFIG_NET_SCHED
-       skb->tc_index = 0;
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 4, 29)
-       skb_reset_tc(skb);
-+#else
-+      skb_reset_redirect(skb);
-+#endif
- #endif
-       skb->hdr_len = skb_headroom(skb);
-       skb_reset_mac_header(skb);
This page took 0.116887 seconds and 4 git commands to generate.