]> git.pld-linux.org Git - packages/STLport.git/commitdiff
- merged into 5.2.x.
authorPaweł Sikora <pluto@pld-linux.org>
Tue, 16 Dec 2008 09:19:43 +0000 (09:19 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    STLport-fstream.patch -> 1.2
    STLport-valarray-copy-constructor.patch -> 1.2
    STLport-vendor_gcc_detection.patch -> 1.3

STLport-fstream.patch [deleted file]
STLport-valarray-copy-constructor.patch [deleted file]
STLport-vendor_gcc_detection.patch [deleted file]

diff --git a/STLport-fstream.patch b/STLport-fstream.patch
deleted file mode 100644 (file)
index 577cbf9..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-this patch fixes inifinite loop in following testcase:
-
-#include <fstream>
-#include <string>
-#include <cassert>
-int main()
-{
-        std::ifstream in( "/tmp" );
-        assert( in.good() );
-        std::string buf;
-        std::getline( in, buf );
-        assert( in.fail() );
-}
-
-Index: STLport-trunk/stlport/stl/_fstream.c
-===================================================================
---- STLport-trunk/stlport/stl/_fstream.c       (wersja 3579)
-+++ STLport-trunk/stlport/stl/_fstream.c       (wersja 3580)
-@@ -513,6 +513,12 @@
-   // to make progress.
-   for (;;) {
-     ptrdiff_t __n = _M_base._M_read(_M_ext_buf_end, _M_ext_buf_EOS - _M_ext_buf_end);
-+    if (__n < 0) {
-+      // Read failed, maybe we should set err bit on associated stream...
-+      this->setg(0, 0, 0);
-+      return traits_type::eof();
-+    }
-+
-     _M_ext_buf_end += __n;
-     // If external buffer is empty there is nothing to do. 
diff --git a/STLport-valarray-copy-constructor.patch b/STLport-valarray-copy-constructor.patch
deleted file mode 100644 (file)
index 9cc6cd5..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-Make copy constructor public.
-
-based on: http://forums.gentoo.org/viewtopic-p-4120030.html#4120030
-
---- STLport-5.1.4/stlport/stl/_valarray.h~     2006-04-05 22:34:29.000000000 +0200
-+++ STLport-5.1.4/stlport/stl/_valarray.h      2007-11-05 10:11:13.528187997 +0100
-@@ -1193,6 +1193,7 @@
-   }
-   ~slice_array() {}
-+  slice_array(const slice_array&);
- private:
-   slice_array(const slice& __slice, valarray<_Tp>& __array)
-@@ -1204,7 +1205,6 @@
- private:                        // Disable assignment and default constructor
-   slice_array();
--  slice_array(const slice_array&);
-   slice_array& operator=(const slice_array&);
- };
diff --git a/STLport-vendor_gcc_detection.patch b/STLport-vendor_gcc_detection.patch
deleted file mode 100644 (file)
index c3853b9..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- STLport-5.1.5/build/Makefiles/gmake/gcc.mak.orig   2008-03-06 20:36:20.000000000 +0100
-+++ STLport-5.1.5/build/Makefiles/gmake/gcc.mak        2008-03-06 20:44:19.000000000 +0100
-@@ -26,7 +26,7 @@
- else
- ifneq ($(OSNAME), windows)
--CXX_VERSION := $(shell ${CXX} --version | grep GCC | awk '{ print $$3; }')
-+CXX_VERSION := $(shell ${CXX} -dumpversion)
- ifeq ($(CXX_VERSION),)
- # 2.95 report only version
This page took 0.143674 seconds and 4 git commands to generate.