]> git.pld-linux.org Git - packages/SFST.git/commitdiff
- fix variable redefinition
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 3 Dec 2013 07:46:23 +0000 (08:46 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 3 Dec 2013 07:46:23 +0000 (08:46 +0100)
SFST.spec
build.patch [new file with mode: 0644]

index 0b874e390bc1beac2f1f61480ca9c1786c234f35..a6306c6c93384a988b43ce5f3667552f2aa0a754 100644 (file)
--- a/SFST.spec
+++ b/SFST.spec
@@ -7,6 +7,7 @@ License:        GPL v2+
 Group:         Development/Tools
 Source0:       ftp://ftp.ims.uni-stuttgart.de/pub/corpora/SFST/%{name}-%{version}.tar.gz
 # Source0-md5: 574f124731ab1b87696fdd9b8a6e4a7d
+Patch0:                build.patch
 URL:           http://www.ims.uni-stuttgart.de/projekte/gramotron/SOFTWARE/SFST.html
 BuildRequires: bison
 BuildRequires: flex
@@ -54,6 +55,7 @@ Pliki nagłówkowe biblioteki SFST.
 
 %prep
 %setup -q -n %{name}
+%patch0 -p1
 
 sed -i -e '/^  strip/d' src/Makefile
 
diff --git a/build.patch b/build.patch
new file mode 100644 (file)
index 0000000..0dd11d4
--- /dev/null
@@ -0,0 +1,16 @@
+--- SFST/src/fst.C~    2012-02-20 13:34:34.000000000 +0100
++++ SFST/src/fst.C     2013-12-03 08:43:28.287475829 +0100
+@@ -511,11 +511,11 @@
+     for( ArcsIter it(node->arcs()); it; it++ ) {
+       Arc *arc=it;
+-      NodeHashSet::iterator it=previous.insert(node).first;
++      NodeHashSet::iterator itp=previous.insert(node).first;
+       path.push_back(arc->label());
+       enumerate_paths_node( arc->target_node(), path, previous, result );
+       path.pop_back();
+-      previous.erase(it);
++      previous.erase(itp);
+     }
+   }
This page took 0.077652 seconds and 4 git commands to generate.