]> git.pld-linux.org Git - packages/QtKeychain.git/blob - QtKeychain.spec
- note on qt5/6 versions
[packages/QtKeychain.git] / QtKeychain.spec
1 Summary:        Qt API to store passwords and other secret data securely
2 Summary(pl.UTF-8):      API Qt do bezpiecznego przechowywania haseł i innych tajnych danych
3 Name:           QtKeychain
4 # keep 0.11.x here for qt4 support; for newer versions see Qt5Keychain.spec, Qt6Keychain.spec
5 Version:        0.11.1
6 Release:        1
7 License:        Modified BSD License
8 Group:          Libraries
9 #Source0Download: https://github.com/frankosterfeld/qtkeychain/releases
10 Source0:        https://github.com/frankosterfeld/qtkeychain/archive/v%{version}/%{name}-%{version}.tar.gz
11 # Source0-md5:  4c398ebd45e7753efa1951b0857e840d
12 URL:            https://github.com/frankosterfeld/qtkeychain
13 BuildRequires:  QtCore-devel >= 4
14 BuildRequires:  QtDBus-devel >= 4
15 BuildRequires:  cmake >= 2.8.11
16 BuildRequires:  libsecret-devel
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  pkgconfig
19 BuildRequires:  rpmbuild(find_lang) >= 1.37
20 BuildRequires:  rpmbuild(macros) >= 1.605
21 BuildRequires:  qt4-build >= 4
22 BuildRequires:  qt4-linguist >= 4
23 BuildRequires:  qt4-qmake >= 4
24 Obsoletes:      QtKeychain-common < 0.10
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 QtKeychain a Qt API to store passwords and other secret data securely.
29
30 How the data is stored depends on the platform:
31 - Mac OS X: Passwords are stored in the OS X Keychain.
32 - Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
33   tries to use KWallet (via D-Bus), if available.
34 - Windows: Windows does not provide a service for secure storage.
35   QtKeychain uses the Windows API function
36
37 %description -l pl.UTF-8
38 API Qt do bezpiecznego przechowywania haseł i innych tajnych danych.
39
40 Sposób przechowywania danych zależy od platformy:
41 - Mac OS X: hasła są przechowywanie poprzez usługę OS X Keychain
42 - Linux/Unix: używany jest GNOME Keyring jeśli jest uruchomiony,
43   w przeciwnym wypadku używany jest KWallet (przez DBus), o ile jest
44   dostępny
45 - Windows: system nie udostępnia usługi do bezpiecznego przechowywania
46   danych; QtKeychain używa funkcji Windows API
47
48 %package devel
49 Summary:        Development files for QtKeychain
50 Summary(pl.UTF-8):      Pliki programistyczne biblioteki QtKeychain
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       QtCore-devel >= 4
54
55 %description devel
56 This package contains the header files for developing applications
57 that use QtKeychain.
58
59 %description devel -l pl.UTF-8
60 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
61 wykorzystujących bibliotekę QtKeychain.
62
63 %prep
64 %setup -q -n qtkeychain-%{version}
65
66 %build
67 install -d build-qt4
68 cd build-qt4
69 %cmake .. \
70         -DBUILD_WITH_QT4:BOOL=ON \
71         -DECM_MKSPECS_INSTALL_DIR=%{_libdir}/qt4/mkspecs/modules
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} -C build-qt4 install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %find_lang qtkeychain --with-qm
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post   -p /sbin/ldconfig
86 %postun -p /sbin/ldconfig
87
88 %files -f qtkeychain.lang
89 %defattr(644,root,root,755)
90 %doc COPYING ChangeLog ReadMe.txt
91 %attr(755,root,root) %{_libdir}/libqtkeychain.so.*.*.*
92 %attr(755,root,root) %ghost %{_libdir}/libqtkeychain.so.1
93 %dir %{_datadir}/qtkeychain
94 %dir %{_datadir}/qtkeychain/translations
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/libqtkeychain.so
99 %{_includedir}/qtkeychain
100 %{_libdir}/cmake/QtKeychain
101 %{_libdir}/qt4/mkspecs/modules/qt_QtKeychain.pri
This page took 0.101625 seconds and 4 git commands to generate.