]> git.pld-linux.org Git - packages/QtKeychain.git/blob - QtKeychain.spec
unify, fix bad copy paste?
[packages/QtKeychain.git] / QtKeychain.spec
1 Summary:        Qt API to store passwords and other secret data securely
2 Name:           QtKeychain
3 Version:        0.3.0
4 Release:        0.1
5 License:        Modified BSD License
6 Group:          Libraries
7 # Repackaged from https://github.com/frankosterfeld/qtkeychain/archive/master.zip
8 Source0:        %{name}-%{version}.tar.bz2
9 # Source0-md5:  a9de9be0cae568c03b152009d24ff170
10 URL:            https://github.com/frankosterfeld/qtkeychain
11 BuildRequires:  QtCore-devel
12 BuildRequires:  libstdc++-devel
13 BuildRequires:  qt4-build
14 BuildRequires:  qt4-linguist
15 BuildRequires:  qt4-qmake
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _qt4_datadir    %{_datadir}/qt4
19
20 %description
21 QtKeychain a Qt API to store passwords and other secret data securely.
22 How the data is stored depends on the platform:
23 - Mac OS X: Passwords are stored in the OS X Keychain.
24 - Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
25   tries to use KWallet (via D-Bus), if available.
26 - Windows: Windows does not provide a service for secure storage.
27   QtKeychain uses the Windows API function
28
29 %package devel
30 Summary:        Development files for QtKeychain
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33 Requires:       qt4-build
34 Requires:       qt4-qmake
35
36 %description devel
37 This package contains libraries and header files for developing
38 applications that use QKeychain.
39
40 %prep
41 %setup -q
42
43 %build
44 install -d build
45 cd build
46 %cmake \
47                 ..
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 %{__make} -C build install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post   -p /sbin/ldconfig
59 %postun -p /sbin/ldconfig
60
61 %files
62 %defattr(644,root,root,755)
63 %doc COPYING ReadMe.txt ChangeLog
64 %attr(755,root,root) %{_libdir}/libqtkeychain.so.*.*.*
65 %attr(755,root,root) %ghost %{_libdir}/libqtkeychain.so.0
66
67 %files devel
68 %defattr(644,root,root,755)
69 #%doc doc examples
70 %dir %{_includedir}/qtkeychain
71 %{_includedir}/qtkeychain/keychain.h
72 %{_includedir}/qtkeychain/qkeychain_export.h
73 %dir %{_libdir}/cmake/QtKeychain
74 %attr(755,root,root) %{_libdir}/libqtkeychain.so
75 %{_libdir}/cmake/QtKeychain/QtKeychainLibraryDepends.cmake
76 %{_libdir}/cmake/QtKeychain/QtKeychainLibraryDepends-pld.cmake
77 %{_libdir}/cmake/QtKeychain/QtKeychainConfig.cmake
78 %{_libdir}/cmake/QtKeychain/QtKeychainConfigVersion.cmake
This page took 0.057628 seconds and 3 git commands to generate.