]> git.pld-linux.org Git - packages/QtKeychain.git/blob - QtKeychain.spec
- up to 0.8.0
[packages/QtKeychain.git] / QtKeychain.spec
1 #
2 # Conditional build:
3 %bcond_without  qt4             # build Qt4
4 %bcond_without  qt5             # build Qt5
5
6 Summary:        Qt API to store passwords and other secret data securely
7 Name:           QtKeychain
8 Version:        0.8.0
9 Release:        1
10 License:        Modified BSD License
11 Group:          Libraries
12 Source0:        https://github.com/frankosterfeld/qtkeychain/archive/v%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  d741e7e55ae48a130cb95264fbe732b7
14 Patch0:         cmake.patch
15 URL:            https://github.com/frankosterfeld/qtkeychain
16 BuildRequires:  cmake
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  rpmbuild(find_lang) >= 1.37
19 %if %{with qt4}
20 BuildRequires:  QtCore-devel
21 BuildRequires:  QtDBus-devel
22 BuildRequires:  qt4-build
23 BuildRequires:  qt4-linguist
24 BuildRequires:  qt4-qmake
25 %endif
26 %if %{with qt5}
27 BuildRequires:  Qt5Core-devel
28 BuildRequires:  Qt5DBus-devel
29 BuildRequires:  qt5-build
30 BuildRequires:  qt5-linguist
31 BuildRequires:  qt5-qmake
32 %endif
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 #define skip_post_check_so      libqt5keychain.so.*
36
37 %description
38 QtKeychain a Qt API to store passwords and other secret data securely.
39
40 How the data is stored depends on the platform:
41 - Mac OS X: Passwords are stored in the OS X Keychain.
42 - Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
43   tries to use KWallet (via D-Bus), if available.
44 - Windows: Windows does not provide a service for secure storage.
45   QtKeychain uses the Windows API function
46
47 %package devel
48 Summary:        Development files for QtKeychain
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 This package contains libraries and header files for developing
54 applications that use QKeychain.
55
56 %package -n Qt5Keychain
57 Summary:        Qt API to store passwords and other secret data securely
58 Group:          Libraries
59
60 %description -n Qt5Keychain
61 QtKeychain a Qt API to store passwords and other secret data securely.
62
63 How the data is stored depends on the platform:
64 - Mac OS X: Passwords are stored in the OS X Keychain.
65 - Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
66   tries to use KWallet (via D-Bus), if available.
67 - Windows: Windows does not provide a service for secure storage.
68   QtKeychain uses the Windows API function
69
70 %package -n Qt5Keychain-devel
71 Summary:        Development files for QtKeychain
72 Group:          Development/Libraries
73 Requires:       Qt5Keychain = %{version}-%{release}
74
75 %description -n Qt5Keychain-devel
76 This package contains libraries and header files for developing
77 applications that use QKeychain.
78
79 %prep
80 %setup -q -n qtkeychain-%{version}
81 %patch0 -p1
82
83 %build
84 %if %{with qt4}
85 install -d build-qt4
86 cd build-qt4
87 %cmake \
88         -DBUILD_WITH_QT4:BOOL=TRUE \
89         ..
90 %{__make}
91 cd ..
92 %endif
93
94 %if %{with qt5}
95 install -d build-qt5
96 cd build-qt5
97 %cmake \
98         -DBUILD_WITH_QT4:BOOL=OFF \
99         ..
100 %{__make}
101 %endif
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 %if %{with qt4}
106 %{__make} -C build-qt4 install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %find_lang qtkeychain --with-qm
110 %endif
111
112 %if %{with qt5}
113 %{__make} -C build-qt5 install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %find_lang qtkeychain --with-qm
117 %endif
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %if %{with qt4}
126 %files -f qtkeychain.lang
127 %defattr(644,root,root,755)
128 %doc COPYING ReadMe.txt ChangeLog
129 %attr(755,root,root) %{_libdir}/libqtkeychain.so.*.*.*
130 %ghost %{_libdir}/libqtkeychain.so.1
131
132 %files devel
133 %defattr(644,root,root,755)
134 %{_includedir}/qtkeychain
135 %{_libdir}/libqtkeychain.so
136 %{_libdir}/cmake/QtKeychain
137 %endif
138
139 %if %{with qt5}
140 %files -n Qt5Keychain
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libqt5keychain.so.*.*.*
143 %ghost %{_libdir}/libqt5keychain.so.1
144
145 %files -n Qt5Keychain-devel
146 %defattr(644,root,root,755)
147 %{_includedir}/qt5keychain
148 %{_libdir}/libqt5keychain.so
149 %{_libdir}/cmake/Qt5Keychain
150 %endif
This page took 0.068533 seconds and 3 git commands to generate.