]> git.pld-linux.org Git - packages/QtKeychain.git/blob - QtKeychain.spec
576d287bca3e86e5b2efa99699b3fd87e41836c2
[packages/QtKeychain.git] / QtKeychain.spec
1 # TODO
2 # - qt5 version
3 Summary:        Qt API to store passwords and other secret data securely
4 Name:           QtKeychain
5 Version:        0.3.0
6 Release:        1
7 License:        Modified BSD License
8 Group:          Libraries
9 # Repackaged from https://github.com/frankosterfeld/qtkeychain/archive/master.zip
10 Source0:        %{name}-%{version}.tar.bz2
11 # Source0-md5:  a9de9be0cae568c03b152009d24ff170
12 URL:            https://github.com/frankosterfeld/qtkeychain
13 BuildRequires:  QtCore-devel
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  qt4-build
16 BuildRequires:  qt4-linguist
17 BuildRequires:  qt4-qmake
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 QtKeychain a Qt API to store passwords and other secret data securely.
22
23 How the data is stored depends on the platform:
24 - Mac OS X: Passwords are stored in the OS X Keychain.
25 - Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
26   tries to use KWallet (via D-Bus), if available.
27 - Windows: Windows does not provide a service for secure storage.
28   QtKeychain uses the Windows API function
29
30 %package devel
31 Summary:        Development files for QtKeychain
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34 Requires:       qt4-build
35 Requires:       qt4-qmake
36
37 %description devel
38 This package contains libraries and header files for developing
39 applications that use QKeychain.
40
41 %prep
42 %setup -q
43
44 %build
45 install -d build
46 cd build
47 %cmake \
48         -DBUILD_WITH_QT4=ON \
49         ..
50 %{__make}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 %{__make} -C build install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %find_lang qtkeychain --with-qm
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post   -p /sbin/ldconfig
63 %postun -p /sbin/ldconfig
64
65 %files -f qtkeychain.lang
66 %defattr(644,root,root,755)
67 %doc COPYING ReadMe.txt ChangeLog
68 %attr(755,root,root) %{_libdir}/libqtkeychain.so.*.*.*
69 %attr(755,root,root) %ghost %{_libdir}/libqtkeychain.so.0
70
71 %files devel
72 %defattr(644,root,root,755)
73 %dir %{_includedir}/qtkeychain
74 %{_includedir}/qtkeychain/keychain.h
75 %{_includedir}/qtkeychain/qkeychain_export.h
76 %dir %{_libdir}/cmake/QtKeychain
77 %attr(755,root,root) %{_libdir}/libqtkeychain.so
78 %{_libdir}/cmake/QtKeychain/QtKeychainLibraryDepends.cmake
79 %{_libdir}/cmake/QtKeychain/QtKeychainLibraryDepends-pld.cmake
80 %{_libdir}/cmake/QtKeychain/QtKeychainConfig.cmake
81 %{_libdir}/cmake/QtKeychain/QtKeychainConfigVersion.cmake
This page took 0.048505 seconds and 2 git commands to generate.