]> git.pld-linux.org Git - packages/QtKeychain.git/blame - QtKeychain.spec
update BR
[packages/QtKeychain.git] / QtKeychain.spec
CommitLineData
2e1a2913
ER
1#
2# Conditional build:
3%bcond_without qt4 # build Qt4
4%bcond_without qt5 # build Qt5
5
8f55f1bc
LM
6Summary: Qt API to store passwords and other secret data securely
7Name: QtKeychain
fbb6061a 8Version: 0.4.0
d72e11a6 9Release: 1
8f55f1bc
LM
10License: Modified BSD License
11Group: Libraries
fbb6061a
ER
12Source0: https://github.com/frankosterfeld/qtkeychain/archive/v%{version}/%{name}-%{version}.tar.gz
13# Source0-md5: e4e48d8742a9fd2664425d58be236424
07788830 14URL: https://github.com/frankosterfeld/qtkeychain
2e1a2913 15BuildRequires: cmake
8f55f1bc 16BuildRequires: libstdc++-devel
f3986110 17BuildRequires: rpmbuild(find_lang) >= 1.37
2e1a2913
ER
18%if %{with qt4}
19BuildRequires: QtCore-devel
f3986110 20BuildRequires: QtDBus-devel
8f55f1bc 21BuildRequires: qt4-build
97e26aaa 22BuildRequires: qt4-linguist
8f55f1bc 23BuildRequires: qt4-qmake
2e1a2913
ER
24%endif
25%if %{with qt5}
26BuildRequires: Qt5Core-devel
f3986110 27BuildRequires: Qt5DBus-devel
2e1a2913
ER
28BuildRequires: qt5-build
29BuildRequires: qt5-linguist
30BuildRequires: qt5-qmake
31%endif
8f55f1bc
LM
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
8f55f1bc 34%description
07788830 35QtKeychain a Qt API to store passwords and other secret data securely.
d72e11a6 36
8f55f1bc
LM
37How the data is stored depends on the platform:
38- Mac OS X: Passwords are stored in the OS X Keychain.
39- Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
40 tries to use KWallet (via D-Bus), if available.
41- Windows: Windows does not provide a service for secure storage.
42 QtKeychain uses the Windows API function
43
44%package devel
8f55f1bc
LM
45Summary: Development files for QtKeychain
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48Requires: qt4-build
49Requires: qt4-qmake
50
51%description devel
52This package contains libraries and header files for developing
53applications that use QKeychain.
54
2e1a2913
ER
55%package -n Qt5Keychain
56Summary: Qt API to store passwords and other secret data securely
57Group: Libraries
58Requires: qt5-build
59Requires: qt5-qmake
60
61%description -n Qt5Keychain
62QtKeychain a Qt API to store passwords and other secret data securely.
63
64How the data is stored depends on the platform:
65- Mac OS X: Passwords are stored in the OS X Keychain.
66- Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
67 tries to use KWallet (via D-Bus), if available.
68- Windows: Windows does not provide a service for secure storage.
69 QtKeychain uses the Windows API function
70
71%package -n Qt5Keychain-devel
72Summary: Development files for QtKeychain
73Group: Development/Libraries
74Requires: Qt5Keychain = %{version}-%{release}
75Requires: qt5-build
76Requires: qt5-qmake
77
78%description -n Qt5Keychain-devel
79This package contains libraries and header files for developing
80applications that use QKeychain.
81
8f55f1bc 82%prep
fbb6061a 83%setup -q -n qtkeychain-%{version}
8f55f1bc
LM
84
85%build
2e1a2913
ER
86%if %{with qt4}
87install -d build-qt4
88cd build-qt4
8f55f1bc 89%cmake \
d72e11a6
ER
90 -DBUILD_WITH_QT4=ON \
91 ..
8f55f1bc 92%{__make}
2e1a2913
ER
93cd ..
94%endif
95
96%if %{with qt5}
97install -d build-qt5
98cd build-qt5
99%cmake \
100 -DBUILD_WITH_QT4=OFF \
101 ..
102%{__make}
103%endif
8f55f1bc
LM
104
105%install
106rm -rf $RPM_BUILD_ROOT
2e1a2913
ER
107%if %{with qt4}
108%{__make} -C build-qt4 install \
07788830 109 DESTDIR=$RPM_BUILD_ROOT
8f55f1bc 110
d72e11a6 111%find_lang qtkeychain --with-qm
2e1a2913
ER
112%endif
113
114%if %{with qt5}
115%{__make} -C build-qt5 install \
116 DESTDIR=$RPM_BUILD_ROOT
117
118%find_lang qtkeychain --with-qm
119%endif
d72e11a6 120
8f55f1bc
LM
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%post -p /sbin/ldconfig
07788830 125%postun -p /sbin/ldconfig
8f55f1bc 126
2e1a2913 127%if %{with qt4}
d72e11a6 128%files -f qtkeychain.lang
8f55f1bc
LM
129%defattr(644,root,root,755)
130%doc COPYING ReadMe.txt ChangeLog
131%attr(755,root,root) %{_libdir}/libqtkeychain.so.*.*.*
2e1a2913 132%ghost %{_libdir}/libqtkeychain.so.0
8f55f1bc
LM
133
134%files devel
135%defattr(644,root,root,755)
2e1a2913
ER
136%{_includedir}/qtkeychain
137%{_libdir}/libqtkeychain.so
138%{_libdir}/cmake/QtKeychain
139%endif
140
141%if %{with qt5}
142%files -n Qt5Keychain
143%defattr(644,root,root,755)
144%attr(755,root,root) %{_libdir}/libqt5keychain.so.*.*.*
145%ghost %{_libdir}/libqt5keychain.so.0
146
147%files -n Qt5Keychain-devel
148%defattr(644,root,root,755)
149%{_includedir}/qt5keychain
150%{_libdir}/libqt5keychain.so
151%{_libdir}/cmake/Qt5Keychain
152%endif
This page took 0.099759 seconds and 4 git commands to generate.