]> git.pld-linux.org Git - packages/QtKeychain.git/blame - QtKeychain.spec
ensure qt4 version is built, package lang; rel 1
[packages/QtKeychain.git] / QtKeychain.spec
CommitLineData
d72e11a6
ER
1# TODO
2# - qt5 version
8f55f1bc
LM
3Summary: Qt API to store passwords and other secret data securely
4Name: QtKeychain
5Version: 0.3.0
d72e11a6 6Release: 1
8f55f1bc
LM
7License: Modified BSD License
8Group: Libraries
8f55f1bc
LM
9# Repackaged from https://github.com/frankosterfeld/qtkeychain/archive/master.zip
10Source0: %{name}-%{version}.tar.bz2
11# Source0-md5: a9de9be0cae568c03b152009d24ff170
07788830 12URL: https://github.com/frankosterfeld/qtkeychain
8f55f1bc
LM
13BuildRequires: QtCore-devel
14BuildRequires: libstdc++-devel
15BuildRequires: qt4-build
97e26aaa 16BuildRequires: qt4-linguist
8f55f1bc
LM
17BuildRequires: qt4-qmake
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
8f55f1bc 20%description
07788830 21QtKeychain a Qt API to store passwords and other secret data securely.
d72e11a6 22
8f55f1bc
LM
23How the data is stored depends on the platform:
24- Mac OS X: Passwords are stored in the OS X Keychain.
25- Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
26 tries to use KWallet (via D-Bus), if available.
27- Windows: Windows does not provide a service for secure storage.
28 QtKeychain uses the Windows API function
29
30%package devel
8f55f1bc
LM
31Summary: Development files for QtKeychain
32Group: Development/Libraries
33Requires: %{name} = %{version}-%{release}
34Requires: qt4-build
35Requires: qt4-qmake
36
37%description devel
38This package contains libraries and header files for developing
39applications that use QKeychain.
40
41%prep
42%setup -q
43
44%build
45install -d build
46cd build
47%cmake \
d72e11a6
ER
48 -DBUILD_WITH_QT4=ON \
49 ..
8f55f1bc
LM
50%{__make}
51
52%install
53rm -rf $RPM_BUILD_ROOT
54%{__make} -C build install \
07788830 55 DESTDIR=$RPM_BUILD_ROOT
8f55f1bc 56
d72e11a6
ER
57%find_lang qtkeychain --with-qm
58
8f55f1bc
LM
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%post -p /sbin/ldconfig
07788830 63%postun -p /sbin/ldconfig
8f55f1bc 64
d72e11a6 65%files -f qtkeychain.lang
8f55f1bc
LM
66%defattr(644,root,root,755)
67%doc COPYING ReadMe.txt ChangeLog
68%attr(755,root,root) %{_libdir}/libqtkeychain.so.*.*.*
69%attr(755,root,root) %ghost %{_libdir}/libqtkeychain.so.0
8f55f1bc
LM
70
71%files devel
72%defattr(644,root,root,755)
8f55f1bc
LM
73%dir %{_includedir}/qtkeychain
74%{_includedir}/qtkeychain/keychain.h
75%{_includedir}/qtkeychain/qkeychain_export.h
76%dir %{_libdir}/cmake/QtKeychain
7e07d501 77%attr(755,root,root) %{_libdir}/libqtkeychain.so
8f55f1bc
LM
78%{_libdir}/cmake/QtKeychain/QtKeychainLibraryDepends.cmake
79%{_libdir}/cmake/QtKeychain/QtKeychainLibraryDepends-pld.cmake
80%{_libdir}/cmake/QtKeychain/QtKeychainConfig.cmake
81%{_libdir}/cmake/QtKeychain/QtKeychainConfigVersion.cmake
This page took 0.076814 seconds and 4 git commands to generate.