]> git.pld-linux.org Git - packages/QtKeychain.git/blame - QtKeychain.spec
- Initial spec.
[packages/QtKeychain.git] / QtKeychain.spec
CommitLineData
8f55f1bc
LM
1Summary: Qt API to store passwords and other secret data securely
2Name: QtKeychain
3Version: 0.3.0
4Release: 0.1
5License: Modified BSD License
6Group: Libraries
7URL: https://github.com/frankosterfeld/qtkeychain
8# Repackaged from https://github.com/frankosterfeld/qtkeychain/archive/master.zip
9Source0: %{name}-%{version}.tar.bz2
10# Source0-md5: a9de9be0cae568c03b152009d24ff170
11BuildRequires: QtCore-devel
12BuildRequires: libstdc++-devel
13BuildRequires: qt4-build
14BuildRequires: qt4-qmake
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%define _qt4_datadir %{_datadir}/qt4
18
19%description
20
21%in is a Qt API to store passwords and other secret data securely.
22How the data is stored depends on the platform:
23- Mac OS X: Passwords are stored in the OS X Keychain.
24- Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
25 tries to use KWallet (via D-Bus), if available.
26- Windows: Windows does not provide a service for secure storage.
27 QtKeychain uses the Windows API function
28
29%package devel
30
31Summary: Development files for QtKeychain
32Group: Development/Libraries
33Requires: %{name} = %{version}-%{release}
34Requires: qt4-build
35Requires: qt4-qmake
36
37%description devel
38This package contains libraries and header files for developing
39applications that use QKeychain.
40
41%prep
42%setup -q
43
44%build
45install -d build
46cd build
47%cmake \
48 ../
49
50%{__make}
51
52%install
53rm -rf $RPM_BUILD_ROOT
54%{__make} -C build install \
55 DESTDIR=$RPM_BUILD_ROOT
56
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%post -p /sbin/ldconfig
61%postun -p /sbin/ldconfig
62
63%files
64%defattr(644,root,root,755)
65%doc COPYING ReadMe.txt ChangeLog
66%attr(755,root,root) %{_libdir}/libqtkeychain.so.*.*.*
67%attr(755,root,root) %ghost %{_libdir}/libqtkeychain.so.0
68%attr(755,root,root) %ghost %{_libdir}/libqtkeychain.so
69
70%files devel
71%defattr(644,root,root,755)
72#%doc doc examples
73%dir %{_includedir}/qtkeychain
74%{_includedir}/qtkeychain/keychain.h
75%{_includedir}/qtkeychain/qkeychain_export.h
76%dir %{_libdir}/cmake/QtKeychain
77%{_libdir}/cmake/QtKeychain/QtKeychainLibraryDepends.cmake
78%{_libdir}/cmake/QtKeychain/QtKeychainLibraryDepends-pld.cmake
79%{_libdir}/cmake/QtKeychain/QtKeychainConfig.cmake
80%{_libdir}/cmake/QtKeychain/QtKeychainConfigVersion.cmake
This page took 0.064772 seconds and 4 git commands to generate.