]> git.pld-linux.org Git - packages/OpenImageIO.git/commitdiff
- fix building with ffmpeg 3 auto/th/OpenImageIO-1.6.8-4
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 21 Mar 2016 09:23:23 +0000 (10:23 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 21 Mar 2016 09:23:23 +0000 (10:23 +0100)
- rel 4

OpenImageIO.spec
ffmpeg3.patch [new file with mode: 0644]

index 0a2c2439a3836ae6801a692f9f8e55127c4f2089..a6f89b062c79b4c72ddeb9f8b583f51954ad0336 100644 (file)
@@ -17,7 +17,7 @@ Summary:      Library for reading and writing images
 Summary(pl.UTF-8):     Biblioteka do odczytu i zapisu obrazów
 Name:          OpenImageIO
 Version:       1.6.8
-Release:       3
+Release:       4
 License:       BSD
 Group:         Libraries
 Source0:       https://github.com/OpenImageIO/oiio/tarball/Release-%{version}/%{name}-%{version}.tar.gz
@@ -30,6 +30,7 @@ Patch4:               %{name}-system-libcineon.patch
 Patch5:                %{name}-werror.patch
 Patch6:                system-pugixml.patch
 Patch7:                fix-types.patch
+Patch8:                ffmpeg3.patch
 URL:           https://sites.google.com/site/openimageio/home
 BuildRequires: Field3D-devel
 %{?with_ocio:BuildRequires:    OpenColorIO-devel}
@@ -351,6 +352,7 @@ Wiązanie Pythona do biblioteki OpenImageIO.
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
 
 %{__rm} -r src/dds.imageio/squish src/ptex.imageio/ptex
 # when using system pugixml, don't use hacked headers
@@ -371,6 +373,7 @@ CXXFLAGS="%{rpmcxxflags} -std=c++11" \
        -DPYLIB_INSTALL_DIR=%{py_sitedir} \
        -DPYTHON_VERSION=%{py_ver} \
        -DUSE_EXTERNAL_PUGIXML=ON \
+       -DSTOP_ON_WARNING=OFF \
        %{!?with_ocio:-DUSE_OCIO=OFF} \
        %{!?with_tbb:-DUSE_TBB=OFF}
 
diff --git a/ffmpeg3.patch b/ffmpeg3.patch
new file mode 100644 (file)
index 0000000..0ae1314
--- /dev/null
@@ -0,0 +1,29 @@
+--- OpenImageIO-oiio-4070df8/src/ffmpeg.imageio/ffmpeginput.cpp~       2015-12-19 07:44:03.000000000 +0100
++++ OpenImageIO-oiio-4070df8/src/ffmpeg.imageio/ffmpeginput.cpp        2016-03-21 10:21:22.218287557 +0100
+@@ -236,7 +236,7 @@
+     m_frame = av_frame_alloc();
+     m_rgb_frame = av_frame_alloc();
+     m_rgb_buffer.resize(
+-        avpicture_get_size (PIX_FMT_RGB24,
++        avpicture_get_size (AV_PIX_FMT_RGB24,
+         m_codec_context->width,
+         m_codec_context->height),
+         0
+@@ -264,7 +264,7 @@
+         pixFormat,
+         m_codec_context->width,
+         m_codec_context->height,
+-        PIX_FMT_RGB24,
++        AV_PIX_FMT_RGB24,
+         SWS_AREA,
+         NULL,
+         NULL,
+@@ -361,7 +361,7 @@
+                 (
+                     reinterpret_cast<AVPicture*>(m_rgb_frame),
+                     &m_rgb_buffer[0],
+-                    PIX_FMT_RGB24,
++                    AV_PIX_FMT_RGB24,
+                     m_codec_context->width,
+                     m_codec_context->height
+                 );
This page took 0.253905 seconds and 4 git commands to generate.