]> git.pld-linux.org Git - packages/Mesa.git/commitdiff
- updated to 19.1.7 auto/th/Mesa-19.1.7-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 6 Oct 2019 19:05:27 +0000 (21:05 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 6 Oct 2019 19:05:27 +0000 (21:05 +0200)
- removed obsolete bug111552 patch
- added xvmc-link patch (fixes build with libXvMC 1.0.12, which no longer pulls libXv; need to link with libXv explicitly now)

Mesa-xvmc-link.patch [new file with mode: 0644]
Mesa.spec
bug111552.patch [deleted file]

diff --git a/Mesa-xvmc-link.patch b/Mesa-xvmc-link.patch
new file mode 100644 (file)
index 0000000..0031af6
--- /dev/null
@@ -0,0 +1,23 @@
+--- mesa-mesa-19.1.7/meson.build.orig  2019-09-17 12:31:43.000000000 +0200
++++ mesa-mesa-19.1.7/meson.build       2019-10-06 20:18:10.222928443 +0200
+@@ -493,7 +493,8 @@
+ with_gallium_xvmc = false
+ if _xvmc != 'false'
+   dep_xvmc = dependency('xvmc', version : '>= 1.0.6', required : _xvmc == 'true')
+-  with_gallium_xvmc = dep_xvmc.found()
++  dep_xv = dependency('xv', required : _xvmc == 'true')
++  with_gallium_xvmc = dep_xvmc.found() and dep_xv.found()
+ endif
+ xvmc_drivers_path = get_option('xvmc-libs-path')
+--- mesa-mesa-19.1.7/src/gallium/state_trackers/xvmc/meson.build.orig  2019-09-17 12:31:43.000000000 +0200
++++ mesa-mesa-19.1.7/src/gallium/state_trackers/xvmc/meson.build       2019-10-06 20:18:31.069482175 +0200
+@@ -23,7 +23,7 @@
+   files('attributes.c', 'block.c', 'context.c', 'surface.c', 'subpicture.c'),
+   c_args : [c_vis_args],
+   include_directories : [inc_common],
+-  dependencies : [dep_xvmc, dep_x11_xcb, dep_xcb, dep_xcb_dri2, dep_xcb_dri3],
++  dependencies : [dep_xvmc, dep_xv, dep_x11_xcb, dep_xcb, dep_xcb_dri2, dep_xcb_dri3],
+ )
+ # These tests will not work without a working xvmc configuration. 
index 298c3d18b057deb934d05b84311a4ea38dc418dc..ed4bca201d609b4c94c8f2a792460f94a7709f62 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     WolnodostÄ™pna implementacja standardu OpenGL
 Name:          Mesa
-Version:       19.1.6
+Version:       19.1.7
 Release:       1
 License:       MIT (core) and others - see license.html file
 Group:         X11/Libraries
 #Source0:      ftp://ftp.freedesktop.org/pub/mesa/mesa-%{version}.tar.xz
 ## Source0-md5:        7c61a801311fb8d2f7b3cceb7b5cf308
 Source0:       https://gitlab.freedesktop.org/mesa/mesa/-/archive/mesa-%{version}/mesa-mesa-%{version}.tar.bz2
-# Source0-md5: 090aae399f31f7518f44be4a93a5f4b7
+# Source0-md5: 77c1b518e5a29d8a5c4d57adcaefbe12
 Patch0:                nouveau_no_rtti.patch
 Patch1:                i9x5-tex-ignore-the-diff-between-GL_TEXTURE_2D-and-GL_TEXTURE_RECTANGLE.patch
-Patch2:                bug111552.patch
+Patch2:                %{name}-xvmc-link.patch
 URL:           http://www.mesa3d.org/
 %{?with_opencl:BuildRequires:  clang-devel >= %{llvm_ver}}
 BuildRequires: elfutils-devel
@@ -93,7 +93,7 @@ BuildRequires:        pkgconfig(xcb-dri3) >= 1.13
 BuildRequires: pkgconfig(xcb-glx) >= 1.8.1
 BuildRequires: pkgconfig(xcb-present) >= 1.13
 BuildRequires: pkgconfig(xcb-randr) >= 1.12
-BuildRequires: python3
+BuildRequires: python3 >= 1:3.2
 BuildRequires: python3-Mako >= 0.8.0
 BuildRequires: rpmbuild(macros) >= 1.470
 BuildRequires: sed >= 4.0
@@ -1306,7 +1306,6 @@ radv - eksperymentalny sterownik Vulkan dla GPU firmy AMD.
 %patch2 -p1
 
 %build
-
 %if %{with opencl}
 if [ "$(llvm-config --has-rtti)" != "YES" ] ; then
        echo "Clover (gallium OpenCL) requires LLVM with RTTI!"
diff --git a/bug111552.patch b/bug111552.patch
deleted file mode 100644 (file)
index 1e053f5..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-From 3b1a7e5333335900293935399ce49a67562eafc7 Mon Sep 17 00:00:00 2001
-From: Jason Ekstrand <jason@jlekstrand.net>
-Date: Tue, 3 Sep 2019 10:00:23 -0500
-Subject: [PATCH] anv: Bump maxComputeWorkgroupSize
-
-Fixes: 9a129510f56f "anv: Bump maxComputeWorkgroupInvocations"
-Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=111552
-Reviewed-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com>
----
- src/intel/vulkan/anv_device.c | 10 ++++++----
- 1 file changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/src/intel/vulkan/anv_device.c b/src/intel/vulkan/anv_device.c
-index a6572135c91..3497a01f900 100644
---- a/src/intel/vulkan/anv_device.c
-+++ b/src/intel/vulkan/anv_device.c
-@@ -1264,6 +1264,8 @@ void anv_GetPhysicalDeviceProperties(
-       pdevice->has_a64_buffer_access ? UINT32_MAX :
-                                        MAX_BINDING_TABLE_SIZE - MAX_RTS;
-+   const uint32_t max_workgroup_size = 32 * devinfo->max_cs_threads;
-+
-    VkSampleCountFlags sample_counts =
-       isl_device_get_sample_counts(&pdevice->isl_dev);
-@@ -1322,11 +1324,11 @@ void anv_GetPhysicalDeviceProperties(
-       .maxFragmentCombinedOutputResources       = 8,
-       .maxComputeSharedMemorySize               = 64 * 1024,
-       .maxComputeWorkGroupCount                 = { 65535, 65535, 65535 },
--      .maxComputeWorkGroupInvocations           = 32 * devinfo->max_cs_threads,
-+      .maxComputeWorkGroupInvocations           = max_workgroup_size,
-       .maxComputeWorkGroupSize = {
--         16 * devinfo->max_cs_threads,
--         16 * devinfo->max_cs_threads,
--         16 * devinfo->max_cs_threads,
-+         max_workgroup_size,
-+         max_workgroup_size,
-+         max_workgroup_size,
-       },
-       .subPixelPrecisionBits                    = 8,
-       .subTexelPrecisionBits                    = 8,
--- 
-2.22.0
-
This page took 0.070914 seconds and 4 git commands to generate.