]> git.pld-linux.org Git - packages/Mesa.git/commitdiff
up to 21.1.0
authorJan Palus <atler@pld-linux.org>
Thu, 6 May 2021 20:25:35 +0000 (22:25 +0200)
committerJan Palus <atler@pld-linux.org>
Thu, 6 May 2021 20:25:35 +0000 (22:25 +0200)
- i9x5-tex-ignore-the-diff-between-GL_TEXTURE_2D-and-GL_TEXTURE_RECTANGLE
  patch appears to be obsolete for quite a while

Mesa.spec
i9x5-tex-ignore-the-diff-between-GL_TEXTURE_2D-and-GL_TEXTURE_RECTANGLE.patch [deleted file]

index f78c9d7767928509eb9fa18c6e18a2856f9c9e7c..bd107fbb2711d707c287d1cd36d22dd19c6f12bf 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
@@ -29,7 +29,7 @@
 # (until they start to be somehow versioned themselves)
 %define                glapi_ver               7.1.0
 # other packages
-%define                libdrm_ver              2.4.102
+%define                libdrm_ver              2.4.105
 %define                dri2proto_ver           2.8
 %define                glproto_ver             1.4.14
 %define                zlib_ver                1.2.8
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     WolnodostÄ™pna implementacja standardu OpenGL
 Name:          Mesa
-Version:       21.0.3
+Version:       21.1.0
 Release:       1
 License:       MIT (core) and others - see license.html file
 Group:         X11/Libraries
 #Source0:      ftp://ftp.freedesktop.org/pub/mesa/mesa-%{version}.tar.xz
 ## Source0-md5:        7c61a801311fb8d2f7b3cceb7b5cf308
 Source0:       https://gitlab.freedesktop.org/mesa/mesa/-/archive/mesa-%{version}/mesa-mesa-%{version}.tar.bz2
-# Source0-md5: 6dda027f1af6c76f5afe9a828dde0139
+# Source0-md5: 7482dd659c3708bdda247c96449d9d79
 Patch0:                nouveau_no_rtti.patch
-Patch1:                i9x5-tex-ignore-the-diff-between-GL_TEXTURE_2D-and-GL_TEXTURE_RECTANGLE.patch
 URL:           http://www.mesa3d.org/
 %{?with_opencl_spirv:BuildRequires:    SPIRV-LLVM-Translator-devel >= 8.0.1.3}
 %{?with_gallium_zink:BuildRequires:    Vulkan-Loader-devel}
@@ -1444,7 +1443,6 @@ radv - eksperymentalny sterownik Vulkan dla GPU firmy AMD.
 %prep
 %setup -q -n mesa-mesa-%{version}
 %patch0 -p1
-%patch1 -p1
 
 %build
 %if %{with opencl}
@@ -1478,7 +1476,6 @@ nouveau
 %ifarch %{arm} aarch64
 etnaviv \
 freedreno \
-kmsro \
 lima \
 panfrost \
 %{?with_gallium_nouveau:tegra} \
diff --git a/i9x5-tex-ignore-the-diff-between-GL_TEXTURE_2D-and-GL_TEXTURE_RECTANGLE.patch b/i9x5-tex-ignore-the-diff-between-GL_TEXTURE_2D-and-GL_TEXTURE_RECTANGLE.patch
deleted file mode 100644 (file)
index 7c14e15..0000000
+++ /dev/null
@@ -1,81 +0,0 @@
-i965/tex: ignore the diff between GL_TEXTURE_2D and GL_TEXTURE_RECTANGLE
-
-the difference between GL_TEXTURE_2D and GL_TEXTURE_RECTANGLE
-doesn't matter as far as the miptree is concerned;
-genX(update_sampler_state) only looks at the
-gl_texture_object and not the miptree when determining whether or
-not to use normalized coordinates.
-
-Signed-off-by: Andrii Simiklit <andrii.simiklit@globallogic.com>
-
-Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=107117
----
- src/mesa/drivers/dri/i965/intel_mipmap_tree.c | 10 +++++++++-
- 1 file changed, 9 insertions(+), 1 deletion(-)
-
-diff --git a/src/mesa/drivers/dri/i965/intel_mipmap_tree.c b/src/mesa/drivers/dri/i965/intel_mipmap_tree.c
-index 7d1fa96..dc45a06 100644
---- a/src/mesa/drivers/dri/i965/intel_mipmap_tree.c
-+++ b/src/mesa/drivers/dri/i965/intel_mipmap_tree.c
-@@ -58,6 +58,12 @@ static void *intel_miptree_map_raw(struct brw_context *brw,
- static void intel_miptree_unmap_raw(struct intel_mipmap_tree *mt);
-+static GLenum
-+tex_rect_to_tex2d(GLenum val)
-+{
-+    return (GL_TEXTURE_RECTANGLE == val) ? GL_TEXTURE_2D : val;
-+}
-+
- /**
-  * Return true if the format that will be used to access the miptree is
-  * CCS_E-compatible with the miptree's linear/non-sRGB format.
-@@ -1320,13 +1326,15 @@ intel_miptree_match_image(struct intel_mipmap_tree *mt,
- {
-    struct intel_texture_image *intelImage = intel_texture_image(image);
-    GLuint level = intelImage->base.Base.Level;
-+   GLenum texObjTarget = tex_rect_to_tex2d(mt->target);
-+   GLenum mipmapTreeTarget = tex_rect_to_tex2d(image->TexObject->Target);
-    int width, height, depth;
-    /* glTexImage* choose the texture object based on the target passed in, and
-     * objects can't change targets over their lifetimes, so this should be
-     * true.
-     */
--   assert(image->TexObject->Target == mt->target);
-+   assert(texObjTarget == mipmapTreeTarget);
-    mesa_format mt_format = mt->format;
-    if (mt->format == MESA_FORMAT_Z24_UNORM_X8_UINT && mt->stencil_mt)
---- mesa-mesa-19.1.5/src/mesa/drivers/dri/i915/intel_mipmap_tree.c.orig        2019-08-26 23:37:27.779941449 +0200
-+++ mesa-mesa-19.1.5/src/mesa/drivers/dri/i915/intel_mipmap_tree.c     2019-08-26 23:38:47.553273174 +0200
-@@ -403,6 +403,12 @@
-    }
- }
-+static GLenum
-+tex_rect_to_tex2d(GLenum val)
-+{
-+    return (GL_TEXTURE_RECTANGLE == val) ? GL_TEXTURE_2D : val;
-+}
-+
- /**
-  * Can the image be pulled into a unified mipmap tree?  This mirrors
-  * the completeness test in a lot of ways.
-@@ -415,13 +421,15 @@
- {
-    struct intel_texture_image *intelImage = intel_texture_image(image);
-    GLuint level = intelImage->base.Base.Level;
-+   GLenum texObjTarget = tex_rect_to_tex2d(mt->target);
-+   GLenum mipmapTreeTarget = tex_rect_to_tex2d(image->TexObject->Target);
-    int width, height, depth;
-    /* glTexImage* choose the texture object based on the target passed in, and
-     * objects can't change targets over their lifetimes, so this should be
-     * true.
-     */
--   assert(target_to_target(image->TexObject->Target) == mt->target);
-+   assert(texObjTarget == mipmapTreeTarget);
-    mesa_format mt_format = mt->format;
This page took 0.143856 seconds and 4 git commands to generate.