]> git.pld-linux.org Git - packages/CHOLMOD.git/blob - CHOLMOD.spec
- release 5 (by relup.sh)
[packages/CHOLMOD.git] / CHOLMOD.spec
1 #
2 # Conditional build:
3 %bcond_with     metis           # build with partition support (using metis lib)
4 #
5 Summary:        CHOLMOD: sparse supernodal Cholesky factorization and update/downdate
6 Summary(pl.UTF-8):      CHOLMOD - rzadki wielowęzłowy rozkład Cholesky'ego z poprawianiem
7 Name:           CHOLMOD
8 Version:        3.0.1
9 Release:        5
10 License:        GPL v2+ (some parts LGPL v2.1+)
11 Group:          Libraries
12 Source0:        http://www.cise.ufl.edu/research/sparse/cholmod/%{name}-%{version}.tar.gz
13 # Source0-md5:  677c2fac5bf480c125801ced2f51f9fe
14 Patch0:         %{name}-ufconfig.patch
15 Patch1:         %{name}-shared.patch
16 # http://www.cise.ufl.edu/research/sparse/cholmod/metis.patch (for METIS 5)
17 Patch2:         %{name}-metis.patch
18 URL:            http://www.cise.ufl.edu/research/sparse/cholmod/
19 BuildRequires:  AMD-devel >= 2.4.0
20 BuildRequires:  CAMD-devel >= 2.4.0
21 BuildRequires:  CCOLAMD-devel >= 2.9.0
22 BuildRequires:  COLAMD-devel >= 2.9.0
23 BuildRequires:  SuiteSparse_config-devel >= 4.3.0
24 BuildRequires:  blas-devel
25 BuildRequires:  gcc-fortran
26 BuildRequires:  lapack-devel
27 BuildRequires:  libtool >= 2:1.5
28 %if %{with metis}
29 BuildRequires:  metis-devel >= 5
30 %endif
31 Requires:       AMD >= 2.4.0
32 Requires:       CAMD >= 2.4.0
33 Requires:       CCOLAMD >= 2.9.0
34 Requires:       COLAMD >= 2.9.0
35 Requires:       SuiteSparse_config-libs >= 4.3.0
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 CHOLMOD is a set of ANSI C routines for sparse Cholesky
40 factorization and update/downdate.
41
42 %description -l pl.UTF-8
43 CHOLMOD to zbiór procedur ANSI C do rzadkiego rozkładu Cholesky'ego z
44 poprawianiem.
45
46 %package devel
47 Summary:        Header files for CHOLMOD library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CHOLMOD
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       AMD-devel >= 2.4.0
52 Requires:       CAMD-devel >= 2.4.0
53 Requires:       CCOLAMD-devel >= 2.9.0
54 Requires:       COLAMD-devel >= 2.9.0
55 Requires:       SuiteSparse_config-devel >= 4.3.0
56 Requires:       blas-devel
57 Requires:       lapack-devel
58
59 %description devel
60 Header files for CHOLMOD library.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki CHOLMOD.
64
65 %package static
66 Summary:        Static CHOLMOD library
67 Summary(pl.UTF-8):      Statyczna biblioteka CHOLMOD
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static CHOLMOD library.
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka CHOLMOD.
76
77 %prep
78 %setup -q -n %{name}
79 %patch0 -p1
80 %patch1 -p1
81 %patch2 -p1
82
83 %build
84 %{__make} \
85         CC="%{__cc}" \
86         %{!?with_metis:CHOLMOD_CONFIG=-DNPARTITION} \
87         %{?with_metis:WITH_METIS=1} \
88         CFLAGS="%{rpmcflags}" \
89         LDFLAGS="%{rpmldflags}" \
90         libdir=%{_libdir}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT%{_includedir}/cholmod
95
96 %{__make} -C Lib install \
97         DESTDIR=$RPM_BUILD_ROOT \
98         libdir=%{_libdir}
99
100 install Include/*.h $RPM_BUILD_ROOT%{_includedir}/cholmod
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc README.txt Doc/ChangeLog
111 %attr(755,root,root) %{_libdir}/libcholmod.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/libcholmod.so.0
113
114 %files devel
115 %defattr(644,root,root,755)
116 %doc Doc/UserGuide.pdf
117 %attr(755,root,root) %{_libdir}/libcholmod.so
118 %{_libdir}/libcholmod.la
119 %{_includedir}/cholmod
120
121 %files static
122 %defattr(644,root,root,755)
123 %{_libdir}/libcholmod.a
This page took 0.062566 seconds and 4 git commands to generate.