]> git.pld-linux.org Git - packages/vala.git/blame - vala.spec
Update to 0.26.0
[packages/vala.git] / vala.spec
CommitLineData
7ec7f175 1%define major_ver 0.26
2100e356 2Summary: GObject-based language compiler
62a0034d 3Summary(pl.UTF-8): Kompilator języka opartego na bibliotece GObject
2100e356 4Name: vala
7ec7f175
MB
5Version: 0.26.0
6Release: 1
c258620e 7Epoch: 2
6a5cf96c 8License: LGPL v2+
37af0a44 9Group: Development/Languages
7ec7f175
MB
10Source0: http://ftp.gnome.org/pub/GNOME/sources/vala/0.26/%{name}-%{version}.tar.xz
11# Source0-md5: a418f9ffacdf4ab1e2ecf52c7a73bfea
9278bb59 12URL: http://live.gnome.org/Vala
a393e7a8 13BuildRequires: autoconf >= 2.50
7ace0cac 14BuildRequires: automake >= 1:1.11
6a5cf96c 15BuildRequires: bison
2ac0ddb6 16BuildRequires: flex
7ec7f175 17BuildRequires: glib2-devel >= 1:2.24.0
1d8bfdb9 18BuildRequires: libtool
7f0c5943 19BuildRequires: libxslt-progs
6a5cf96c 20BuildRequires: pkgconfig
7ace0cac
AF
21BuildRequires: tar >= 1:1.22
22BuildRequires: xz
7ec7f175 23Requires: glib2 >= 1:2.24.0
a147192b 24Conflicts: gdk-pixbuf2 < 2.23.3-1
2100e356 25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28Vala is a new programming language that aims to bring modern
29programming language features to GNOME developers without imposing any
30additional runtime requirements and without using a different ABI
31compared to applications and libraries written in C.
32
33valac, the Vala compiler, is a self-hosting compiler that translates
34Vala source code into C source and header files. It uses the GObject
35type system to create classes and interfaces declared in the Vala
36source code. It's also planned to generate GIDL files when
37gobject-introspection is ready.
38
39The syntax of Vala is similar to C#, modified to better fit the
40GObject type system.
41
a030a99c
JR
42%description -l pl.UTF-8
43Vala to nowy język programowania, którego celem jest udostępnienie
44cech nowoczesnych języków programowania programistom GNOME bez
45wymuszania dodatkowych wymagań co do środowiska uruchomieniowego i
46używania API innego niż w aplikacjach i bibliotekach napisanych w C.
fc5b0e4f 47
a030a99c
JR
48valac - kompilator języka Vala - to napisany w sobie samym kompilator
49tłumaczący kod źródłowy w języku Vala na pliki źródłowe i nagłówkowe w
50C. Używa systemu typów GObject do tworzenia klas i interfejsów
51zadeklarowanych w kodzie źródłowym w języku Vala. Planowane jest także
52generowanie plików GIDL, kiedy system gobject-introspection będzie
fc5b0e4f
JB
53gotowy.
54
a030a99c
JR
55Składnia języka Vala jest podobna do C#, zmodyfikowana tak, aby lepiej
56pasować do systemu typów GObject.
fc5b0e4f 57
b0568d57 58%package apidocs
59Summary: vala API documentation
60Summary(pl.UTF-8): Dokumentacja API vala
61Group: Documentation
8634ffb4 62Requires: devhelp
b0568d57 63
64%description apidocs
65vala API documentation.
66
67%description apidocs -l pl.UTF-8
68Dokumentacja API vala.
69
2100e356 70%prep
71%setup -q
72
73%build
1d8bfdb9 74%{__libtoolize}
7ace0cac 75%{__aclocal} -I m4
1d8bfdb9 76%{__autoconf}
77%{__autoheader}
78%{__automake}
79%configure \
7ec7f175 80 --disable-silent-rules
2100e356 81%{__make}
82
83%install
84rm -rf $RPM_BUILD_ROOT
a3c413c5
PZ
85install -d $RPM_BUILD_ROOT%{_datadir}/vala/vapi
86
2100e356 87%{__make} install \
88 DESTDIR=$RPM_BUILD_ROOT
89
a3c413c5
PZ
90%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
91
2100e356 92%clean
93rm -rf $RPM_BUILD_ROOT
94
6a5cf96c
JB
95%post -p /sbin/ldconfig
96%postun -p /sbin/ldconfig
97
2100e356 98%files
99%defattr(644,root,root,755)
f7af4f63 100%doc AUTHORS ChangeLog MAINTAINERS NEWS README THANKS
a393e7a8
JB
101%attr(755,root,root) %{_bindir}/vala
102%attr(755,root,root) %{_bindir}/vala-%{major_ver}
103%attr(755,root,root) %{_bindir}/vala-gen-introspect
104%attr(755,root,root) %{_bindir}/vala-gen-introspect-%{major_ver}
105%attr(755,root,root) %{_bindir}/valac
106%attr(755,root,root) %{_bindir}/valac-%{major_ver}
107%attr(755,root,root) %{_bindir}/vapicheck
108%attr(755,root,root) %{_bindir}/vapicheck-%{major_ver}
109%attr(755,root,root) %{_bindir}/vapigen
110%attr(755,root,root) %{_bindir}/vapigen-%{major_ver}
a3c413c5
PZ
111%attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so.*.*.*
112%attr(755,root,root) %ghost %{_libdir}/libvala-%{major_ver}.so.0
113%attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so
092cc603 114%{_includedir}/vala-%{major_ver}
e6241369 115%{_pkgconfigdir}/libvala-%{major_ver}.pc
ce788c9c
MB
116%{_npkgconfigdir}/vapigen-%{major_ver}.pc
117%{_npkgconfigdir}/vapigen.pc
a3c413c5 118%dir %{_datadir}/vala
ce788c9c 119%{_datadir}/vala/Makefile.vapigen
a3c413c5 120%dir %{_datadir}/vala/vapi
092cc603
JK
121%dir %{_datadir}/vala-%{major_ver}
122%dir %{_datadir}/vala-%{major_ver}/vapi
123%{_datadir}/vala-%{major_ver}/vapi/*.vapi
124%{_datadir}/vala-%{major_ver}/vapi/*.deps
092cc603
JK
125%dir %{_libdir}/vala-%{major_ver}
126%attr(755,root,root) %{_libdir}/vala-%{major_ver}/gen-introspect-%{major_ver}
cbe6d1d3 127%{_mandir}/man1/vala-gen-introspect.1*
092cc603 128%{_mandir}/man1/vala-gen-introspect-%{major_ver}.1*
a393e7a8
JB
129%{_mandir}/man1/valac.1*
130%{_mandir}/man1/valac-%{major_ver}.1*
cbe6d1d3 131%{_mandir}/man1/vapigen.1*
092cc603
JK
132%{_mandir}/man1/vapigen-%{major_ver}.1*
133%{_aclocaldir}/vala.m4
ce788c9c 134%{_aclocaldir}/vapigen.m4
b0568d57 135
136%files apidocs
137%defattr(644,root,root,755)
092cc603 138%{_datadir}/devhelp/books/vala-%{major_ver}
This page took 0.075851 seconds and 4 git commands to generate.