]> git.pld-linux.org Git - packages/v8.git/blame - v8.spec
- updated URLs, dropped upstream-tracker.org note (this domain is dead now)
[packages/v8.git] / v8.spec
CommitLineData
f852d988 1# TODO
4d92292d 2# - readline not working in d8 (at least arrows)
2264b152
ER
3#
4# Conditional build:
5%bcond_without verbose # verbose build (V=1)
6
855c3a42
JB
7Summary: JavaScript Engine by Google
8Summary(pl.UTF-8): Silnik JavaScript firmy Google
b8bbb50f 9Name: v8
2cc5e706 10Version: 3.15.11.18
ac44effd 11Release: 2
855c3a42 12License: BSD
2264b152 13Group: Development/Languages
f6756e65
JB
14#Source0Download: https://github.com/v8/v8/releases
15#Source0: https://github.com/v8/v8/archive/%{version}/%{name}-%{version}.tar.gz
2cc5e706
ER
16Source0: %{name}-%{version}.tar.bz2
17# Source0-md5: a08c74de1f8d71d309077cb7a640583f
855c3a42
JB
18Patch0: %{name}-cstdio.patch
19Patch1: %{name}-strndup.patch
855c3a42 20Patch3: %{name}-dynlink.patch
f8f77d43 21Patch4: abort-uncaught-exception.patch
f6756e65 22URL: https://github.com/v8/v8/wiki
2a373d08 23BuildRequires: gyp
982929a0 24BuildRequires: libstdc++-devel >= 5:4.0
e111b3e4 25BuildRequires: python >= 1:2.5
7594b47f 26BuildRequires: readline-devel
855c3a42 27BuildRequires: sed >= 4.0
c9aae908 28Requires: %{name}-libs = %{version}-%{release}
60c4bab2 29ExclusiveArch: %{ix86} %{x8664} arm mips
b8bbb50f
AM
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
035f4755 32%define sover %(echo %{version} | cut -d. -f1-2)
855c3a42 33
b8bbb50f
AM
34%description
35V8 is Google's open source JavaScript engine. V8 is written in C++ and
36is used in Google Chrome, the open source browser from Google. V8
37implements ECMAScript as specified in ECMA-262, 3rd edition.
38
855c3a42
JB
39This package contains the V8 developer shell.
40
41%description -l pl.UTF-8
42V8 to mający otwarte źródła silnik JavaScriptu firmy Google. V8 jest
43napisany w C++ i wykorzystywany w mającej otwarte źródła przeglądarce
44Google Chrome. V8 implementuje ECMAScript zgodnie ze specyfikacją
45ECMA-262, edycja 3.
46
47Ten pakiet zawiera powłokę programistyczną V8.
37bf3af8
ER
48
49%package libs
50Summary: V8 JavaScript Engine shared library
855c3a42 51Summary(pl.UTF-8): Biblioteka współdzielona silnika JavaScriptu V8
37bf3af8
ER
52Group: Libraries
53Conflicts: v8 < 2.0.0
54
55%description libs
56V8 is Google's open source JavaScript engine. V8 is written in C++ and
57is used in Google Chrome, the open source browser from Google. V8
58implements ECMAScript as specified in ECMA-262, 3rd edition.
59
60This package contains the shared library.
61
855c3a42
JB
62%description libs -l pl.UTF-8
63V8 to mający otwarte źródła silnik JavaScriptu firmy Google. V8 jest
64napisany w C++ i wykorzystywany w mającej otwarte źródła przeglądarce
65Google Chrome. V8 implementuje ECMAScript zgodnie ze specyfikacją
66ECMA-262, edycja 3.
67
68Ten pakiet zawiera bibliotekę współdzieloną.
69
b8bbb50f 70%package devel
855c3a42
JB
71Summary: Development headers for V8 JavaScript engine
72Summary(pl.UTF-8): Pliki nagłówkowe silnika JavaScriptu V8
b8bbb50f 73Group: Development/Libraries
37bf3af8 74Requires: %{name}-libs = %{version}-%{release}
855c3a42 75Requires: libstdc++-devel
b8bbb50f
AM
76
77%description devel
855c3a42
JB
78Development headers for V8 JavaScript engine.
79
80%description devel -l pl.UTF-8
81Pliki nagłówkowe silnika JavaScriptu V8.
b8bbb50f
AM
82
83%prep
ce2a821c 84%setup -q
855c3a42
JB
85%patch0 -p1
86%patch1 -p1
ffa963bd 87%patch3 -p1
f8f77d43 88%patch4 -p1
b8bbb50f 89
2cc5e706
ER
90install -d build/gyp
91ln -s %{_bindir}/gyp build/gyp/gyp
1a3015af 92
b8bbb50f 93%build
1a3015af 94# -Wno-unused-local-typedefs is gcc 4.8 workaround: http://code.google.com/p/v8/issues/detail?id=2149
2264b152
ER
95%{__make} -r native \
96 component=shared_library \
60c4bab2 97 soname_version=%{sover} \
2264b152
ER
98 console=readline \
99 CC="%{__cc}" \
100 CXX="%{__cxx}" \
ec2b48cc 101 LINK="%{__cxx} -fuse-ld=gold" \
2264b152 102 CFLAGS="%{rpmcflags}" \
1a3015af 103 CXXFLAGS="%{rpmcxxflags} -Wno-unused-local-typedefs" \
2264b152
ER
104 LDFLAGS="%{rpmldflags}" \
105 %{?with_verbose:V=1}
c894b44e 106
b8bbb50f
AM
107%install
108rm -rf $RPM_BUILD_ROOT
5e90f260 109install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}}
855c3a42 110
c265e165
A
111install -p out/native/lib.target/libv8.so.%{sover} $RPM_BUILD_ROOT%{_libdir}/libv8.so.%{version}
112ln -sf libv8.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libv8.so.%{sover}
113ln -sf libv8.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libv8.so
f852d988 114cp -p include/*.h $RPM_BUILD_ROOT%{_includedir}
b8bbb50f 115
c265e165 116install -p out/native/d8 $RPM_BUILD_ROOT%{_bindir}
b8bbb50f
AM
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
37bf3af8
ER
121%post libs -p /sbin/ldconfig
122%postun libs -p /sbin/ldconfig
b8bbb50f
AM
123
124%files
125%defattr(644,root,root,755)
855c3a42 126%doc AUTHORS ChangeLog LICENSE LICENSE.strongtalk LICENSE.valgrind
4d92292d 127%attr(755,root,root) %{_bindir}/d8
37bf3af8
ER
128
129%files libs
982929a0 130%defattr(644,root,root,755)
c894b44e 131%attr(755,root,root) %{_libdir}/libv8.so.*.*.*
035f4755 132%attr(755,root,root) %ghost %{_libdir}/libv8.so.%{sover}
b8bbb50f
AM
133
134%files devel
135%defattr(644,root,root,755)
c894b44e 136%attr(755,root,root) %{_libdir}/libv8.so
855c3a42 137%{_includedir}/v8*.h
This page took 0.100467 seconds and 4 git commands to generate.