]> git.pld-linux.org Git - packages/tellico.git/blob - tellico.spec
up to 3.1.1
[packages/tellico.git] / tellico.spec
1 #
2 # Conditional build:
3 %bcond_with     webcam  # build with webcam barcode recognition
4 #
5 %define         qt_ver  5.4.0
6 Summary:        A collection manager
7 Summary(pl.UTF-8):      Zarządca zbiorów wideo, audio i książek
8 Name:           tellico
9 Version:        3.1.1
10 Release:        1
11 License:        GPL v3
12 Group:          X11/Applications
13 Source0:        http://tellico-project.org/files/%{name}-%{version}.tar.xz
14 # Source0-md5:  8c503a21b12d5bfc62f55b287855fa6e
15 URL:            http://tellico-project.org/
16 BuildRequires:  Qt5Core-devel >= %{qt_ver}
17 BuildRequires:  Qt5DBus-devel >= %{qt_ver}
18 BuildRequires:  Qt5Network-devel >= %{qt_ver}
19 BuildRequires:  Qt5Test-devel >= %{qt_ver}
20 BuildRequires:  Qt5Widgets-devel >= %{qt_ver}
21 BuildRequires:  Qt5Xml-devel >= %{qt_ver}
22 BuildRequires:  cmake >= 2.8.12
23 BuildRequires:  exempi-devel
24 BuildRequires:  kf5-extra-cmake-modules >= 5.19
25 BuildRequires:  kf5-karchive-devel
26 BuildRequires:  kf5-kcodecs-devel
27 BuildRequires:  kf5-kconfig-devel
28 BuildRequires:  kf5-kconfigwidgets-devel
29 BuildRequires:  kf5-kcoreaddons-devel
30 BuildRequires:  kf5-kcrash-devel
31 BuildRequires:  kf5-kdoctools-devel
32 BuildRequires:  kf5-kguiaddons-devel
33 BuildRequires:  kf5-khtml-devel
34 BuildRequires:  kf5-ki18n-devel
35 BuildRequires:  kf5-kiconthemes-devel
36 BuildRequires:  kf5-kitemmodels-devel
37 BuildRequires:  kf5-kjobwidgets-devel
38 BuildRequires:  kf5-kio-devel
39 BuildRequires:  kf5-kwallet-devel
40 BuildRequires:  kf5-kwidgetsaddons-devel
41 BuildRequires:  kf5-kwindowsystem-devel
42 BuildRequires:  kf5-kxmlgui-devel
43 BuildRequires:  kf5-solid-devel
44 BuildRequires:  libxml2-devel
45 BuildRequires:  libxml2-progs
46 BuildRequires:  libxslt-devel >= 1.0.19
47 BuildRequires:  poppler-qt5-devel
48 BuildRequires:  qimageblitz-devel
49 BuildRequires:  qjson-devel
50 BuildRequires:  rpmbuild(macros) >= 1.129
51 BuildRequires:  shared-desktop-ontologies-devel
52 BuildRequires:  soprano-devel
53 BuildRequires:  taglib-devel
54 BuildRequires:  yaz-devel
55 Requires:       Qt5Core >= %{qt_ver}
56 Requires:       Qt5DBus >= %{qt_ver}
57 Requires:       Qt5Network >= %{qt_ver}
58 Requires:       Qt5Widgets >= %{qt_ver}
59 Requires:       Qt5Xml >= %{qt_ver}
60 Requires:       desktop-file-utils
61 Requires:       libxslt >= 1.0.19
62 Obsoletes:      bookcase
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 Tellico is a personal catalog application for your book, video and
67 audio collection.
68
69 %description -l pl.UTF-8
70 Tellico to osobista aplikacja katalogowa przeznaczona do
71 księgozbiorów, archiwów wideo i audio.
72
73 %prep
74 %setup -q
75
76 %build
77 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT%{_desktopdir}
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT \
86         kde_htmldir=%{_kdedocdir} \
87         kde_libs_htmldir=%{_kdedocdir}
88
89 rm -r $RPM_BUILD_ROOT%{_docdir}
90
91 %find_lang %{name} --with-kde
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post
97 %update_desktop_database_post
98 %update_mime_database
99
100 %postun
101 %update_desktop_database_postun
102 %update_mime_database
103
104 %files -f %{name}.lang
105 %defattr(644,root,root,755)
106 %doc AUTHORS ChangeLog README
107 %attr(755,root,root) %{_bindir}/*
108 /etc/xdg/tellicorc
109 /etc/xdg/tellico-script.knsrc
110 /etc/xdg/tellico-template.knsrc
111 %{_datadir}/kconf_update/%{name}-rename.upd
112 %{_datadir}/kconf_update/tellico.upd
113 %{_datadir}/kconf_update/tellico-1-3-update.pl
114 %{_datadir}/%{name}
115 %{_datadir}/config.kcfg/tellico_config.kcfg
116 %{_datadir}/mime/packages/*.xml
117 %{_datadir}/kxmlgui5/tellico
118 %{_datadir}/metainfo/org.kde.tellico.appdata.xml
119 %{_desktopdir}/org.kde.tellico.desktop
120 %{_iconsdir}/*/*/*/*.png
This page took 0.037873 seconds and 3 git commands to generate.