]> git.pld-linux.org Git - packages/strigi.git/blame - strigi.spec
- fix building with ffmpeg 3
[packages/strigi.git] / strigi.spec
CommitLineData
1253c3bb 1#
6a7d7a23
ER
2# Conditional build:
3%bcond_without dbus # dbus support
4#
64e6c73a 5%define qtver 4.6.3
9897709b 6
493bcf16 7Summary: Strigi desktop search
abba28fc 8Summary(pl.UTF-8): System wyszukiwania Strigi
1253c3bb 9Name: strigi
cfce5085 10Version: 0.7.8
845404c3 11Release: 7
4a9fce3d 12License: LGPL v2+
1253c3bb 13Group: X11/Applications
cfce5085
AM
14Source0: http://www.vandenoever.info/software/strigi/%{name}-%{version}.tar.bz2
15# Source0-md5: d69443234f4286d71997db9de543331a
845404c3
JR
16Patch0: %{name}-as-needed.patch
17Patch1: ffmpeg3.patch
1becfb15 18URL: http://strigi.sourceforge.net/
9897709b 19BuildRequires: QtDBus-devel >= %{qtver}
20BuildRequires: QtGui-devel >= %{qtver}
4a9fce3d 21BuildRequires: attr-devel
6a7d7a23 22BuildRequires: bzip2-devel
4a9fce3d
JB
23BuildRequires: clucene-core-devel >= 0.9.21
24BuildRequires: cmake >= 2.8.9
f331c639 25BuildRequires: cppunit-devel
6a7d7a23 26%{?with_dbus:BuildRequires: dbus-devel >= 1.0}
2027d9a2 27BuildRequires: exiv2-devel >= 0.21
6a7d7a23 28BuildRequires: expat-devel
9b415f88 29BuildRequires: fam-devel
44a8c079 30BuildRequires: ffmpeg-devel
4a9fce3d 31BuildRequires: libxml2-devel >= 2
b7b1af67 32BuildRequires: log4cxx-devel
9b415f88 33%{?with_dbus:BuildRequires: pkgconfig}
9897709b 34BuildRequires: qt4-build >= %{qtver}
35BuildRequires: qt4-qmake >= %{qtver}
4a9fce3d 36BuildRequires: rpmbuild(macros) >= 1.605
6a7d7a23 37BuildRequires: zlib-devel
1253c3bb 38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
abba28fc
JB
41Here are the main features of Strigi Desktop Search: very fast
42crawling, very small memory footprint, no hammering of the system,
43pluggable backend (currently clucene and hyperestraier, sqlite3 and
44xapian are in the works), communication between daemon and search
45program over an abstract interface with two implementations: DBus and
b25c5eb4 46a simple Unix socket. Especially the DBus interface makes it very easy
abba28fc
JB
47to write client applications. There are a few sample scripts in the
48code using Perl, Python, GTK+ and Qt. Writing clients is so easy that
49any GNOME or KDE app could implement this. Additionally, there is a
50simple interface for implementing plugins for extracting information.
51We'll try to reuse the kat plugins, although native plugins will have
52a large speed advantage. Strigi also has calculation of sha1 for every
53file crawled which allows for fast finding of duplicate files.
493bcf16 54
abba28fc
JB
55%description -l pl.UTF-8
56Główne cechy systemu wyszukiwania Strigi to: bardzo szybkie
57przeglądanie, bardzo mały narzut pamięciowy, nieprzytykanie systemu,
58backend z obsługą wtyczek (aktualnie clucene i hyperestraier, sqlite3
59i xapian w trakcie rozwoju), komunikacja między demonem a programem
60wyszukującym po abstrakcyjnym interfejsie z dwiema implementacjami:
61DBus i prostym gdzieździe uniksowym. Zwłaszcza interfejs DBus znacznie
62ułatwia pisanie aplikacji klienckich. Istnieje kilka przykładowych
63skryptów napisanych z użyciem Perla, Pythona, GTK+ i Qt. Tworzenie
64klientów jest tak proste, że każda aplikacja GNOME czy KDE może to
65zaimplementować. Ponadto istnieje prosty interfejs do implementowania
66wtyczek do wydobywania informacji. Autorzy będą próbowali
67wykorzystywać wtyczki kata, ale natywne wtyczki będą miały większą
68szybkość. Strigi ma także obliczanie sha1 dla każdego przeglądanego
69pliku, co pozwala na szybkie znajdowanie duplikatów.
1253c3bb 70
71%package devel
493bcf16 72Summary: Header files for strigi
73Summary(pl.UTF-8): Pliki nagłówkowe dla strigi
74Group: Development/Libraries
75Requires: %{name} = %{version}-%{release}
1253c3bb 76
77%description devel
78Header files for strigi.
79
80%description devel -l pl.UTF-8
81Pliki nagłówkowe dla strigi.
82
83%prep
84%setup -q
845404c3 85%patch0 -p1
acbb9c35 86%patch1 -p1
1253c3bb 87
88%build
89install -d build
90cd build
4a9fce3d
JB
91# note: package expects relative CMAKE_INSTALL_LIBDIR
92%cmake .. \
cfce5085 93 -DCMAKE_INSTALL_LIBDIR=%{_lib} \
130bea1a 94 -DFORCE_DEPS=1 \
b7b1af67 95 -DENABLE_FAM=1 \
4a9fce3d
JB
96 -DENABLE_INOTIFY=1 \
97 -DENABLE_LOG4CXX=1
1253c3bb 98
99%{__make}
100
101%install
102rm -rf $RPM_BUILD_ROOT
abba28fc
JB
103
104%{__make} -C build install \
1253c3bb 105 DESTDIR=$RPM_BUILD_ROOT
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%post -p /sbin/ldconfig
111%postun -p /sbin/ldconfig
112
113%files
114%defattr(644,root,root,755)
4a9fce3d
JB
115%doc AUTHORS ChangeLog
116%attr(755,root,root) %{_bindir}/deepfind
117%attr(755,root,root) %{_bindir}/deepgrep
118%attr(755,root,root) %{_bindir}/lucene2indexer
119%attr(755,root,root) %{_bindir}/rdfindexer
120%attr(755,root,root) %{_bindir}/strigiclient
121%attr(755,root,root) %{_bindir}/strigicmd
122%attr(755,root,root) %{_bindir}/strigidaemon
123%attr(755,root,root) %{_bindir}/xmlindexer
3b877464 124%attr(755,root,root) %{_libdir}/libsearchclient.so.*.*.*
f29c8e58 125%attr(755,root,root) %ghost %{_libdir}/libsearchclient.so.0
4a9fce3d 126%attr(755,root,root) %{_libdir}/libstreamanalyzer.so.*.*.*
a52c8172 127%attr(755,root,root) %ghost %{_libdir}/libstreamanalyzer.so.0
4a9fce3d 128%attr(755,root,root) %{_libdir}/libstreams.so.*.*.*
a52c8172 129%attr(755,root,root) %ghost %{_libdir}/libstreams.so.0
4a9fce3d 130%attr(755,root,root) %{_libdir}/libstrigihtmlgui.so.*.*.*
f29c8e58 131%attr(755,root,root) %ghost %{_libdir}/libstrigihtmlgui.so.0
4a9fce3d 132%attr(755,root,root) %{_libdir}/libstrigiqtdbusclient.so.*.*.*
f29c8e58
JB
133%attr(755,root,root) %ghost %{_libdir}/libstrigiqtdbusclient.so.0
134%dir %{_libdir}/strigi
135%attr(755,root,root) %{_libdir}/strigi/*.so
4a9fce3d
JB
136%{?with_dbus:%{_datadir}/dbus-1/services/org.freedesktop.xesam.searcher.service}
137%{?with_dbus:%{_datadir}/dbus-1/services/vandenoever.strigi.service}
a52c8172
JB
138%dir %{_datadir}/strigi
139%{_datadir}/strigi/fieldproperties
1253c3bb 140
141%files devel
142%defattr(644,root,root,755)
3b877464 143%attr(755,root,root) %{_libdir}/libsearchclient.so
a52c8172
JB
144%attr(755,root,root) %{_libdir}/libstreamanalyzer.so
145%attr(755,root,root) %{_libdir}/libstreams.so
3b877464
RT
146%attr(755,root,root) %{_libdir}/libstrigihtmlgui.so
147%attr(755,root,root) %{_libdir}/libstrigiqtdbusclient.so
31d6d646 148%dir %{_libdir}/cmake/Strigi
cfce5085
AM
149%{_libdir}/cmake/Strigi/*.cmake
150%dir %{_libdir}/cmake/LibSearchClient
151%{_libdir}/cmake/LibSearchClient/LibSearchClientConfig.cmake
152%dir %{_libdir}/cmake/LibStreamAnalyzer
153%{_libdir}/cmake/LibStreamAnalyzer/LibStreamAnalyzerConfig.cmake
154%{_libdir}/cmake/LibStreamAnalyzer/LibStreamAnalyzerConfigVersion.cmake
155%dir %{_libdir}/cmake/LibStreams
156%{_libdir}/cmake/LibStreams/LibStreamsConfig.cmake
157%{_libdir}/cmake/LibStreams/LibStreamsConfigVersion.cmake
158%{_libdir}/cmake/LibStreams/LibStreamsTargets-pld.cmake
159%{_libdir}/cmake/LibStreams/LibStreamsTargets.cmake
1253c3bb 160%dir %{_includedir}/strigi
161%{_includedir}/strigi/*.h
3b877464 162%{_includedir}/strigi/qtdbus
a52c8172
JB
163%{_pkgconfigdir}/libstreamanalyzer.pc
164%{_pkgconfigdir}/libstreams.pc
This page took 0.135202 seconds and 4 git commands to generate.