]> git.pld-linux.org Git - packages/sqlite3.git/blobdiff - sqlite3.spec
up to 3.23.0
[packages/sqlite3.git] / sqlite3.spec
index 7da150013b319e8cc6fabd27fb938bbdb9177bf5..cfb2ea42168f4ea2ec61723729d8500390061d17 100644 (file)
@@ -1,9 +1,11 @@
 # TODO:
 # - some tests fail with tcl8.5, it's tcl fault,
 #      if someone REALLY cares (s)he can look into it
+# - configure.ac present, but doesn't support all -DEFINES, also it uses bash syntax (var+=value)
 #
 # Conditional build:
 %bcond_with    tests           # run tests
+%bcond_with    readline        # readline (GPL) instead of libedit
 %bcond_without tcl             # Tcl extension
 %bcond_without doc             # disable documentation building
 %bcond_without unlock_notify   # disable unlock notify API
 %endif
 
 # sqlite3 version with zero padded without any dots (3 08 10 01 is 3.8.10.1)
-%define                vnum    3081101
-%define                ver             %{lua:vn=rpm.expand("%vnum");v="";for i in string.gmatch(string.format("%08d", vn), "..") do; v=v.."."..i:gsub("^0", "");end;v=v:gsub("^.","");print(v)}
+# but trailing 00 means no 4rd part (3 11 01 00 is 3.11.1)
+%define                vnum    3230000
+%define                ver             %{lua:vn=rpm.expand("%vnum");v="";for i in string.gmatch(string.format("%08d", vn), "..") do v=v.."."..i:gsub("^0", "");end;v=v:gsub("^.",""):gsub("\.0$","");print(v)}
 
 %define                tclver          8.6
-Summary:       SQLite library
-Summary(pl.UTF-8):     Biblioteka SQLite
+Summary:       SQLite3 library
+Summary(pl.UTF-8):     Biblioteka SQLite3
 Name:          sqlite3
 Version:       %{ver}
-Release:       2
+Release:       1
 License:       Public Domain
 Group:         Libraries
 # Source0Download: http://www.sqlite.org/download.html
-Source0:       http://www.sqlite.org/2015/sqlite-src-%{vnum}.zip
-# Source0-md5: 4550012d85ffdc607d0c86aef2d47974
+Source0:       http://www.sqlite.org/2018/sqlite-src-%{vnum}.zip
+# Source0-md5: 72ef3398e710f81a0da037c0e128e02d
 Patch0:                %{name}-sign-function.patch
 URL:           http://www.sqlite.org/
 %{?with_load_extension:Provides:       %{name}(load_extension)}
@@ -42,8 +45,9 @@ URL:          http://www.sqlite.org/
 %{?with_icu:Provides:  %{name}(icu)}
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
+%{!?with_readline:BuildRequires:       libedit-devel}
 BuildRequires: libtool
-BuildRequires: readline-devel
+%{?with_readline:BuildRequires:        readline-devel}
 %{?with_load_extension:BuildRequires:  sed >= 4.0}
 BuildRequires: tcl
 %{?with_tcl:BuildRequires:     tcl-devel >= %{tclver}}
@@ -190,7 +194,7 @@ fi
 %{__libtoolize}
 cp -f /usr/share/automake/config.sub .
 %{__aclocal}
-%{__autoconf}
+%{__autoconf} --force
 append-cppflags() {
        CPPFLAGS="$CPPFLAGS $*"
 }
@@ -214,6 +218,7 @@ append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
 # http://sqlite.org/fts3.html
 #append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_ENABLE_FTS4 -DSQLITE_ENABLE_FTS4_UNICODE61
 append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS
+append-cppflags -DSQLITE_ENABLE_FTS3_TOKENIZER
 
 # Support R*Trees.
 # http://sqlite.org/rtree.html
@@ -223,6 +228,10 @@ append-cppflags -DSQLITE_ENABLE_RTREE
 # http://sqlite.org/lang_corefunc.html#soundex
 #append-cppflags -DSQLITE_SOUNDEX
 
+# Support dbstat virtual table.
+# https://www.sqlite.org/dbstat.html
+append-cppflags -DSQLITE_ENABLE_DBSTAT_VTAB
+
 %if %{with unlock_notify}
 # Support unlock notification.
 # http://sqlite.org/unlock_notify.html
@@ -239,9 +248,11 @@ append-libs "-ldl"
 %endif
 
 %configure \
+       %{?with_readline:--disable-editline} \
        %{!?with_tcl:--disable-tcl}%{?with_tcl:--with-tcl=%{_ulibdir}} \
        %{__enable_disable load_extension load-extension} \
-       --enable-threadsafe
+       --enable-threadsafe \
+       --enable-fts5
 
 %{__make}
 
@@ -254,10 +265,11 @@ append-libs "-ldl"
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.so
 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo lib*.so.*.*) \
        $RPM_BUILD_ROOT%{_libdir}/libsqlite3.so
This page took 0.029293 seconds and 4 git commands to generate.