]> git.pld-linux.org Git - packages/rust.git/commitdiff
x32 patch does not seem to be required anymore
authorJan Palus <atler@pld-linux.org>
Fri, 28 May 2021 17:31:18 +0000 (19:31 +0200)
committerJan Palus <atler@pld-linux.org>
Fri, 28 May 2021 17:31:18 +0000 (19:31 +0200)
rust-x32.patch [deleted file]
rust.spec

diff --git a/rust-x32.patch b/rust-x32.patch
deleted file mode 100644 (file)
index 25b454b..0000000
+++ /dev/null
@@ -1,141 +0,0 @@
---- rustc-1.47.0-src.orig/compiler/rustc_errors/src/lib.rs     2020-10-07 09:53:22.000000000 +0200
-+++ rustc-1.47.0-src/compiler/rustc_errors/src/lib.rs  2020-10-30 13:52:39.921952637 +0100
-@@ -45,7 +45,7 @@
- // `PResult` is used a lot. Make sure it doesn't unintentionally get bigger.
- // (See also the comment on `DiagnosticBuilderInner`.)
--#[cfg(target_arch = "x86_64")]
-+#[cfg(all(target_arch = "x86_64", target_pointer_size = "64"))]
- rustc_data_structures::static_assert_size!(PResult<'_, bool>, 16);
- /// Indicates the confidence in the correctness of a suggestion.
---- rustc-1.47.0-src.orig/compiler/rustc_ast/src/ast.rs        2020-10-07 09:53:22.000000000 +0200
-+++ rustc-1.47.0-src/compiler/rustc_ast/src/ast.rs     2020-10-30 13:53:59.025035237 +0100
-@@ -1056,7 +1056,7 @@
- }
- // `Expr` is used a lot. Make sure it doesn't unintentionally get bigger.
--#[cfg(target_arch = "x86_64")]
-+#[cfg(all(target_arch = "x86_64", target_pointer_size = "64"))]
- rustc_data_structures::static_assert_size!(Expr, 120);
- impl Expr {
---- rustc-1.47.0-src.orig/compiler/rustc_ast/src/token.rs      2020-10-07 09:53:22.000000000 +0200
-+++ rustc-1.47.0-src/compiler/rustc_ast/src/token.rs   2020-10-30 13:52:39.925285960 +0100
-@@ -710,7 +710,7 @@
- }
- // `Nonterminal` is used a lot. Make sure it doesn't unintentionally get bigger.
--#[cfg(target_arch = "x86_64")]
-+#[cfg(all(target_arch = "x86_64", target_pointer_size = "64"))]
- rustc_data_structures::static_assert_size!(Nonterminal, 48);
- #[derive(Debug, Copy, Clone, PartialEq, Encodable, Decodable)]
---- rustc-1.47.0-src.orig/compiler/rustc_ast/src/tokenstream.rs        2020-10-07 09:53:22.000000000 +0200
-+++ rustc-1.47.0-src/compiler/rustc_ast/src/tokenstream.rs     2020-10-30 13:52:39.925285960 +0100
-@@ -130,7 +130,7 @@
- pub type TreeAndJoint = (TokenTree, IsJoint);
- // `TokenStream` is used a lot. Make sure it doesn't unintentionally get bigger.
--#[cfg(target_arch = "x86_64")]
-+#[cfg(all(target_arch = "x86_64", target_pointer_size = "64"))]
- rustc_data_structures::static_assert_size!(TokenStream, 8);
- #[derive(Clone, Copy, Debug, PartialEq, Encodable, Decodable)]
---- rustc-1.47.0-src.orig/compiler/rustc_middle/src/mir/mod.rs 2020-10-07 09:53:22.000000000 +0200
-+++ rustc-1.47.0-src/compiler/rustc_middle/src/mir/mod.rs      2020-10-30 13:52:39.925285960 +0100
-@@ -1353,7 +1353,7 @@
- }
- // `Statement` is used a lot. Make sure it doesn't unintentionally get bigger.
--#[cfg(target_arch = "x86_64")]
-+#[cfg(all(target_arch = "x86_64", target_pointer_size = "64"))]
- static_assert_size!(Statement<'_>, 32);
- impl Statement<'_> {
-@@ -1615,7 +1615,7 @@
- pub type PlaceElem<'tcx> = ProjectionElem<Local, Ty<'tcx>>;
- // At least on 64 bit systems, `PlaceElem` should not be larger than two pointers.
--#[cfg(target_arch = "x86_64")]
-+#[cfg(all(target_arch = "x86_64", target_pointer_size = "64"))]
- static_assert_size!(PlaceElem<'_>, 24);
- /// Alias for projections as they appear in `UserTypeProjection`, where we
---- rustc-1.47.0-src.orig/compiler/rustc_middle/src/mir/tcx.rs 2020-10-07 09:53:22.000000000 +0200
-+++ rustc-1.47.0-src/compiler/rustc_middle/src/mir/tcx.rs      2020-10-30 13:52:39.925285960 +0100
-@@ -17,7 +17,7 @@
- }
- // At least on 64 bit systems, `PlaceTy` should not be larger than two or three pointers.
--#[cfg(target_arch = "x86_64")]
-+#[cfg(all(target_arch = "x86_64", target_pointer_size = "64"))]
- static_assert_size!(PlaceTy<'_>, 16);
- impl<'tcx> PlaceTy<'tcx> {
---- rustc-1.47.0-src.orig/compiler/rustc_middle/src/traits/mod.rs      2020-10-07 09:53:22.000000000 +0200
-+++ rustc-1.47.0-src/compiler/rustc_middle/src/traits/mod.rs   2020-10-30 13:52:39.925285960 +0100
-@@ -339,7 +339,7 @@
- }
- // `ObligationCauseCode` is used a lot. Make sure it doesn't unintentionally get bigger.
--#[cfg(target_arch = "x86_64")]
-+#[cfg(all(target_arch = "x86_64", target_pointer_size = "64"))]
- static_assert_size!(ObligationCauseCode<'_>, 32);
- #[derive(Clone, Debug, PartialEq, Eq, Hash, Lift)]
---- rustc-1.47.0-src.orig/compiler/rustc_middle/src/ty/mod.rs  2020-10-07 09:53:22.000000000 +0200
-+++ rustc-1.47.0-src/compiler/rustc_middle/src/ty/mod.rs       2020-10-30 13:52:39.925285960 +0100
-@@ -604,7 +604,7 @@
- }
- // `TyS` is used a lot. Make sure it doesn't unintentionally get bigger.
--#[cfg(target_arch = "x86_64")]
-+#[cfg(all(target_arch = "x86_64", target_pointer_size = "64"))]
- static_assert_size!(TyS<'_>, 32);
- impl<'tcx> Ord for TyS<'tcx> {
---- rustc-1.47.0-src.orig/compiler/rustc_middle/src/ty/sty.rs  2020-10-07 09:53:22.000000000 +0200
-+++ rustc-1.47.0-src/compiler/rustc_middle/src/ty/sty.rs       2020-10-30 13:52:39.925285960 +0100
-@@ -213,7 +213,7 @@
- }
- // `TyKind` is used a lot. Make sure it doesn't unintentionally get bigger.
--#[cfg(target_arch = "x86_64")]
-+#[cfg(all(target_arch = "x86_64", target_pointer_size = "64"))]
- static_assert_size!(TyKind<'_>, 24);
- /// A closure can be modeled as a struct that looks like:
---- rustc-1.47.0-src.orig/compiler/rustc_infer/src/traits/mod.rs       2020-10-07 09:53:22.000000000 +0200
-+++ rustc-1.47.0-src/compiler/rustc_infer/src/traits/mod.rs    2020-10-30 13:53:29.548462138 +0100
-@@ -56,7 +56,7 @@
- pub type TraitObligation<'tcx> = Obligation<'tcx, ty::PolyTraitPredicate<'tcx>>;
- // `PredicateObligation` is used a lot. Make sure it doesn't unintentionally get bigger.
--#[cfg(target_arch = "x86_64")]
-+#[cfg(all(target_arch = "x86_64", target_pointer_size = "64"))]
- static_assert_size!(PredicateObligation<'_>, 32);
- pub type Obligations<'tcx, O> = Vec<Obligation<'tcx, O>>;
---- rustc-1.47.0-src.orig/compiler/rustc_trait_selection/src/traits/fulfill.rs 2020-10-07 09:53:22.000000000 +0200
-+++ rustc-1.47.0-src/compiler/rustc_trait_selection/src/traits/fulfill.rs      2020-10-30 13:53:12.381849892 +0100
-@@ -85,7 +85,7 @@
- }
- // `PendingPredicateObligation` is used a lot. Make sure it doesn't unintentionally get bigger.
--#[cfg(target_arch = "x86_64")]
-+#[cfg(all(target_arch = "x86_64", target_pointer_size = "64"))]
- static_assert_size!(PendingPredicateObligation<'_>, 56);
- impl<'a, 'tcx> FulfillmentContext<'tcx> {
---- rustc-1.47.0-src.orig/compiler/rustc_trait_selection/src/lib.rs    2020-10-07 09:53:22.000000000 +0200
-+++ rustc-1.47.0-src/compiler/rustc_trait_selection/src/lib.rs 2020-10-30 13:52:39.925285960 +0100
-@@ -20,7 +20,7 @@
- #[macro_use]
- extern crate rustc_macros;
--#[cfg(target_arch = "x86_64")]
-+#[cfg(all(target_arch = "x86_64", target_pointer_size = "64"))]
- #[macro_use]
- extern crate rustc_data_structures;
- #[macro_use]
index 66310f54d44f6d8a76d1fb5dd20628d4c113a805..59293cc1ffeab535275c0b592fdcecc8065760d0 100644 (file)
--- a/rust.spec
+++ b/rust.spec
@@ -51,7 +51,6 @@ Source3:      https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_ru
 # Source3-md5: 3ac79872671df7ea0215fd351f52ffcf
 Source4:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
 # Source4-md5: f624772d7c7ba2e83a51b4e9c1657f7b
-Patch0:                %{name}-x32.patch
 URL:           https://www.rust-lang.org/
 # for src/compiler-rt
 BuildRequires: cmake >= 3.4.3
@@ -326,8 +325,6 @@ Dopełnianie parametrów polecenia cargo w powłoce Zsh.
 
 %prep
 %setup -q -n %{rustc_package}
-# irrelevant when not building rustc for x32
-#%%patch0 -p1
 
 %if %{with bootstrap}
 %ifarch %{x8664} x32
This page took 0.047334 seconds and 4 git commands to generate.