]> git.pld-linux.org Git - packages/rust.git/blobdiff - rust.spec
- update libgit2 BRs
[packages/rust.git] / rust.spec
index a3b7b2137e9700f991a095670202a4c5c768b75b..d9b270d7a7e349748946aed2240742a58652ceed 100644 (file)
--- a/rust.spec
+++ b/rust.spec
@@ -22,9 +22,9 @@
 # To bootstrap from scratch, set the channel and date from src/stage0.txt
 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
 # or nightly wants some beta-YYYY-MM-DD
-%define                bootstrap_rust  1.53.0
-%define                bootstrap_cargo 1.53.0
-%define                bootstrap_date  2021-06-17
+%define                bootstrap_rust  1.55.0
+%define                bootstrap_cargo 1.55.0
+%define                bootstrap_date  2021-09-09
 
 %ifarch x32
 %define                with_cross      1
 Summary:       The Rust Programming Language
 Summary(pl.UTF-8):     JÄ™zyk programowania Rust
 Name:          rust
-Version:       1.54.0
-Release:       1
+Version:       1.56.0
+Release:       2
 # Licenses: (rust itself) and (bundled libraries)
 License:       (Apache v2.0 or MIT) and (BSD and ISC and MIT)
 Group:         Development/Languages
 Source0:       https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
-# Source0-md5: f1fc7b0f0c7aff2b8d61e58b510a6f66
+# Source0-md5: 3ad94ba9f05779800a5da6c02e00c444
 Source1:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
-# Source1-md5: 3f2ea3d908dac317d6006a117463f18e
+# Source1-md5: 59b0a04436f96250a307086b6fc2ce34
 Source2:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
-# Source2-md5: 2ea9461d6c06c38ad85cc6037d70b9d7
+# Source2-md5: 693c87cf2fc1a41169f55fdbf8426a2e
 Source3:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
-# Source3-md5: 0772ec454b29685a4d79ead06c5cdd23
+# Source3-md5: 475f762804d4ad8695029a70f8b93a6d
 Source4:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
-# Source4-md5: 7ecbfb7344a3dbafcaddffb898afbfa9
+# Source4-md5: 56a568e97e7a5c3cb80569ab84f4657b
 Source5:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
-# Source5-md5: 3650d93b062c6605e3aa96ce4d63335c
+# Source5-md5: 991a439bcdcbcf1b2bbe55ce9e90404f
 URL:           https://www.rust-lang.org/
 # for src/compiler-rt
 BuildRequires: cmake >= 3.4.3
@@ -64,9 +64,12 @@ BuildRequires:       python >= 1:2.7
 BuildRequires: rpmbuild(macros) >= 1.752
 %if %{without cross}
 BuildRequires: curl-devel
-BuildRequires: libgit2-devel >= 1.1.0
+BuildRequires: libgit2-devel >= 1.3.0
 BuildRequires: libstdc++-devel
-%{?with_system_llvm:BuildRequires:     llvm-devel >= 10.0}
+%if %{with system_llvm}
+BuildRequires: llvm >= 10.0
+BuildRequires: llvm-devel >= 10.0
+%endif
 BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
@@ -84,7 +87,7 @@ BuildRequires:        glibc-devel(x86-x32)
 # building on x86_64 host with --target x32-pld-linux
 BuildRequires: curl-devel
 BuildRequires: gcc-multilib-x32
-BuildRequires: libgit2-devel >= 1.1.0
+BuildRequires: libgit2-devel >= 1.3.0
 BuildRequires: libstdc++-devel
 %{?with_system_llvm:BuildRequires:     llvm-devel >= 10.0}
 BuildRequires: openssl-devel >= 1.0.1
@@ -94,8 +97,8 @@ BuildRequires:        zlib-devel
 BuildRequires: curl-devel(x86-64)
 BuildRequires: curl-devel(x86-x32)
 BuildRequires: gcc-multilib-64
-BuildRequires: libgit2-devel(x86-64) >= 1.1.0
-BuildRequires: libgit2-devel(x86-x32) >= 1.1.0
+BuildRequires: libgit2-devel(x86-64) >= 1.3.0
+BuildRequires: libgit2-devel(x86-x32) >= 1.3.0
 BuildRequires: libstdc++-multilib-64-devel
 %if %{with system_llvm}
 BuildRequires: llvm-devel(x86-64) >= 10.0
@@ -360,10 +363,6 @@ test -f %{local_rust_root}/bin/rustc
 mkdir -p src/llvm-project/libunwind
 %endif
 
-# extract bundled licenses for packaging
-sed -e '/*\//q' library/backtrace/crates/backtrace-sys/src/libbacktrace/backtrace.h \
-       >library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
-
 # rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
 sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
        src/etc/rust-gdb
@@ -474,7 +473,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
+%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md
 %attr(755,root,root) %{_bindir}/rustc
 %attr(755,root,root) %{_bindir}/rustdoc
 %attr(755,root,root) %{_bindir}/rustfmt
This page took 0.115371 seconds and 4 git commands to generate.