]> git.pld-linux.org Git - packages/rust.git/blobdiff - rust.spec
follow Fedora and package cargo shipped with rust
[packages/rust.git] / rust.spec
index b45a408b46d69e8889038572601d87704aee0851..6e14c54478050e654b5b4d73cd463b7590bf657b 100644 (file)
--- a/rust.spec
+++ b/rust.spec
@@ -1,6 +1,7 @@
 # TODO
 # - consider a rust-std package containing .../rustlib/$target
 #   This might allow multilib cross-compilation to work naturally.
+# - package additional tools
 #
 # Conditional build:
 %bcond_with    bootstrap       # bootstrap using precompiled binaries
 # To bootstrap from scratch, set the channel and date from src/stage0.txt
 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
 # or nightly wants some beta-YYYY-MM-DD
-%define                bootstrap_rust  1.27.2
-%define                bootstrap_cargo 1.27.0
-%define                bootstrap_date  2018-07-20
+%define                bootstrap_rust  1.28.0
+%define                bootstrap_cargo 0.29.0
+%define                bootstrap_date  2018-08-02
 
 Summary:       The Rust Programming Language
 Summary(pl.UTF-8):     Język programowania Rust
 Name:          rust
-Version:       1.28.0
+Version:       1.29.0
 Release:       1
 # Licenses: (rust itself) and (bundled libraries)
 License:       (Apache v2.0 or MIT) and (BSD and ISC and MIT)
 Group:         Development/Languages
 Source0:       https://static.rust-lang.org/dist/%{rustc_package}.tar.gz
-# Source0-md5: 80acd625df9389e16a88fc4f1d0f646b
+# Source0-md5: 54c3f0ffb826bdcc2a7395468828a94c
 Source1:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.gz
-# Source1-md5: 3564263497f7b3cb0c9391f7b0c5831d
+# Source1-md5: b2fd4b6300018239e61b35aa80a5a9ee
 Source2:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.gz
-# Source2-md5: 5df2caf50f5e8c4706d8151ebd845f9c
+# Source2-md5: d70f6d58f7de41672a27c3b37f1dcbb6
 Patch0:                x32.patch
 URL:           https://www.rust-lang.org/
 # for src/compiler-rt
@@ -162,6 +163,46 @@ language and its standard library.
 Ten pakiet zawiera dokumentację w formacie HTML do języka
 programowania Rust i jego biblioteki standardowej.
 
+%package -n bash-completion-cargo
+Summary:       Bash completion for cargo command
+Summary(pl.UTF-8):     Bashowe dopełnianie parametrów polecenia cargo
+Group:         Applications/Shells
+Requires:      %{name} = %{version}-%{release}
+Requires:      bash-completion
+
+%description -n bash-completion-cargo
+Bash completion for cargo command.
+
+%description -n bash-completion-cargo -l pl.UTF-8
+Bashowe dopełnianie parametrów polecenia cargo.
+
+%package -n cargo
+Summary:       Rust's package manager and build tool
+Summary(pl.UTF-8):     Zarządca pakietów i narzędzie do budowania
+Group:         Development/Tools
+Requires:      %{name}
+
+%description -n cargo
+Cargo is a tool that allows Rust projects to declare their various
+dependencies and ensure that you'll always get a repeatable build.
+
+%description -n cargo -l pl.UTF-8
+Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
+zależności i zapewniające powtarzalność procesu budowania.
+
+%package -n zsh-completion-cargo
+Summary:       Zsh completion for cargo command
+Summary(pl.UTF-8):     Dopełnianie parametrów polecenia cargo w powłoce Zsh
+Group:         Applications/Shells
+Requires:      %{name} = %{version}-%{release}
+Requires:      bash-completion
+
+%description -n zsh-completion-cargo
+Zsh completion for cargo command.
+
+%description -n zsh-completion-cargo -l pl.UTF-8
+Dopełnianie parametrów polecenia cargo w powłoce Zsh.
+
 %prep
 %setup -q -n %{rustc_package}
 %ifarch x32
@@ -221,6 +262,7 @@ find src/vendor -name .cargo-checksum.json \
        --enable-debuginfo-only-std \
        --disable-debuginfo \
 %endif
+       --enable-extended \
        --enable-llvm-link-shared \
        --local-rust-root=%{local_rust_root} \
        --enable-vendor \
@@ -331,3 +373,18 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %dir %{_docdir}/%{name}
 %doc %{_docdir}/%{name}/html
+
+%files -n cargo
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/cargo
+%{_mandir}/man1/cargo*.1*
+%dir %{_datadir}/cargo
+%dir %{_datadir}/cargo/registry
+
+%files -n bash-completion-cargo
+%defattr(644,root,root,755)
+%{_sysconfdir}/bash_completion.d/cargo
+
+%files -n zsh-completion-cargo
+%defattr(644,root,root,755)
+%{zsh_compdir}/_cargo
This page took 0.118647 seconds and 4 git commands to generate.