]> git.pld-linux.org Git - packages/rust.git/blob - rust.spec
- update git2 and libgit2 crates to latest versions, rel 3
[packages/rust.git] / rust.spec
1 # TODO
2 # - unpackaged %{rustlibdir}/%{rust_triple}/bin/rust-llvm-dwp
3 # - consider a rust-std package containing .../rustlib/$target
4 #   This might allow multilib cross-compilation to work naturally.
5 # - package additional tools
6 #
7 # Conditional build:
8 %bcond_with     bootstrap       # bootstrap using precompiled binaries
9 %bcond_with     full_debuginfo  # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
10 %bcond_without  system_llvm     # system LLVM
11 %bcond_with     tests           # build without tests
12
13 # The channel can be stable, beta, or nightly
14 %define         channel         stable
15
16 %if "%{channel}" == "stable"
17 %define         rustc_package   rustc-%{version}-src
18 %else
19 %define         rustc_package   rustc-%{channel}-src
20 %endif
21
22 # To bootstrap from scratch, set the channel and date from src/stage0.txt
23 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
24 # or nightly wants some beta-YYYY-MM-DD
25 %define         bootstrap_rust  1.55.0
26 %define         bootstrap_cargo 1.55.0
27 %define         bootstrap_date  2021-09-09
28
29 %ifarch x32
30 %define         with_cross      1
31 %endif
32
33 %if %{without full_debuginfo}
34 %define         _enable_debug_packages  0
35 %endif
36
37 Summary:        The Rust Programming Language
38 Summary(pl.UTF-8):      Język programowania Rust
39 Name:           rust
40 Version:        1.56.0
41 Release:        3
42 # Licenses: (rust itself) and (bundled libraries)
43 License:        (Apache v2.0 or MIT) and (BSD and ISC and MIT)
44 Group:          Development/Languages
45 Source0:        https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
46 # Source0-md5:  3ad94ba9f05779800a5da6c02e00c444
47 Source1:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
48 # Source1-md5:  59b0a04436f96250a307086b6fc2ce34
49 Source2:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
50 # Source2-md5:  693c87cf2fc1a41169f55fdbf8426a2e
51 Source3:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
52 # Source3-md5:  475f762804d4ad8695029a70f8b93a6d
53 Source4:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
54 # Source4-md5:  56a568e97e7a5c3cb80569ab84f4657b
55 Source5:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
56 # Source5-md5:  991a439bcdcbcf1b2bbe55ce9e90404f
57 Patch0:         libgit2.patch
58 URL:            https://www.rust-lang.org/
59 # for src/compiler-rt
60 BuildRequires:  cmake >= 3.4.3
61 BuildRequires:  curl
62 # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
63 BuildRequires:  procps
64 BuildRequires:  python >= 1:2.7
65 BuildRequires:  rpmbuild(macros) >= 1.752
66 %if %{without cross}
67 BuildRequires:  curl-devel
68 BuildRequires:  libgit2-devel >= 1.3.0
69 BuildRequires:  libstdc++-devel
70 %if %{with system_llvm}
71 BuildRequires:  llvm >= 10.0
72 BuildRequires:  llvm-devel >= 10.0
73 %endif
74 BuildRequires:  openssl-devel >= 1.0.1
75 BuildRequires:  tar >= 1:1.22
76 BuildRequires:  xz
77 BuildRequires:  zlib-devel
78 %endif
79 %if %{without bootstrap}
80 BuildRequires:  %{name} >= %{bootstrap_rust}
81 BuildRequires:  cargo >= %{bootstrap_cargo}
82 BuildConflicts: %{name} > %{version}
83 %endif
84 %ifarch x32
85 BuildRequires:  glibc-devel(x86-64)
86 BuildRequires:  glibc-devel(x86-x32)
87 %if "%{_host_cpu}" == "x86_64"
88 # building on x86_64 host with --target x32-pld-linux
89 BuildRequires:  curl-devel
90 BuildRequires:  gcc-multilib-x32
91 BuildRequires:  libgit2-devel >= 1.3.0
92 BuildRequires:  libstdc++-devel
93 %{?with_system_llvm:BuildRequires:      llvm-devel >= 10.0}
94 BuildRequires:  openssl-devel >= 1.0.1
95 BuildRequires:  zlib-devel
96 %else
97 # building x86_64-hosted crosscompiler on x32 host
98 BuildRequires:  curl-devel(x86-64)
99 BuildRequires:  curl-devel(x86-x32)
100 BuildRequires:  gcc-multilib-64
101 BuildRequires:  libgit2-devel(x86-64) >= 1.3.0
102 BuildRequires:  libgit2-devel(x86-x32) >= 1.3.0
103 BuildRequires:  libstdc++-multilib-64-devel
104 %if %{with system_llvm}
105 BuildRequires:  llvm-devel(x86-64) >= 10.0
106 BuildRequires:  llvm-devel(x86-x32) >= 10.0
107 %endif
108 BuildRequires:  openssl-devel(x86-64)
109 BuildRequires:  openssl-devel(x86-x32)
110 BuildRequires:  zlib-devel(x86-64)
111 BuildRequires:  zlib-devel(x86-x32)
112 %endif
113 %endif
114 # The C compiler is needed at runtime just for linking.  Someday rustc might
115 # invoke the linker directly, and then we'll only need binutils.
116 # https://github.com/rust-lang/rust/issues/11937
117 Requires:       gcc
118 Requires:       %{name}-std%{?_isa} = %{version}-%{release}
119 %ifarch x32
120 Requires:       %{name}-std(x86-64) = %{version}-%{release}
121 %endif
122 Obsoletes:      rust-analyzer < 1.53.0
123 # Only x86_64 and i686 are Tier 1 platforms at this time.
124 # x32 is Tier 2, only rust-std is available (no rustc or cargo).
125 # https://doc.rust-lang.org/nightly/rustc/platform-support.html
126 ExclusiveArch:  %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
127 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
128
129 %ifarch x32
130 %define         rust_triple             x86_64-unknown-linux-gnux32
131 %define         rust_host_triple        x86_64-unknown-linux-gnu
132 %define         rust_bootstrap_triple   x86_64-unknown-linux-gnu
133 # libs in _libdir are x86_64 64bit
134 %define         _lib                    lib64
135 %define         _libdir                 %{_prefix}/lib64
136 %else
137 %ifarch armv6hl
138 %define         rust_triple             arm-unknown-linux-gnueabihf
139 %define         rust_host_triple        %{rust_triple}
140 %define         rust_bootstrap_triple   %{rust_triple}
141 %else
142 %ifarch armv7hl armv7hnl
143 %define         rust_triple             armv7-unknown-linux-gnueabihf
144 %define         rust_host_triple        %{rust_triple}
145 %define         rust_bootstrap_triple   %{rust_triple}
146 %else
147 %define         rust_triple             %{_target_cpu}-unknown-linux-gnu
148 %define         rust_host_triple        %{rust_triple}
149 %define         rust_bootstrap_triple   %{rust_triple}
150 %endif
151 %endif
152 %endif
153
154 %if %{without bootstrap}
155 %define         local_rust_root %{_prefix}
156 %else
157 %define         bootstrap_root  rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
158 %define         local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
159 %endif
160
161 # We're going to override --libdir when configuring to get rustlib into a
162 # common path, but we'll fix the shared libraries during install.
163 # Without this ugly hack, rust would not be able to build itself
164 # for non-bootstrap build, lib64 is just too complicated for it.
165 %define         common_libdir   %{_prefix}/lib
166 %define         rustlibdir      %{common_libdir}/rustlib
167
168 # once_call/once_callable non-function libstdc++ symbols
169 %define         skip_post_check_so      'librustc.*llvm.*\.so.*'
170
171 # ALL Rust libraries are private, because they don't keep an ABI.
172 %define         _noautoreqfiles         lib.*-[[:xdigit:]]{8}[.]so.*
173 %define         _noautoprovfiles        lib.*-[[:xdigit:]]{8}[.]so.*
174
175 %define         x_py { \
176         x_py() { \
177                 local cmd="$1"; \
178                 shift; \
179                 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
180         }; x_py }
181
182
183 %description
184 Rust is a systems programming language that runs blazingly fast,
185 prevents segfaults, and guarantees thread safety.
186
187 This package includes the Rust compiler, standard library, and
188 documentation generator.
189
190 %description -l pl.UTF-8
191 Rust to systemowy język programowania działający bardzo szybko,
192 zapobiegający naruszeniom ochrony pamięci i gwarantujący
193 bezpieczną wielowątkowość.
194
195 %package analysis
196 Summary:        Metadata about the standard library
197 Summary(pl.UTF-8):      Metadane o standardowej bibliotece
198 Group:          Development/Tools
199 Requires:       %{name} = %{version}-%{release}
200
201 %description analysis
202 Metadata about the standard library.
203
204 %description analysis -l pl.UTF-8
205 Metadane o standardowej bibliotece.
206
207 %package std
208 Summary:        Standard library for Rust
209 Summary(pl.UTF-8):      Standardowa biblioteka Rusta
210 Group:          Development/Tools
211 Requires:       %{name} = %{version}-%{release}
212
213 %description std
214 Standard library for Rust.
215
216 %description std -l pl.UTF-8
217 Standardowa biblioteka Rusta.
218
219 %package debugger-common
220 Summary:        Common debugger pretty printers for Rust
221 Summary(pl.UTF-8):      Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
222 Group:          Development/Debuggers
223 BuildArch:      noarch
224
225 %description debugger-common
226 This package includes the common functionality for rust-gdb and
227 rust-lldb.
228
229 %description debugger-common -l pl.UTF-8
230 Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
231
232 %package gdb
233 Summary:        GDB pretty printers for Rust
234 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w GDB
235 Group:          Development/Debuggers
236 Requires:       %{name}-debugger-common = %{version}-%{release}
237 Requires:       gdb
238 BuildArch:      noarch
239
240 %description gdb
241 This package includes the rust-gdb script, which allows easier
242 debugging of Rust programs.
243
244 %description gdb -l pl.UTF-8
245 Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
246 odpluskwianie programów w języku Rust.
247
248 %package lldb
249 Summary:        LLDB pretty printers for Rust
250 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w LLDB
251 Group:          Development/Debuggers
252 Requires:       %{name}-debugger-common = %{version}-%{release}
253 Requires:       lldb
254 BuildArch:      noarch
255
256 %description lldb
257 This package includes the rust-lldb script, which allows easier
258 debugging of Rust programs.
259
260 %description lldb -l pl.UTF-8
261 Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
262 odpluskwianie programów w języku Rust.
263
264 %package rls
265 Summary:        Rust Language Server for IDE integration
266 Summary(pl.UTF-8):      Rust Language Server do integracji z IDE
267 Group:          Development/Tools
268 Requires:       %{name} = %{version}-%{release}
269 Requires:       %{name}-analysis = %{version}-%{release}
270
271 %description rls
272 Rust Language Server for IDE integration.
273
274 %description rls -l pl.UTF-8
275 Rust Language Server do integracji z IDE.
276
277 %package doc
278 Summary:        Documentation for Rust
279 Summary(pl.UTF-8):      Dokumentacja do Rusta
280 Group:          Documentation
281 BuildArch:      noarch
282
283 %description doc
284 This package includes HTML documentation for the Rust programming
285 language and its standard library.
286
287 %description doc -l pl.UTF-8
288 Ten pakiet zawiera dokumentację w formacie HTML do języka
289 programowania Rust i jego biblioteki standardowej.
290
291 %package -n cargo
292 Summary:        Rust's package manager and build tool
293 Summary(pl.UTF-8):      Zarządca pakietów i narzędzie do budowania
294 Group:          Development/Tools
295 Requires:       %{name}%{?_isa}
296
297 %description -n cargo
298 Cargo is a tool that allows Rust projects to declare their various
299 dependencies and ensure that you'll always get a repeatable build.
300
301 %description -n cargo -l pl.UTF-8
302 Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
303 zależności i zapewniające powtarzalność procesu budowania.
304
305 %package -n bash-completion-cargo
306 Summary:        Bash completion for cargo command
307 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów polecenia cargo
308 Group:          Applications/Shells
309 Requires:       %{name} = %{version}-%{release}
310 Requires:       bash-completion
311
312 %description -n bash-completion-cargo
313 Bash completion for cargo command.
314
315 %description -n bash-completion-cargo -l pl.UTF-8
316 Bashowe dopełnianie parametrów polecenia cargo.
317
318 %package -n zsh-completion-cargo
319 Summary:        Zsh completion for cargo command
320 Summary(pl.UTF-8):      Dopełnianie parametrów polecenia cargo w powłoce Zsh
321 Group:          Applications/Shells
322 Requires:       %{name} = %{version}-%{release}
323 Requires:       zsh
324
325 %description -n zsh-completion-cargo
326 Zsh completion for cargo command.
327
328 %description -n zsh-completion-cargo -l pl.UTF-8
329 Dopełnianie parametrów polecenia cargo w powłoce Zsh.
330
331 %prep
332 %setup -q -n %{rustc_package}
333 %patch0 -p1
334
335 %if %{with bootstrap}
336 %ifarch %{x8664} x32
337 tar xf %{SOURCE1}
338 %endif
339 %ifarch %{ix86}
340 tar xf %{SOURCE2}
341 %endif
342 %ifarch aarch64
343 tar xf %{SOURCE3}
344 %endif
345 %ifarch armv6hl
346 tar xf %{SOURCE4}
347 %endif
348 %ifarch armv7hl armv7hnl
349 tar xf %{SOURCE5}
350 %endif
351 %{__mv} %{bootstrap_root} %{bootstrap_root}-root
352 %{bootstrap_root}-root/install.sh \
353         --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
354         --prefix=%{local_rust_root} \
355         --disable-ldconfig
356 test -f %{local_rust_root}/bin/cargo
357 test -f %{local_rust_root}/bin/rustc
358 %endif
359
360 # unbundle
361 # We're disabling jemalloc, but rust-src still wants it.
362 #%{__rm} -r src/jemalloc
363 %if %{with system_llvm}
364 %{__rm} -r src/llvm-project
365 mkdir -p src/llvm-project/libunwind
366 %endif
367
368 # rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
369 sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
370         src/etc/rust-gdb
371
372 # cargo has hardcoded libexec path - honour rpm _libexecdir
373 %if "%{_libexecdir}" != "%{_prefix}/libexec"
374 suffix="%(echo "%{_libexecdir}" | %{__sed} -e 's,^%{_prefix}/,,')"
375 %{__sed} -i -e 's,"libexec","'${suffix}'",' \
376         src/bootstrap/dist.rs \
377         src/tools/cargo/src/cargo/ops/registry/auth.rs
378 %{__sed} -i -e 's,libexec/,'${suffix}'/,' src/tools/cargo/tests/testsuite/credential_process.rs
379 %endif
380
381 # The configure macro will modify some autoconf-related files, which upsets
382 # cargo when it tries to verify checksums in those files.  If we just truncate
383 # that file list, cargo won't have anything to complain about.
384 find vendor -name .cargo-checksum.json \
385         -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
386
387 %build
388 %configure \
389         --build=%{rust_bootstrap_triple} \
390         --host=%{rust_host_triple} \
391         --target=%{rust_triple} \
392         --libdir=%{common_libdir} \
393         --disable-codegen-tests \
394         --disable-debuginfo-lines \
395 %if %{with full_debuginfo}
396         --disable-debuginfo-only-std \
397         --enable-debuginfo \
398 %else
399         --enable-debuginfo-only-std \
400         --disable-debuginfo \
401 %endif
402         --disable-jemalloc \
403         --disable-option-checking \
404         --disable-rpath \
405         --enable-extended \
406         --enable-llvm-link-shared \
407         --enable-vendor \
408         --local-rust-root=%{local_rust_root} \
409         --llvm-root=%{_prefix} \
410         --release-channel=%{channel}
411
412 export RUST_BACKTRACE=full
413 %x_py dist --verbose
414
415 %{?with_tests:%x_py test}
416
417 %install
418 rm -rf $RPM_BUILD_ROOT
419
420 export DESTDIR=$RPM_BUILD_ROOT
421 %x_py install
422
423 # Make sure the shared libraries are in the proper libdir
424 %if "%{_libdir}" != "%{common_libdir}"
425 mkdir -p %{buildroot}%{_libdir}
426 find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
427         -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
428 %endif
429
430 # The shared libraries should be executable for debuginfo extraction.
431 find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
432
433 # The libdir libraries are identical to those under rustlib/.  It's easier on
434 # library loading if we keep them in libdir, but we do need them in rustlib/
435 # to support dynamic linking for compiler plugins, so we'll symlink.
436 for l in libstd libtest ; do
437         liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
438         libstd=$RPM_BUILD_ROOT%{rustlibdir}/%{rust_triple}/lib/${l}-*.so
439         if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
440                 ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
441         fi
442 done
443
444 # Remove installer artifacts (manifests, uninstall scripts, etc.)
445 find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
446
447 # FIXME: __os_install_post will strip the rlibs
448 # -- should we find a way to preserve debuginfo?
449
450 # Remove unwanted documentation files (we already package them)
451 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
452 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
453 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
454 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
455
456 # Sanitize the HTML documentation
457 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
458 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
459
460 # Move rust-gdb's python scripts so they're noarch
461 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
462 %{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
463
464 # We don't need stdlib source
465 %{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
466
467 # Create the path for crate-devel packages
468 install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
469
470 %clean
471 rm -rf $RPM_BUILD_ROOT
472
473 %post   -p /sbin/ldconfig
474 %postun -p /sbin/ldconfig
475
476 %files
477 %defattr(644,root,root,755)
478 %doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md
479 %attr(755,root,root) %{_bindir}/rustc
480 %attr(755,root,root) %{_bindir}/rustdoc
481 %attr(755,root,root) %{_bindir}/rustfmt
482 %attr(755,root,root) %{_libdir}/librustc_driver-*.so
483 %attr(755,root,root) %{_libdir}/libstd-*.so
484 %attr(755,root,root) %{_libdir}/libtest-*.so
485 %{_mandir}/man1/rustc.1*
486 %{_mandir}/man1/rustdoc.1*
487 %dir %{rustlibdir}
488
489 %files analysis
490 %defattr(644,root,root,755)
491 %{rustlibdir}/%{rust_triple}/analysis
492
493 %files std
494 %defattr(644,root,root,755)
495 %dir %{rustlibdir}/%{rust_triple}
496 %dir %{rustlibdir}/%{rust_triple}/lib
497 %attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
498 %{rustlibdir}/%{rust_triple}/lib/*.rlib
499
500 %files debugger-common
501 %defattr(644,root,root,755)
502 %dir %{_datadir}/%{name}
503 %dir %{_datadir}/%{name}/etc
504 %{_datadir}/%{name}/etc/lldb_commands
505 %{_datadir}/%{name}/etc/rust_types.py
506
507 %files lldb
508 %defattr(644,root,root,755)
509 %attr(755,root,root) %{_bindir}/rust-lldb
510 %{_datadir}/%{name}/etc/lldb_*.py*
511
512 %files gdb
513 %defattr(644,root,root,755)
514 %attr(755,root,root) %{_bindir}/rust-gdb
515 %attr(755,root,root) %{_bindir}/rust-gdbgui
516 %{_datadir}/%{name}/etc/gdb_*.py*
517
518 %files rls
519 %defattr(644,root,root,755)
520 %attr(755,root,root) %{_bindir}/rls
521
522 %files doc
523 %defattr(644,root,root,755)
524 %dir %{_docdir}/%{name}
525 %doc %{_docdir}/%{name}/html
526
527 %files -n cargo
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_bindir}/cargo
530 %attr(755,root,root) %{_bindir}/cargo-clippy
531 %attr(755,root,root) %{_bindir}/cargo-fmt
532 %attr(755,root,root) %{_bindir}/clippy-driver
533 %attr(755,root,root) %{_libexecdir}/cargo-credential-1password
534 %{_mandir}/man1/cargo*.1*
535 %dir %{_datadir}/cargo
536 %dir %{_datadir}/cargo/registry
537
538 %files -n bash-completion-cargo
539 %defattr(644,root,root,755)
540 %{_sysconfdir}/bash_completion.d/cargo
541
542 %files -n zsh-completion-cargo
543 %defattr(644,root,root,755)
544 %{zsh_compdir}/_cargo
This page took 0.08119 seconds and 4 git commands to generate.