]> git.pld-linux.org Git - packages/rust.git/blob - rust.spec
- rel 2
[packages/rust.git] / rust.spec
1 # TODO
2 # - consider a rust-std package containing .../rustlib/$target
3 #   This might allow multilib cross-compilation to work naturally.
4 # - package additional tools
5 #
6 # Conditional build:
7 %bcond_with     bootstrap       # bootstrap using precompiled binaries
8 %bcond_with     full_debuginfo  # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
9 %bcond_without  system_llvm     # system LLVM
10 %bcond_with     tests           # build without tests
11
12 # The channel can be stable, beta, or nightly
13 %define         channel         stable
14
15 %if "%{channel}" == "stable"
16 %define         rustc_package   rustc-%{version}-src
17 %else
18 %define         rustc_package   rustc-%{channel}-src
19 %endif
20
21 # To bootstrap from scratch, set the channel and date from src/stage0.txt
22 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23 # or nightly wants some beta-YYYY-MM-DD
24 %define         bootstrap_rust  1.51.0
25 %define         bootstrap_cargo 1.51.0
26 %define         bootstrap_date  2021-03-25
27
28 %ifarch x32
29 %define         with_cross      1
30 %endif
31
32 %if %{without full_debuginfo}
33 %define         _enable_debug_packages  0
34 %endif
35
36 Summary:        The Rust Programming Language
37 Summary(pl.UTF-8):      Język programowania Rust
38 Name:           rust
39 Version:        1.52.1
40 Release:        2
41 # Licenses: (rust itself) and (bundled libraries)
42 License:        (Apache v2.0 or MIT) and (BSD and ISC and MIT)
43 Group:          Development/Languages
44 Source0:        https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
45 # Source0-md5:  2df4835e3a15cc6f7e06fa4a986285d2
46 Source1:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
47 # Source1-md5:  7640d6538716c6492e56f361e3af0631
48 Source2:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
49 # Source2-md5:  64f117dc1ae1543c8910eaa9a971ddd4
50 Source3:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
51 # Source3-md5:  3ac79872671df7ea0215fd351f52ffcf
52 Source4:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
53 # Source4-md5:  f624772d7c7ba2e83a51b4e9c1657f7b
54 URL:            https://www.rust-lang.org/
55 # for src/compiler-rt
56 BuildRequires:  cmake >= 3.4.3
57 BuildRequires:  curl
58 # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
59 BuildRequires:  procps
60 BuildRequires:  python >= 1:2.7
61 BuildRequires:  rpmbuild(macros) >= 1.752
62 %if %{without cross}
63 BuildRequires:  curl-devel
64 BuildRequires:  libgit2-devel >= 1.1.0
65 BuildRequires:  libstdc++-devel
66 %{?with_system_llvm:BuildRequires:      llvm-devel >= 9.0}
67 BuildRequires:  openssl-devel >= 1.0.1
68 BuildRequires:  tar >= 1:1.22
69 BuildRequires:  xz
70 BuildRequires:  zlib-devel
71 %endif
72 %if %{without bootstrap}
73 BuildRequires:  %{name} >= %{bootstrap_rust}
74 BuildRequires:  cargo >= %{bootstrap_cargo}
75 BuildConflicts: %{name} > %{version}
76 %endif
77 %ifarch x32
78 BuildRequires:  glibc-devel(x86-64)
79 BuildRequires:  glibc-devel(x86-x32)
80 %if "%{_host_cpu}" == "x86_64"
81 # building on x86_64 host with --target x32-pld-linux
82 BuildRequires:  curl-devel
83 BuildRequires:  gcc-multilib-x32
84 BuildRequires:  libgit2-devel >= 1.1.0
85 BuildRequires:  libstdc++-devel
86 %{?with_system_llvm:BuildRequires:      llvm-devel >= 9.0}
87 BuildRequires:  openssl-devel >= 1.0.1
88 BuildRequires:  zlib-devel
89 %else
90 # building x86_64-hosted crosscompiler on x32 host
91 BuildRequires:  curl-devel(x86-64)
92 BuildRequires:  curl-devel(x86-x32)
93 BuildRequires:  gcc-multilib-64
94 BuildRequires:  libgit2-devel(x86-64) >= 1.1.0
95 BuildRequires:  libgit2-devel(x86-x32) >= 1.1.0
96 BuildRequires:  libstdc++-multilib-64-devel
97 %if %{with system_llvm}
98 BuildRequires:  llvm-devel(x86-64) >= 9.0
99 BuildRequires:  llvm-devel(x86-x32) >= 9.0
100 %endif
101 BuildRequires:  openssl-devel(x86-64)
102 BuildRequires:  openssl-devel(x86-x32)
103 BuildRequires:  zlib-devel(x86-64)
104 BuildRequires:  zlib-devel(x86-x32)
105 %endif
106 %endif
107 # The C compiler is needed at runtime just for linking.  Someday rustc might
108 # invoke the linker directly, and then we'll only need binutils.
109 # https://github.com/rust-lang/rust/issues/11937
110 Requires:       gcc
111 Requires:       %{name}-std%{?_isa} = %{version}-%{release}
112 %ifarch x32
113 Requires:       %{name}-std(x86-64) = %{version}-%{release}
114 %endif
115 # Only x86_64 and i686 are Tier 1 platforms at this time.
116 # x32 is Tier 2, only rust-std is available (no rustc or cargo).
117 # https://doc.rust-lang.org/nightly/rustc/platform-support.html
118 ExclusiveArch:  %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
119 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
120
121 %ifarch x32
122 %define         rust_triple             x86_64-unknown-linux-gnux32
123 %define         rust_host_triple        x86_64-unknown-linux-gnu
124 %define         rust_bootstrap_triple   x86_64-unknown-linux-gnu
125 # libs in _libdir are x86_64 64bit
126 %define         _lib                    lib64
127 %define         _libdir                 %{_prefix}/lib64
128 %else
129 %ifarch armv6hl armv7hl armv7hnl
130 %define         rust_triple             arm-unknown-linux-gnueabihf
131 %define         rust_host_triple        %{rust_triple}
132 %define         rust_bootstrap_triple   %{rust_triple}
133 %else
134 %define         rust_triple             %{_target_cpu}-unknown-linux-gnu
135 %define         rust_host_triple        %{rust_triple}
136 %define         rust_bootstrap_triple   %{rust_triple}
137 %endif
138 %endif
139
140 %if %{without bootstrap}
141 %define         local_rust_root %{_prefix}
142 %else
143 %define         bootstrap_root  rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
144 %define         local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
145 %endif
146
147 # We're going to override --libdir when configuring to get rustlib into a
148 # common path, but we'll fix the shared libraries during install.
149 # Without this ugly hack, rust would not be able to build itself
150 # for non-bootstrap build, lib64 is just too complicated for it.
151 %define         common_libdir   %{_prefix}/lib
152 %define         rustlibdir      %{common_libdir}/rustlib
153
154 # once_call/once_callable non-function libstdc++ symbols
155 %define         skip_post_check_so      'librustc.*llvm.*\.so.*'
156
157 # ALL Rust libraries are private, because they don't keep an ABI.
158 %define         _noautoreqfiles         lib.*-[[:xdigit:]]{8}[.]so.*
159 %define         _noautoprovfiles        lib.*-[[:xdigit:]]{8}[.]so.*
160
161 %define         x_py { \
162         x_py() { \
163                 local cmd="$1"; \
164                 shift; \
165                 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
166         }; x_py }
167
168
169 %description
170 Rust is a systems programming language that runs blazingly fast,
171 prevents segfaults, and guarantees thread safety.
172
173 This package includes the Rust compiler, standard library, and
174 documentation generator.
175
176 %description -l pl.UTF-8
177 Rust to systemowy język programowania działający bardzo szybko,
178 zapobiegający naruszeniom ochrony pamięci i gwarantujący
179 bezpieczną wielowątkowość.
180
181 %package analysis
182 Summary:        Metadata about the standard library
183 Summary(pl.UTF-8):      Metadane o standardowej bibliotece
184 Group:          Development/Tools
185 Requires:       %{name} = %{version}-%{release}
186
187 %description analysis
188 Metadata about the standard library.
189
190 %description analysis -l pl.UTF-8
191 Metadane o standardowej bibliotece.
192
193 %package std
194 Summary:        Standard library for Rust
195 Summary(pl.UTF-8):      Standardowa biblioteka Rusta
196 Group:          Development/Tools
197 Requires:       %{name} = %{version}-%{release}
198
199 %description std
200 Standard library for Rust.
201
202 %description std -l pl.UTF-8
203 Standardowa biblioteka Rusta.
204
205 %package analyzer
206 Summary:        Implementation of Language Server Protocol for Rust
207 Summary(pl.UTF-8):      Implementacja Language Server Protocol dla Rusta
208 Group:          Development/Tools
209 Requires:       %{name} = %{version}-%{release}
210
211 %description analyzer
212 Implementation of Language Server Protocol for Rust.
213
214 %description analyzer -l pl.UTF-8
215 Implementacja Language Server Protocol dla Rusta.
216
217 %package debugger-common
218 Summary:        Common debugger pretty printers for Rust
219 Summary(pl.UTF-8):      Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
220 Group:          Development/Debuggers
221 BuildArch:      noarch
222
223 %description debugger-common
224 This package includes the common functionality for rust-gdb and
225 rust-lldb.
226
227 %description debugger-common -l pl.UTF-8
228 Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
229
230 %package gdb
231 Summary:        GDB pretty printers for Rust
232 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w GDB
233 Group:          Development/Debuggers
234 Requires:       %{name}-debugger-common = %{version}-%{release}
235 Requires:       gdb
236 BuildArch:      noarch
237
238 %description gdb
239 This package includes the rust-gdb script, which allows easier
240 debugging of Rust programs.
241
242 %description gdb -l pl.UTF-8
243 Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
244 odpluskwianie programów w języku Rust.
245
246 %package lldb
247 Summary:        LLDB pretty printers for Rust
248 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w LLDB
249 Group:          Development/Debuggers
250 Requires:       %{name}-debugger-common = %{version}-%{release}
251 Requires:       lldb
252 BuildArch:      noarch
253
254 %description lldb
255 This package includes the rust-lldb script, which allows easier
256 debugging of Rust programs.
257
258 %description lldb -l pl.UTF-8
259 Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
260 odpluskwianie programów w języku Rust.
261
262 %package rls
263 Summary:        Rust Language Server for IDE integration
264 Summary(pl.UTF-8):      Rust Language Server do integracji z IDE
265 Group:          Development/Tools
266 Requires:       %{name} = %{version}-%{release}
267 Requires:       %{name}-analysis = %{version}-%{release}
268
269 %description rls
270 Rust Language Server for IDE integration.
271
272 %description rls -l pl.UTF-8
273 Rust Language Server do integracji z IDE.
274
275 %package doc
276 Summary:        Documentation for Rust
277 Summary(pl.UTF-8):      Dokumentacja do Rusta
278 Group:          Documentation
279 BuildArch:      noarch
280
281 %description doc
282 This package includes HTML documentation for the Rust programming
283 language and its standard library.
284
285 %description doc -l pl.UTF-8
286 Ten pakiet zawiera dokumentację w formacie HTML do języka
287 programowania Rust i jego biblioteki standardowej.
288
289 %package -n cargo
290 Summary:        Rust's package manager and build tool
291 Summary(pl.UTF-8):      Zarządca pakietów i narzędzie do budowania
292 Group:          Development/Tools
293 Requires:       %{name}%{?_isa}
294
295 %description -n cargo
296 Cargo is a tool that allows Rust projects to declare their various
297 dependencies and ensure that you'll always get a repeatable build.
298
299 %description -n cargo -l pl.UTF-8
300 Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
301 zależności i zapewniające powtarzalność procesu budowania.
302
303 %package -n bash-completion-cargo
304 Summary:        Bash completion for cargo command
305 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów polecenia cargo
306 Group:          Applications/Shells
307 Requires:       %{name} = %{version}-%{release}
308 Requires:       bash-completion
309
310 %description -n bash-completion-cargo
311 Bash completion for cargo command.
312
313 %description -n bash-completion-cargo -l pl.UTF-8
314 Bashowe dopełnianie parametrów polecenia cargo.
315
316 %package -n zsh-completion-cargo
317 Summary:        Zsh completion for cargo command
318 Summary(pl.UTF-8):      Dopełnianie parametrów polecenia cargo w powłoce Zsh
319 Group:          Applications/Shells
320 Requires:       %{name} = %{version}-%{release}
321 Requires:       zsh
322
323 %description -n zsh-completion-cargo
324 Zsh completion for cargo command.
325
326 %description -n zsh-completion-cargo -l pl.UTF-8
327 Dopełnianie parametrów polecenia cargo w powłoce Zsh.
328
329 %prep
330 %setup -q -n %{rustc_package}
331
332 %if %{with bootstrap}
333 %ifarch %{x8664} x32
334 tar xf %{SOURCE1}
335 %endif
336 %ifarch %{ix86}
337 tar xf %{SOURCE2}
338 %endif
339 %ifarch aarch64
340 tar xf %{SOURCE3}
341 %endif
342 %ifarch armv6hl armv7hl armv7hnl
343 tar xf %{SOURCE4}
344 %endif
345 %{__mv} %{bootstrap_root} %{bootstrap_root}-root
346 %{bootstrap_root}-root/install.sh \
347         --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
348         --prefix=%{local_rust_root} \
349         --disable-ldconfig
350 test -f %{local_rust_root}/bin/cargo
351 test -f %{local_rust_root}/bin/rustc
352 %endif
353
354 # unbundle
355 # We're disabling jemalloc, but rust-src still wants it.
356 #%{__rm} -r src/jemalloc
357 %if %{with system_llvm}
358 %{__rm} -r src/llvm-project
359 mkdir -p src/llvm-project/libunwind
360 %endif
361
362 # extract bundled licenses for packaging
363 sed -e '/*\//q' library/backtrace/crates/backtrace-sys/src/libbacktrace/backtrace.h \
364         >library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
365
366 # rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
367 sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
368         src/etc/rust-gdb
369
370 # The configure macro will modify some autoconf-related files, which upsets
371 # cargo when it tries to verify checksums in those files.  If we just truncate
372 # that file list, cargo won't have anything to complain about.
373 find vendor -name .cargo-checksum.json \
374         -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
375
376 %build
377 %configure \
378         --build=%{rust_bootstrap_triple} \
379         --host=%{rust_host_triple} \
380         --target=%{rust_triple} \
381         --libdir=%{common_libdir} \
382         --disable-codegen-tests \
383         --disable-debuginfo-lines \
384 %if %{with full_debuginfo}
385         --disable-debuginfo-only-std \
386         --enable-debuginfo \
387 %else
388         --enable-debuginfo-only-std \
389         --disable-debuginfo \
390 %endif
391         --disable-jemalloc \
392         --disable-option-checking \
393         --disable-rpath \
394         --enable-extended \
395         --enable-llvm-link-shared \
396         --enable-vendor \
397         --local-rust-root=%{local_rust_root} \
398         --llvm-root=%{_prefix} \
399         --release-channel=%{channel}
400
401 export RUST_BACKTRACE=full
402 %x_py dist --verbose
403
404 %{?with_tests:%x_py test}
405
406 %install
407 rm -rf $RPM_BUILD_ROOT
408
409 export DESTDIR=$RPM_BUILD_ROOT
410 %x_py install
411
412 # Make sure the shared libraries are in the proper libdir
413 %if "%{_libdir}" != "%{common_libdir}"
414 mkdir -p %{buildroot}%{_libdir}
415 find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
416         -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
417 %endif
418
419 # The shared libraries should be executable for debuginfo extraction.
420 find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
421
422 # The libdir libraries are identical to those under rustlib/.  It's easier on
423 # library loading if we keep them in libdir, but we do need them in rustlib/
424 # to support dynamic linking for compiler plugins, so we'll symlink.
425 for l in libstd libtest ; do
426         liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
427         libstd=$RPM_BUILD_ROOT%{rustlibdir}/%{rust_triple}/lib/${l}-*.so
428         if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
429                 ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
430         fi
431 done
432
433 # Remove installer artifacts (manifests, uninstall scripts, etc.)
434 find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
435
436 # FIXME: __os_install_post will strip the rlibs
437 # -- should we find a way to preserve debuginfo?
438
439 # Remove unwanted documentation files (we already package them)
440 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
441 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
442 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
443 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
444
445 # Sanitize the HTML documentation
446 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
447 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
448
449 # Move rust-gdb's python scripts so they're noarch
450 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
451 %{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
452
453 # We don't need stdlib source
454 %{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
455
456 # Create the path for crate-devel packages
457 install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
458
459 %clean
460 rm -rf $RPM_BUILD_ROOT
461
462 %post   -p /sbin/ldconfig
463 %postun -p /sbin/ldconfig
464
465 %files
466 %defattr(644,root,root,755)
467 %doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
468 %attr(755,root,root) %{_bindir}/miri
469 %attr(755,root,root) %{_bindir}/rustc
470 %attr(755,root,root) %{_bindir}/rustdoc
471 %attr(755,root,root) %{_bindir}/rustfmt
472 %attr(755,root,root) %{_libdir}/librustc_driver-*.so
473 %attr(755,root,root) %{_libdir}/libstd-*.so
474 %attr(755,root,root) %{_libdir}/libtest-*.so
475 %{_mandir}/man1/rustc.1*
476 %{_mandir}/man1/rustdoc.1*
477 %dir %{rustlibdir}
478
479 %files analysis
480 %defattr(644,root,root,755)
481 %{rustlibdir}/%{rust_triple}/analysis
482
483 %files std
484 %defattr(644,root,root,755)
485 %dir %{rustlibdir}/%{rust_triple}
486 %dir %{rustlibdir}/%{rust_triple}/lib
487 %attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
488 %{rustlibdir}/%{rust_triple}/lib/*.rlib
489
490 %files analyzer
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{_bindir}/rust-analyzer
493
494 %files debugger-common
495 %defattr(644,root,root,755)
496 %dir %{_datadir}/%{name}
497 %dir %{_datadir}/%{name}/etc
498 %{_datadir}/%{name}/etc/lldb_commands
499 %{_datadir}/%{name}/etc/rust_types.py
500
501 %files lldb
502 %defattr(644,root,root,755)
503 %attr(755,root,root) %{_bindir}/rust-lldb
504 %{_datadir}/%{name}/etc/lldb_*.py*
505
506 %files gdb
507 %defattr(644,root,root,755)
508 %attr(755,root,root) %{_bindir}/rust-gdb
509 %attr(755,root,root) %{_bindir}/rust-gdbgui
510 %{_datadir}/%{name}/etc/gdb_*.py*
511
512 %files rls
513 %defattr(644,root,root,755)
514 %attr(755,root,root) %{_bindir}/rls
515
516 %files doc
517 %defattr(644,root,root,755)
518 %dir %{_docdir}/%{name}
519 %doc %{_docdir}/%{name}/html
520
521 %files -n cargo
522 %defattr(644,root,root,755)
523 %attr(755,root,root) %{_bindir}/cargo
524 %attr(755,root,root) %{_bindir}/cargo-clippy
525 %attr(755,root,root) %{_bindir}/cargo-fmt
526 %attr(755,root,root) %{_bindir}/cargo-miri
527 %attr(755,root,root) %{_bindir}/clippy-driver
528 %attr(755,root,root) %{_libexecdir}/cargo-credential-1password
529 %{_mandir}/man1/cargo*.1*
530 %dir %{_datadir}/cargo
531 %dir %{_datadir}/cargo/registry
532
533 %files -n bash-completion-cargo
534 %defattr(644,root,root,755)
535 %{_sysconfdir}/bash_completion.d/cargo
536
537 %files -n zsh-completion-cargo
538 %defattr(644,root,root,755)
539 %{zsh_compdir}/_cargo
This page took 0.064351 seconds and 4 git commands to generate.