]> git.pld-linux.org Git - packages/rust.git/blob - rust.spec
bump required libgit2 version
[packages/rust.git] / rust.spec
1 # TODO
2 # - consider a rust-std package containing .../rustlib/$target
3 #   This might allow multilib cross-compilation to work naturally.
4 # - package additional tools
5 #
6 # Conditional build:
7 %bcond_with     bootstrap       # bootstrap using precompiled binaries
8 %bcond_with     full_debuginfo  # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
9 %bcond_without  system_llvm     # system LLVM
10 %bcond_with     tests           # build without tests
11
12 # The channel can be stable, beta, or nightly
13 %define         channel         stable
14
15 %if "%{channel}" == "stable"
16 %define         rustc_package   rustc-%{version}-src
17 %else
18 %define         rustc_package   rustc-%{channel}-src
19 %endif
20
21 # To bootstrap from scratch, set the channel and date from src/stage0.txt
22 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23 # or nightly wants some beta-YYYY-MM-DD
24 %define         bootstrap_rust  1.51.0
25 %define         bootstrap_cargo 1.51.0
26 %define         bootstrap_date  2021-03-25
27
28 %ifarch x32
29 %define         with_cross      1
30 %endif
31
32 %if %{without full_debuginfo}
33 %define         _enable_debug_packages  0
34 %endif
35
36 Summary:        The Rust Programming Language
37 Summary(pl.UTF-8):      Język programowania Rust
38 Name:           rust
39 Version:        1.52.0
40 Release:        0.1
41 # Licenses: (rust itself) and (bundled libraries)
42 License:        (Apache v2.0 or MIT) and (BSD and ISC and MIT)
43 Group:          Development/Languages
44 Source0:        https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
45 # Source0-md5:  f95ca614a531b3c1edd4918eaa329732
46 Source1:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
47 # Source1-md5:  7640d6538716c6492e56f361e3af0631
48 Source2:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
49 # Source2-md5:  64f117dc1ae1543c8910eaa9a971ddd4
50 Source3:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
51 # Source3-md5:  3ac79872671df7ea0215fd351f52ffcf
52 Source4:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
53 # Source4-md5:  f624772d7c7ba2e83a51b4e9c1657f7b
54 Patch0:         %{name}-x32.patch
55 URL:            https://www.rust-lang.org/
56 # for src/compiler-rt
57 BuildRequires:  cmake >= 3.4.3
58 BuildRequires:  curl
59 # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
60 BuildRequires:  procps
61 BuildRequires:  python >= 1:2.7
62 BuildRequires:  rpmbuild(macros) >= 1.752
63 %if %{without cross}
64 BuildRequires:  curl-devel
65 BuildRequires:  libgit2-devel >= 1.1.0
66 BuildRequires:  libstdc++-devel
67 %{?with_system_llvm:BuildRequires:      llvm-devel >= 9.0}
68 BuildRequires:  openssl-devel >= 1.0.1
69 BuildRequires:  tar >= 1:1.22
70 BuildRequires:  xz
71 BuildRequires:  zlib-devel
72 %endif
73 %if %{without bootstrap}
74 BuildRequires:  %{name} >= %{bootstrap_rust}
75 BuildRequires:  cargo >= %{bootstrap_cargo}
76 BuildConflicts: %{name} > %{version}
77 %endif
78 %ifarch x32
79 BuildRequires:  glibc-devel(x32)
80 BuildRequires:  glibc-devel(x86_64)
81 %if "%{_host_cpu}" == "x86_64"
82 # building on x86_64 host with --target x32-pld-linux
83 BuildRequires:  curl-devel
84 BuildRequires:  gcc-multilib-x32
85 BuildRequires:  libgit2-devel >= 1.1.0
86 BuildRequires:  libstdc++-devel
87 %{?with_system_llvm:BuildRequires:      llvm-devel >= 9.0}
88 BuildRequires:  openssl-devel >= 1.0.1
89 BuildRequires:  zlib-devel
90 %else
91 # building x86_64-hosted crosscompiler on x32 host
92 BuildRequires:  curl-devel(x86-64)
93 BuildRequires:  gcc-multilib-64
94 BuildRequires:  libgit2-devel(x86-64) >= 1.1.0
95 BuildRequires:  libstdc++-multilib-64-devel
96 %{?with_system_llvm:BuildRequires:      llvm-devel(x86-64) >= 9.0}
97 BuildRequires:  openssl-devel(x86-64)
98 BuildRequires:  zlib-devel(x86-64)
99 %endif
100 %endif
101 # The C compiler is needed at runtime just for linking.  Someday rustc might
102 # invoke the linker directly, and then we'll only need binutils.
103 # https://github.com/rust-lang/rust/issues/11937
104 Requires:       gcc
105 # Only x86_64 and i686 are Tier 1 platforms at this time.
106 # x32 is Tier 2, only rust-std is available (no rustc or cargo).
107 # https://doc.rust-lang.org/nightly/rustc/platform-support.html
108 ExclusiveArch:  %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
109 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
110
111 %ifarch x32
112 %define         rust_triple             x86_64-unknown-linux-gnux32
113 %define         rust_host_triple        x86_64-unknown-linux-gnu
114 %define         rust_bootstrap_triple   x86_64-unknown-linux-gnu
115 %else
116 %ifarch armv6hl armv7hl armv7hnl
117 %define         rust_triple             arm-unknown-linux-gnueabihf
118 %define         rust_host_triple        %{rust_triple}
119 %define         rust_bootstrap_triple   %{rust_triple}
120 %else
121 %define         rust_triple             %{_target_cpu}-unknown-linux-gnu
122 %define         rust_host_triple        %{rust_triple}
123 %define         rust_bootstrap_triple   %{rust_triple}
124 %endif
125 %endif
126
127 %if %{without bootstrap}
128 %define         local_rust_root %{_prefix}
129 %else
130 %define         bootstrap_root  rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
131 %define         local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
132 %endif
133
134 # We're going to override --libdir when configuring to get rustlib into a
135 # common path, but we'll fix the shared libraries during install.
136 # Without this ugly hack, rust would not be able to build itself
137 # for non-bootstrap build, lib64 is just too complicated for it.
138 %define         common_libdir   %{_prefix}/lib
139 %define         rustlibdir      %{common_libdir}/rustlib
140
141 # once_call/once_callable non-function libstdc++ symbols
142 %define         skip_post_check_so      'librustc.*llvm.*\.so.*'
143
144 # ALL Rust libraries are private, because they don't keep an ABI.
145 %define         _noautoreqfiles         lib.*-[[:xdigit:]]{8}[.]so.*
146 %define         _noautoprovfiles        lib.*-[[:xdigit:]]{8}[.]so.*
147
148 %define         x_py { \
149         x_py() { \
150                 local cmd="$1"; \
151                 shift; \
152                 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
153         }; x_py }
154
155
156 %description
157 Rust is a systems programming language that runs blazingly fast,
158 prevents segfaults, and guarantees thread safety.
159
160 This package includes the Rust compiler, standard library, and
161 documentation generator.
162
163 %description -l pl.UTF-8
164 Rust to systemowy język programowania działający bardzo szybko,
165 zapobiegający naruszeniom ochrony pamięci i gwarantujący
166 bezpieczną wielowątkowość.
167
168 %package analyzer
169 Summary:        Implementation of Language Server Protocol for Rust
170 Summary(pl.UTF-8):      Implementacja Language Server Protocol dla Rusta
171 Group:          Development/Tools
172 Requires:       %{name} = %{version}-%{release}
173
174 %description analyzer
175 Implementation of Language Server Protocol for Rust.
176
177 %description analyzer -l pl.UTF-8
178 Implementacja Language Server Protocol dla Rusta.
179
180 %package debugger-common
181 Summary:        Common debugger pretty printers for Rust
182 Summary(pl.UTF-8):      Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
183 Group:          Development/Debuggers
184 BuildArch:      noarch
185
186 %description debugger-common
187 This package includes the common functionality for rust-gdb and
188 rust-lldb.
189
190 %description debugger-common -l pl.UTF-8
191 Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
192
193 %package gdb
194 Summary:        GDB pretty printers for Rust
195 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w GDB
196 Group:          Development/Debuggers
197 Requires:       %{name}-debugger-common = %{version}-%{release}
198 Requires:       gdb
199 BuildArch:      noarch
200
201 %description gdb
202 This package includes the rust-gdb script, which allows easier
203 debugging of Rust programs.
204
205 %description gdb -l pl.UTF-8
206 Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
207 odpluskwianie programów w języku Rust.
208
209 %package lldb
210 Summary:        LLDB pretty printers for Rust
211 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w LLDB
212 Group:          Development/Debuggers
213 Requires:       %{name}-debugger-common = %{version}-%{release}
214 Requires:       lldb
215 BuildArch:      noarch
216
217 %description lldb
218 This package includes the rust-lldb script, which allows easier
219 debugging of Rust programs.
220
221 %description lldb -l pl.UTF-8
222 Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
223 odpluskwianie programów w języku Rust.
224
225 %package rls
226 Summary:        Rust Language Server for IDE integration
227 Summary(pl.UTF-8):      Rust Language Server do integracji z IDE
228 Group:          Development/Tools
229 Requires:       %{name} = %{version}-%{release}
230
231 %description rls
232 Rust Language Server for IDE integration.
233
234 %description rls -l pl.UTF-8
235 Rust Language Server do integracji z IDE.
236
237 %package doc
238 Summary:        Documentation for Rust
239 Summary(pl.UTF-8):      Dokumentacja do Rusta
240 Group:          Documentation
241 BuildArch:      noarch
242
243 %description doc
244 This package includes HTML documentation for the Rust programming
245 language and its standard library.
246
247 %description doc -l pl.UTF-8
248 Ten pakiet zawiera dokumentację w formacie HTML do języka
249 programowania Rust i jego biblioteki standardowej.
250
251 %package -n cargo
252 Summary:        Rust's package manager and build tool
253 Summary(pl.UTF-8):      Zarządca pakietów i narzędzie do budowania
254 Group:          Development/Tools
255 Requires:       %{name}
256
257 %description -n cargo
258 Cargo is a tool that allows Rust projects to declare their various
259 dependencies and ensure that you'll always get a repeatable build.
260
261 %description -n cargo -l pl.UTF-8
262 Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
263 zależności i zapewniające powtarzalność procesu budowania.
264
265 %package -n bash-completion-cargo
266 Summary:        Bash completion for cargo command
267 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów polecenia cargo
268 Group:          Applications/Shells
269 Requires:       %{name} = %{version}-%{release}
270 Requires:       bash-completion
271
272 %description -n bash-completion-cargo
273 Bash completion for cargo command.
274
275 %description -n bash-completion-cargo -l pl.UTF-8
276 Bashowe dopełnianie parametrów polecenia cargo.
277
278 %package -n zsh-completion-cargo
279 Summary:        Zsh completion for cargo command
280 Summary(pl.UTF-8):      Dopełnianie parametrów polecenia cargo w powłoce Zsh
281 Group:          Applications/Shells
282 Requires:       %{name} = %{version}-%{release}
283 Requires:       zsh
284
285 %description -n zsh-completion-cargo
286 Zsh completion for cargo command.
287
288 %description -n zsh-completion-cargo -l pl.UTF-8
289 Dopełnianie parametrów polecenia cargo w powłoce Zsh.
290
291 %prep
292 %setup -q -n %{rustc_package}
293 # irrelevant when not building rustc for x32
294 #%%patch0 -p1
295
296 %if %{with bootstrap}
297 %ifarch %{x8664} x32
298 tar xf %{SOURCE1}
299 %endif
300 %ifarch %{ix86}
301 tar xf %{SOURCE2}
302 %endif
303 %ifarch aarch64
304 tar xf %{SOURCE3}
305 %endif
306 %ifarch armv6hl armv7hl armv7hnl
307 tar xf %{SOURCE4}
308 %endif
309 %{__mv} %{bootstrap_root} %{bootstrap_root}-root
310 %{bootstrap_root}-root/install.sh \
311         --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
312         --prefix=%{local_rust_root} \
313         --disable-ldconfig
314 test -f %{local_rust_root}/bin/cargo
315 test -f %{local_rust_root}/bin/rustc
316 %endif
317
318 # unbundle
319 # We're disabling jemalloc, but rust-src still wants it.
320 #%{__rm} -r src/jemalloc
321 %if %{with system_llvm}
322 %{__rm} -r src/llvm-project
323 mkdir -p src/llvm-project/libunwind
324 %endif
325
326 # extract bundled licenses for packaging
327 sed -e '/*\//q' library/backtrace/crates/backtrace-sys/src/libbacktrace/backtrace.h \
328         >library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
329
330 # rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
331 sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
332         src/etc/rust-gdb
333
334 # The configure macro will modify some autoconf-related files, which upsets
335 # cargo when it tries to verify checksums in those files.  If we just truncate
336 # that file list, cargo won't have anything to complain about.
337 find vendor -name .cargo-checksum.json \
338         -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
339
340 %build
341 %configure \
342         --build=%{rust_bootstrap_triple} \
343         --host=%{rust_host_triple} \
344         --target=%{rust_triple} \
345         --libdir=%{common_libdir} \
346         --disable-codegen-tests \
347         --disable-debuginfo-lines \
348 %if %{with full_debuginfo}
349         --disable-debuginfo-only-std \
350         --enable-debuginfo \
351 %else
352         --enable-debuginfo-only-std \
353         --disable-debuginfo \
354 %endif
355         --disable-jemalloc \
356         --disable-option-checking \
357         --disable-rpath \
358         --enable-extended \
359         --enable-llvm-link-shared \
360         --enable-vendor \
361         --local-rust-root=%{local_rust_root} \
362         --llvm-root=%{_prefix} \
363         --release-channel=%{channel}
364
365 export RUST_BACKTRACE=full
366 %x_py dist --verbose
367
368 %{?with_tests:%x_py test}
369
370 %install
371 rm -rf $RPM_BUILD_ROOT
372
373 export DESTDIR=$RPM_BUILD_ROOT
374 %x_py install
375
376 # Make sure the shared libraries are in the proper libdir
377 %if "%{_libdir}" != "%{common_libdir}"
378 mkdir -p %{buildroot}%{_libdir}
379 find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
380         -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
381 %endif
382
383 # The shared libraries should be executable for debuginfo extraction.
384 find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
385
386 # The libdir libraries are identical to those under rustlib/.  It's easier on
387 # library loading if we keep them in libdir, but we do need them in rustlib/
388 # to support dynamic linking for compiler plugins, so we'll symlink.
389 (cd "$RPM_BUILD_ROOT%{rustlibdir}/%{rust_triple}/lib" &&
390         find ../../../../%{_lib} -maxdepth 1 -name '*.so' \
391         -exec ln -v -f -s -t . '{}' '+')
392
393 # Remove installer artifacts (manifests, uninstall scripts, etc.)
394 find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
395
396 # FIXME: __os_install_post will strip the rlibs
397 # -- should we find a way to preserve debuginfo?
398
399 # Remove unwanted documentation files (we already package them)
400 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
401 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
402 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
403 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
404
405 # Sanitize the HTML documentation
406 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
407 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
408
409 # Move rust-gdb's python scripts so they're noarch
410 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
411 %{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
412
413 # We don't need stdlib source
414 %{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
415
416 # Create the path for crate-devel packages
417 install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
418
419 %clean
420 rm -rf $RPM_BUILD_ROOT
421
422 %post   -p /sbin/ldconfig
423 %postun -p /sbin/ldconfig
424
425 %files
426 %defattr(644,root,root,755)
427 %doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
428 %attr(755,root,root) %{_bindir}/miri
429 %attr(755,root,root) %{_bindir}/rustc
430 %attr(755,root,root) %{_bindir}/rustdoc
431 %attr(755,root,root) %{_bindir}/rustfmt
432 %attr(755,root,root) %{_libdir}/librustc*-*.so
433 %attr(755,root,root) %{_libdir}/libstd-*.so
434 %attr(755,root,root) %{_libdir}/libtest-*.so
435 %{_mandir}/man1/rustc.1*
436 %{_mandir}/man1/rustdoc.1*
437 %dir %{rustlibdir}
438 %dir %{rustlibdir}/%{rust_triple}
439 %{rustlibdir}/%{rust_triple}/analysis
440 %dir %{rustlibdir}/%{rust_triple}/lib
441 %attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
442 %{rustlibdir}/%{rust_triple}/lib/*.rlib
443
444 %files analyzer
445 %defattr(644,root,root,755)
446 %attr(755,root,root) %{_bindir}/rust-analyzer
447
448 %files debugger-common
449 %defattr(644,root,root,755)
450 %dir %{_datadir}/%{name}
451 %dir %{_datadir}/%{name}/etc
452 %{_datadir}/%{name}/etc/lldb_commands
453 %{_datadir}/%{name}/etc/rust_types.py
454
455 %files lldb
456 %defattr(644,root,root,755)
457 %attr(755,root,root) %{_bindir}/rust-lldb
458 %{_datadir}/%{name}/etc/lldb_*.py*
459
460 %files gdb
461 %defattr(644,root,root,755)
462 %attr(755,root,root) %{_bindir}/rust-gdb
463 %attr(755,root,root) %{_bindir}/rust-gdbgui
464 %{_datadir}/%{name}/etc/gdb_*.py*
465
466 %files rls
467 %defattr(644,root,root,755)
468 %attr(755,root,root) %{_bindir}/rls
469
470 %files doc
471 %defattr(644,root,root,755)
472 %dir %{_docdir}/%{name}
473 %doc %{_docdir}/%{name}/html
474
475 %files -n cargo
476 %defattr(644,root,root,755)
477 %attr(755,root,root) %{_bindir}/cargo
478 %attr(755,root,root) %{_bindir}/cargo-clippy
479 %attr(755,root,root) %{_bindir}/cargo-fmt
480 %attr(755,root,root) %{_bindir}/cargo-miri
481 %attr(755,root,root) %{_bindir}/clippy-driver
482 %attr(755,root,root) %{_libexecdir}/cargo-credential-1password
483 %{_mandir}/man1/cargo*.1*
484 %dir %{_datadir}/cargo
485 %dir %{_datadir}/cargo/registry
486
487 %files -n bash-completion-cargo
488 %defattr(644,root,root,755)
489 %{_sysconfdir}/bash_completion.d/cargo
490
491 %files -n zsh-completion-cargo
492 %defattr(644,root,root,755)
493 %{zsh_compdir}/_cargo
This page took 0.145071 seconds and 4 git commands to generate.