]> git.pld-linux.org Git - packages/rust.git/blame - rust.spec
- requires gcc-multilib-64 on x32 for proper cross compiling, rel 4
[packages/rust.git] / rust.spec
CommitLineData
e361528e
ER
1# TODO
2# - consider a rust-std package containing .../rustlib/$target
3# This might allow multilib cross-compilation to work naturally.
8a758d34 4# - package additional tools
e361528e
ER
5#
6# Conditional build:
e8f16183 7%bcond_with bootstrap # bootstrap using precompiled binaries
398b58dd 8%bcond_with full_debuginfo # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
5b9d67b0 9%bcond_without system_llvm # system LLVM
cace5bf9 10%bcond_with tests # build without tests
e361528e 11
8a073211
JR
12# The channel can be stable, beta, or nightly
13%define channel stable
14
e361528e 15%if "%{channel}" == "stable"
8a073211 16%define rustc_package rustc-%{version}-src
e361528e 17%else
8a073211 18%define rustc_package rustc-%{channel}-src
e361528e
ER
19%endif
20
fc3be51a 21# To bootstrap from scratch, set the channel and date from src/stage0.json
e361528e
ER
22# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23# or nightly wants some beta-YYYY-MM-DD
aea1d260
JP
24%define bootstrap_rust 1.57.0
25%define bootstrap_cargo %{bootstrap_rust}
26%define bootstrap_date 2021-12-02
e361528e 27
badbe44d 28%ifarch x32
2eb30149 29%define with_cross 1
badbe44d 30%endif
c19e7faa
JP
31
32%if %{without full_debuginfo}
33%define _enable_debug_packages 0
34%endif
35
e361528e 36Summary: The Rust Programming Language
e8f16183 37Summary(pl.UTF-8): Język programowania Rust
e361528e 38Name: rust
5c688b54 39Version: 1.58.1
417178e1 40Release: 4
d1b96fd8 41# Licenses: (rust itself) and (bundled libraries)
e8f16183 42License: (Apache v2.0 or MIT) and (BSD and ISC and MIT)
e361528e 43Group: Development/Languages
be28e1f1 44Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
5c688b54 45# Source0-md5: 835e82d659ea4fc19fd1f0888de01ad8
be28e1f1 46Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
aea1d260 47# Source1-md5: 0f58dba84eba1a5ab8ec51f52d95f453
be28e1f1 48Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
aea1d260 49# Source2-md5: d75c7b995614c6ffa8df4409e64a13d6
9eb0511e 50Source3: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
aea1d260 51# Source3-md5: 7ba95696643b96b765b7ef5179cba8a4
1fe729c8 52Source4: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
aea1d260 53# Source4-md5: 50ab0a0c6f4dc386e09616778e92a934
ad044650 54Source5: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
aea1d260 55# Source5-md5: d79e80ff8677da71154b326f51ea39ee
e361528e 56URL: https://www.rust-lang.org/
e8f16183
JB
57# for src/compiler-rt
58BuildRequires: cmake >= 3.4.3
e361528e 59BuildRequires: curl
2eb30149
JB
60# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
61BuildRequires: procps
e65d284f
JP
62BuildRequires: python3
63BuildRequires: python3-modules
fc3be51a 64BuildRequires: rpm-build >= 4.6
2eb30149
JB
65BuildRequires: rpmbuild(macros) >= 1.752
66%if %{without cross}
8f176645 67BuildRequires: curl-devel
2983f519 68BuildRequires: libgit2-devel >= 1.3.0
d1b96fd8 69BuildRequires: libstdc++-devel
2cec66d3 70%if %{with system_llvm}
aea1d260
JP
71BuildRequires: llvm >= 12.0
72BuildRequires: llvm-devel >= 12.0
2cec66d3 73%endif
7da6653d 74BuildRequires: openssl-devel >= 1.0.1
8a54bb92
JP
75BuildRequires: tar >= 1:1.22
76BuildRequires: xz
e361528e 77BuildRequires: zlib-devel
2eb30149 78%endif
e361528e 79%if %{without bootstrap}
d6d4cb2b 80BuildRequires: %{name} >= %{bootstrap_rust}
d1b96fd8 81BuildRequires: cargo >= %{bootstrap_cargo}
ff5a5e0b 82BuildConflicts: %{name} > %{version}
e361528e 83%endif
2eb30149 84%ifarch x32
cd0c1484
JR
85BuildRequires: glibc-devel(x86-64)
86BuildRequires: glibc-devel(x86-x32)
2eb30149
JB
87%if "%{_host_cpu}" == "x86_64"
88# building on x86_64 host with --target x32-pld-linux
8f176645 89BuildRequires: curl-devel
2eb30149 90BuildRequires: gcc-multilib-x32
2983f519 91BuildRequires: libgit2-devel >= 1.3.0
2eb30149 92BuildRequires: libstdc++-devel
aea1d260 93%{?with_system_llvm:BuildRequires: llvm-devel >= 12.0}
2eb30149
JB
94BuildRequires: openssl-devel >= 1.0.1
95BuildRequires: zlib-devel
96%else
97# building x86_64-hosted crosscompiler on x32 host
56b25e8b 98BuildRequires: curl-devel(x86-64)
cd0c1484 99BuildRequires: curl-devel(x86-x32)
2eb30149 100BuildRequires: gcc-multilib-64
2983f519
JR
101BuildRequires: libgit2-devel(x86-64) >= 1.3.0
102BuildRequires: libgit2-devel(x86-x32) >= 1.3.0
2eb30149 103BuildRequires: libstdc++-multilib-64-devel
cd0c1484 104%if %{with system_llvm}
aea1d260
JP
105BuildRequires: llvm-devel(x86-64) >= 12.0
106BuildRequires: llvm-devel(x86-x32) >= 12.0
cd0c1484 107%endif
56b25e8b 108BuildRequires: openssl-devel(x86-64)
cd0c1484 109BuildRequires: openssl-devel(x86-x32)
56b25e8b 110BuildRequires: zlib-devel(x86-64)
cd0c1484 111BuildRequires: zlib-devel(x86-x32)
2eb30149
JB
112%endif
113%endif
e361528e
ER
114# The C compiler is needed at runtime just for linking. Someday rustc might
115# invoke the linker directly, and then we'll only need binutils.
116# https://github.com/rust-lang/rust/issues/11937
117Requires: gcc
cd0c1484
JR
118Requires: %{name}-std%{?_isa} = %{version}-%{release}
119%ifarch x32
120Requires: %{name}-std(x86-64) = %{version}-%{release}
417178e1 121Requires: gcc-multilib-64
cd0c1484 122%endif
b8711561 123Obsoletes: rust-analyzer < 1.53.0
e361528e 124# Only x86_64 and i686 are Tier 1 platforms at this time.
badbe44d 125# x32 is Tier 2, only rust-std is available (no rustc or cargo).
4f433f76 126# https://doc.rust-lang.org/nightly/rustc/platform-support.html
1fe729c8 127ExclusiveArch: %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
6ed79af8 128BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
e361528e 129
e064fbd0 130%ifarch x32
badbe44d 131%define rust_triple x86_64-unknown-linux-gnux32
2eb30149 132%define rust_host_triple x86_64-unknown-linux-gnu
badbe44d 133%define rust_bootstrap_triple x86_64-unknown-linux-gnu
a973dc7e
JR
134# libs in _libdir are x86_64 64bit
135%define _lib lib64
136%define _libdir %{_prefix}/lib64
e064fbd0 137%else
ad044650 138%ifarch armv6hl
1fe729c8
JP
139%define rust_triple arm-unknown-linux-gnueabihf
140%define rust_host_triple %{rust_triple}
141%define rust_bootstrap_triple %{rust_triple}
142%else
ad044650
JP
143%ifarch armv7hl armv7hnl
144%define rust_triple armv7-unknown-linux-gnueabihf
145%define rust_host_triple %{rust_triple}
146%define rust_bootstrap_triple %{rust_triple}
6c4856ce 147%define rust_suppl_targets thumbv7neon-unknown-linux-gnueabihf
ad044650 148%else
badbe44d 149%define rust_triple %{_target_cpu}-unknown-linux-gnu
2eb30149
JB
150%define rust_host_triple %{rust_triple}
151%define rust_bootstrap_triple %{rust_triple}
e064fbd0 152%endif
1fe729c8 153%endif
ad044650 154%endif
e361528e 155
62473c95
JP
156%define rust_targets %rust_triple %{?rust_suppl_targets}
157
e361528e 158%if %{without bootstrap}
8a073211 159%define local_rust_root %{_prefix}
e361528e 160%else
badbe44d 161%define bootstrap_root rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
8a073211 162%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
e361528e
ER
163%endif
164
18a1004b
JR
165# We're going to override --libdir when configuring to get rustlib into a
166# common path, but we'll fix the shared libraries during install.
5b9d67b0 167# Without this ugly hack, rust would not be able to build itself
18a1004b
JR
168# for non-bootstrap build, lib64 is just too complicated for it.
169%define common_libdir %{_prefix}/lib
170%define rustlibdir %{common_libdir}/rustlib
171
19f98749 172# once_call/once_callable non-function libstdc++ symbols
8f4c23f4 173%define skip_post_check_so 'librustc.*llvm.*\.so.*'
19f98749 174
e361528e 175# ALL Rust libraries are private, because they don't keep an ABI.
8a073211
JR
176%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
177%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
e361528e 178
37765656
JP
179%define x_py { \
180 x_py() { \
181 local cmd="$1"; \
182 shift; \
e65d284f 183 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }%{__python3} ./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
37765656
JP
184 }; x_py }
185
186
e361528e
ER
187%description
188Rust is a systems programming language that runs blazingly fast,
189prevents segfaults, and guarantees thread safety.
190
191This package includes the Rust compiler, standard library, and
192documentation generator.
193
e8f16183
JB
194%description -l pl.UTF-8
195Rust to systemowy język programowania działający bardzo szybko,
196zapobiegający naruszeniom ochrony pamięci i gwarantujący
197bezpieczną wielowątkowość.
198
cd0c1484
JR
199%package analysis
200Summary: Metadata about the standard library
201Summary(pl.UTF-8): Metadane o standardowej bibliotece
202Group: Development/Tools
89a1e043 203Requires: %{name} = %{version}-%{release}
cd0c1484
JR
204
205%description analysis
206Metadata about the standard library.
207
208%description analysis -l pl.UTF-8
209Metadane o standardowej bibliotece.
210
211%package std
212Summary: Standard library for Rust
213Summary(pl.UTF-8): Standardowa biblioteka Rusta
214Group: Development/Tools
89a1e043 215Requires: %{name} = %{version}-%{release}
cd0c1484
JR
216
217%description std
218Standard library for Rust.
219
220%description std -l pl.UTF-8
221Standardowa biblioteka Rusta.
222
d1b96fd8
JR
223%package debugger-common
224Summary: Common debugger pretty printers for Rust
e8f16183 225Summary(pl.UTF-8): Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
d1b96fd8 226Group: Development/Debuggers
e67020b3 227BuildArch: noarch
d1b96fd8
JR
228
229%description debugger-common
e8f16183
JB
230This package includes the common functionality for rust-gdb and
231rust-lldb.
232
233%description debugger-common -l pl.UTF-8
234Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
d1b96fd8 235
e361528e
ER
236%package gdb
237Summary: GDB pretty printers for Rust
e8f16183 238Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w GDB
d1b96fd8
JR
239Group: Development/Debuggers
240Requires: %{name}-debugger-common = %{version}-%{release}
e361528e 241Requires: gdb
e67020b3 242BuildArch: noarch
e361528e
ER
243
244%description gdb
245This package includes the rust-gdb script, which allows easier
246debugging of Rust programs.
247
e8f16183
JB
248%description gdb -l pl.UTF-8
249Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
250odpluskwianie programów w języku Rust.
251
d1b96fd8
JR
252%package lldb
253Summary: LLDB pretty printers for Rust
e8f16183 254Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w LLDB
d1b96fd8
JR
255Group: Development/Debuggers
256Requires: %{name}-debugger-common = %{version}-%{release}
257Requires: lldb
e67020b3 258BuildArch: noarch
d1b96fd8
JR
259
260%description lldb
261This package includes the rust-lldb script, which allows easier
262debugging of Rust programs.
263
e8f16183
JB
264%description lldb -l pl.UTF-8
265Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
266odpluskwianie programów w języku Rust.
267
a7fda0f8
JP
268%package rls
269Summary: Rust Language Server for IDE integration
270Summary(pl.UTF-8): Rust Language Server do integracji z IDE
271Group: Development/Tools
89a1e043
JR
272Requires: %{name} = %{version}-%{release}
273Requires: %{name}-analysis = %{version}-%{release}
a7fda0f8
JP
274
275%description rls
276Rust Language Server for IDE integration.
277
278%description rls -l pl.UTF-8
279Rust Language Server do integracji z IDE.
280
e361528e
ER
281%package doc
282Summary: Documentation for Rust
e8f16183 283Summary(pl.UTF-8): Dokumentacja do Rusta
d1b96fd8 284Group: Documentation
e67020b3 285BuildArch: noarch
e361528e
ER
286
287%description doc
288This package includes HTML documentation for the Rust programming
289language and its standard library.
290
e8f16183
JB
291%description doc -l pl.UTF-8
292Ten pakiet zawiera dokumentację w formacie HTML do języka
293programowania Rust i jego biblioteki standardowej.
294
8a758d34
JP
295%package -n cargo
296Summary: Rust's package manager and build tool
297Summary(pl.UTF-8): Zarządca pakietów i narzędzie do budowania
298Group: Development/Tools
cd0c1484 299Requires: %{name}%{?_isa}
8a758d34
JP
300
301%description -n cargo
302Cargo is a tool that allows Rust projects to declare their various
303dependencies and ensure that you'll always get a repeatable build.
304
305%description -n cargo -l pl.UTF-8
306Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
307zależności i zapewniające powtarzalność procesu budowania.
308
6ed79af8
JB
309%package -n bash-completion-cargo
310Summary: Bash completion for cargo command
311Summary(pl.UTF-8): Bashowe dopełnianie parametrów polecenia cargo
312Group: Applications/Shells
313Requires: %{name} = %{version}-%{release}
314Requires: bash-completion
315
316%description -n bash-completion-cargo
317Bash completion for cargo command.
318
319%description -n bash-completion-cargo -l pl.UTF-8
320Bashowe dopełnianie parametrów polecenia cargo.
321
8a758d34
JP
322%package -n zsh-completion-cargo
323Summary: Zsh completion for cargo command
324Summary(pl.UTF-8): Dopełnianie parametrów polecenia cargo w powłoce Zsh
325Group: Applications/Shells
326Requires: %{name} = %{version}-%{release}
6ed79af8 327Requires: zsh
8a758d34
JP
328
329%description -n zsh-completion-cargo
330Zsh completion for cargo command.
331
332%description -n zsh-completion-cargo -l pl.UTF-8
333Dopełnianie parametrów polecenia cargo w powłoce Zsh.
334
e361528e
ER
335%prep
336%setup -q -n %{rustc_package}
b5eceb5e 337
e361528e 338%if %{with bootstrap}
a1735efb 339%ifarch %{x8664} x32
e361528e
ER
340tar xf %{SOURCE1}
341%endif
342%ifarch %{ix86}
343tar xf %{SOURCE2}
344%endif
c160f211 345%ifarch aarch64
9eb0511e 346tar xf %{SOURCE3}
c160f211 347%endif
ad044650 348%ifarch armv6hl
1fe729c8
JP
349tar xf %{SOURCE4}
350%endif
ad044650
JP
351%ifarch armv7hl armv7hnl
352tar xf %{SOURCE5}
353%endif
d6d4cb2b
JR
354%{__mv} %{bootstrap_root} %{bootstrap_root}-root
355%{bootstrap_root}-root/install.sh \
badbe44d 356 --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
d6d4cb2b
JR
357 --prefix=%{local_rust_root} \
358 --disable-ldconfig
359test -f %{local_rust_root}/bin/cargo
e361528e
ER
360test -f %{local_rust_root}/bin/rustc
361%endif
362
363# unbundle
d4b51567 364# We're disabling jemalloc, but rust-src still wants it.
5b9d67b0 365#%{__rm} -r src/jemalloc
9e7854c5
JP
366%if %{with system_llvm}
367%{__rm} -r src/llvm-project
368mkdir -p src/llvm-project/libunwind
369%endif
e361528e 370
e361528e
ER
371# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
372sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
373 src/etc/rust-gdb
374
4b354bd7
JB
375# cargo has hardcoded libexec path - honour rpm _libexecdir
376%if "%{_libexecdir}" != "%{_prefix}/libexec"
377suffix="%(echo "%{_libexecdir}" | %{__sed} -e 's,^%{_prefix}/,,')"
378%{__sed} -i -e 's,"libexec","'${suffix}'",' \
379 src/bootstrap/dist.rs \
380 src/tools/cargo/src/cargo/ops/registry/auth.rs
381%{__sed} -i -e 's,libexec/,'${suffix}'/,' src/tools/cargo/tests/testsuite/credential_process.rs
382%endif
383
5ee06aa0
JR
384# The configure macro will modify some autoconf-related files, which upsets
385# cargo when it tries to verify checksums in those files. If we just truncate
386# that file list, cargo won't have anything to complain about.
fe49e3fc 387find vendor -name .cargo-checksum.json \
5ee06aa0 388 -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
e361528e 389
e361528e 390%build
863a59ff
JP
391export CC="%{__cc}"
392export CXX="%{__cxx}"
393export AR="%{__ar}"
e361528e 394%configure \
2eb30149
JB
395 --build=%{rust_bootstrap_triple} \
396 --host=%{rust_host_triple} \
62473c95 397 --target="%(echo %rust_targets | tr ' ' ,)" \
18a1004b 398 --libdir=%{common_libdir} \
e8f16183 399 --disable-codegen-tests \
5ee06aa0 400 --disable-debuginfo-lines \
5b9d67b0 401%if %{with full_debuginfo}
5ee06aa0 402 --disable-debuginfo-only-std \
e361528e 403 --enable-debuginfo \
5b9d67b0
JB
404%else
405 --enable-debuginfo-only-std \
406 --disable-debuginfo \
407%endif
6ed79af8
JB
408 --disable-jemalloc \
409 --disable-option-checking \
410 --disable-rpath \
8a758d34 411 --enable-extended \
e8f16183 412 --enable-llvm-link-shared \
d6d4cb2b 413 --enable-vendor \
6ed79af8 414 --local-rust-root=%{local_rust_root} \
e8f16183 415 --llvm-root=%{_prefix} \
e361528e
ER
416 --release-channel=%{channel}
417
37765656
JP
418export RUST_BACKTRACE=full
419%x_py dist --verbose
e361528e 420
37765656 421%{?with_tests:%x_py test}
8a073211 422
e361528e
ER
423%install
424rm -rf $RPM_BUILD_ROOT
e361528e 425
13ab0532
JP
426export CC="%{__cc}"
427export CXX="%{__cxx}"
428export AR="%{__ar}"
37765656
JP
429export DESTDIR=$RPM_BUILD_ROOT
430%x_py install
e361528e 431
18a1004b
JR
432# Make sure the shared libraries are in the proper libdir
433%if "%{_libdir}" != "%{common_libdir}"
434mkdir -p %{buildroot}%{_libdir}
435find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
436 -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
437%endif
438
d1b96fd8 439# The shared libraries should be executable for debuginfo extraction.
e361528e
ER
440find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
441
d1b96fd8
JR
442# The libdir libraries are identical to those under rustlib/. It's easier on
443# library loading if we keep them in libdir, but we do need them in rustlib/
444# to support dynamic linking for compiler plugins, so we'll symlink.
62473c95
JP
445for rust_target in %rust_targets; do
446 for l in libstd libtest ; do
447 liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
448 libstd=$RPM_BUILD_ROOT%{rustlibdir}/${rust_target}/lib/${l}-*.so
449 if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
450 ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
451 fi
452 done
a973dc7e 453done
d1b96fd8
JR
454
455# Remove installer artifacts (manifests, uninstall scripts, etc.)
18a1004b 456find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
e361528e
ER
457
458# FIXME: __os_install_post will strip the rlibs
459# -- should we find a way to preserve debuginfo?
460
461# Remove unwanted documentation files (we already package them)
e8f16183
JB
462%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
463%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
464%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
465%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
e361528e
ER
466
467# Sanitize the HTML documentation
468find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
469find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
470
471# Move rust-gdb's python scripts so they're noarch
472install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
e8f16183 473%{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
e361528e 474
4f353dba
JR
475# We don't need stdlib source
476%{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
477
1dd26160
JP
478# Create the path for crate-devel packages
479install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
480
e361528e
ER
481%clean
482rm -rf $RPM_BUILD_ROOT
483
484%post -p /sbin/ldconfig
485%postun -p /sbin/ldconfig
486
487%files
488%defattr(644,root,root,755)
16ea23d8 489%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md
1736a047 490%attr(755,root,root) %{_bindir}/rust-demangler
e361528e
ER
491%attr(755,root,root) %{_bindir}/rustc
492%attr(755,root,root) %{_bindir}/rustdoc
6ed79af8 493%attr(755,root,root) %{_bindir}/rustfmt
a973dc7e 494%attr(755,root,root) %{_libdir}/librustc_driver-*.so
e8f16183 495%attr(755,root,root) %{_libdir}/libstd-*.so
e8f16183 496%attr(755,root,root) %{_libdir}/libtest-*.so
e361528e
ER
497%{_mandir}/man1/rustc.1*
498%{_mandir}/man1/rustdoc.1*
18a1004b 499%dir %{rustlibdir}
cd0c1484
JR
500
501%files analysis
502%defattr(644,root,root,755)
62473c95
JP
503%(for rust_target in %rust_targets; do
504echo "%{rustlibdir}/$rust_target/analysis"
505done
506)
cd0c1484
JR
507
508%files std
509%defattr(644,root,root,755)
62473c95
JP
510%(for rust_target in %rust_targets; do
511cat <<EOF
512%dir %{rustlibdir}/$rust_target
513%dir %{rustlibdir}/$rust_target/lib
514%attr(755,root,root) %{rustlibdir}/$rust_target/lib/*.so
515%{rustlibdir}/$rust_target/lib/*.rlib
516EOF
517done
518)
df90c046 519%ifnarch x32
f78840a2 520%dir %{rustlibdir}/%{rust_triple}/bin
1736a047 521%attr(755,root,root) %{rustlibdir}/%{rust_triple}/bin/rust-llvm-dwp
df90c046 522%endif
e361528e 523
d1b96fd8
JR
524%files debugger-common
525%defattr(644,root,root,755)
526%dir %{_datadir}/%{name}
527%dir %{_datadir}/%{name}/etc
5aae056c
JP
528%{_datadir}/%{name}/etc/lldb_commands
529%{_datadir}/%{name}/etc/rust_types.py
d1b96fd8
JR
530
531%files lldb
532%defattr(644,root,root,755)
533%attr(755,root,root) %{_bindir}/rust-lldb
534%{_datadir}/%{name}/etc/lldb_*.py*
535
e361528e
ER
536%files gdb
537%defattr(644,root,root,755)
538%attr(755,root,root) %{_bindir}/rust-gdb
fe49e3fc 539%attr(755,root,root) %{_bindir}/rust-gdbgui
d1b96fd8 540%{_datadir}/%{name}/etc/gdb_*.py*
e361528e 541
a7fda0f8
JP
542%files rls
543%defattr(644,root,root,755)
544%attr(755,root,root) %{_bindir}/rls
545
e361528e
ER
546%files doc
547%defattr(644,root,root,755)
548%dir %{_docdir}/%{name}
d1b96fd8 549%doc %{_docdir}/%{name}/html
8a758d34
JP
550
551%files -n cargo
552%defattr(644,root,root,755)
553%attr(755,root,root) %{_bindir}/cargo
6ed79af8
JB
554%attr(755,root,root) %{_bindir}/cargo-clippy
555%attr(755,root,root) %{_bindir}/cargo-fmt
556%attr(755,root,root) %{_bindir}/clippy-driver
8a54bb92 557%attr(755,root,root) %{_libexecdir}/cargo-credential-1password
8a758d34
JP
558%{_mandir}/man1/cargo*.1*
559%dir %{_datadir}/cargo
560%dir %{_datadir}/cargo/registry
561
562%files -n bash-completion-cargo
563%defattr(644,root,root,755)
564%{_sysconfdir}/bash_completion.d/cargo
565
566%files -n zsh-completion-cargo
567%defattr(644,root,root,755)
568%{zsh_compdir}/_cargo
This page took 0.118341 seconds and 4 git commands to generate.